Bug 294160 - Provide "on all activities"-button
Summary: Provide "on all activities"-button
Status: RESOLVED INTENTIONAL
Alias: None
Product: kwin
Classification: Plasma
Component: decorations (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on: 295687
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 16:27 UTC by S. Burmeister
Modified: 2015-01-05 14:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2012-02-15 16:27:06 UTC
Version:           unspecified (using KDE 4.8.0) 
OS:                Linux

Since activities kind of are supposed to replace virtual desktops, the windeco should get a button to make windows appear on all activities. Currently there is only a button to make them appear on all virtual desktops.

Reproducible: Always

Steps to Reproduce:
Go to the "buttons for titlebar" settings

Actual Results:  
No button for "show window on all activities" but only a button for "show on all desktops"

Expected Results:  
Button as described above
Comment 1 Hugo Pereira Da Costa 2012-02-15 16:32:33 UTC
Reassigning to kwin
Comment 2 Martin Flöser 2015-01-05 14:18:19 UTC
wasn't considered to be added to the new decoration API. A toggle button does not reflect the switching for activities.