Bug 293893 - Useless error messages
Summary: Useless error messages
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 12:13 UTC by Michael Holtermann
Modified: 2017-01-07 22:20 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Log from akonadi_imap_resource, remote service is GoogleMail (11.22 KB, text/plain)
2012-02-12 12:13 UTC, Michael Holtermann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Holtermann 2012-02-12 12:13:08 UTC
Created attachment 68726 [details]
Log from akonadi_imap_resource, remote service is GoogleMail

Version:           4.7 (using KDE 4.7.4) 
OS:                Linux

Hi folks,

today one of my Akonadi agents stops working - the agent fetches GoogleMail via IMAP. On every sync I'll get a notification saying "Unable to list item parts".

This message (like many others, like "NO unkown namespace") is pretty useless for the unambitious, normal user. There is no guidance available in how to solve such issues.

The Akonadi Console, a developer tool displaying frightening warnings wen started, names the error as Unknown Error:

"AgentBase(akonadi_imap_resource_9): Unbekannter Fehler. (Unable to list item parts)"

How can I solve the error of "Unable to list item parts"?

For details I'll attach the debug output from Akonadi Console of that resource.

I'm sorry that I have to say that, but currently I'm very dissatisfied with Akonadi. Akonadi is a vital part of KDE. KOrganizer depends on it; if Akonadi fails, the PIM suite fails, too. Akonadi should be much more fault tolerant if the remote resources does not work as expected, or should guide the user to the current settings if client's config is faulty. In my opinion, Akonadi is far away from being "rock solid".




Reproducible: Always

Steps to Reproduce:
at least on my machine.

Actual Results:  
- A useless error message without any advice about a possible fix.

- A software (Akonadi) producing new errors once a month, while user has not changed anything in his settings.

Expected Results:  
- A link to a FAQ, or at least a FAQ or answer that could by found by Google. The first link on Google is a link to a diff where 'mwolff' inserts that Exception into Akonadi.

- If a serious exception occurs, Akonadi should no longer try to fetch that resource over and over again (my sync interval is 1 minute). It might lenghten the interval, but after a few tries it should notifiy the user *once*.
Comment 1 Alexandre Bonneau 2012-04-20 16:39:58 UTC
I agree, Akonadi is really *not* rock solid.
Akonadi users are really lenient about its ability to break when sneezing.

Today for instance Akonadi just repeated over and over that a maildir folder didn't exist until I stopped Akonadi, Nepomuk, then the whole Kde session. No I have that problem mentioned in bug #289097 to solve.

Please make Akonadi more fault tolerant.
Comment 2 Nick Leverton 2012-05-15 13:09:17 UTC
Both errors confirmed here.  Our Exchange server is hopelessly unreliable (well what would you expect) and the admins restart it on a whim, sometimes several times a day.  Every time they do, my DIMAP Akonadi resources either silently become disconnected and never reconnect, or loudly squirt out a dozen errors every minute.  I'm not sure which is worse but neither is good :-(
Comment 3 Christophe Marin 2012-05-18 21:01:16 UTC
(In reply to comment #2)
>  Every time they do, my DIMAP Akonadi resources either
> silently become disconnected and never reconnect, or loudly squirt out a
> dozen errors every minute.  [...]

which KDE version ? Make sure you use a recent one
Comment 4 Nick Leverton 2012-05-31 08:21:11 UTC
Currently on 4.8.3, and have been generally tracking KDE stable via Ubuntu kde PPA.
We only got the (ptui) exchange server recently so I can't go back much before 4.7.2 but this issue is certainly current.
Comment 5 Nick Leverton 2012-05-31 08:32:59 UTC
By coincidence I just had this issue again whilst responding.  It may be related to the caldav link perhaps rather than dimap, since they both go to the same server.

After an overnight interruption to the connection, I have closed and exited kontact (not even running in system tray), and run "akonadictl stop", but the flood of "Unknown error: unable to list item parts" is *still* going on :-(

I restarted akonadi using systemsettings "PIM framework", and both korganizer and plasma-desktop have now put up "Fetch job error" dialogue boxes with the same "unable to list item parts" message.

What can be producing it, how can I help you debug this issue ?  The cpu is being slugged to 100%, and the continuing popups severely interrupt my work.
Comment 6 Elián Hanisch 2013-11-30 11:58:56 UTC
Same issue here, KDE 4.11.2 on Kubuntu 13.10

I have imap gmail and I get spammed with these kind of error messages constantly and is so aggravating that I end turning off akonadi.
Comment 7 Denis Kurz 2016-09-24 20:35:00 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 8 Denis Kurz 2017-01-07 22:20:48 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.