Bug 293883 - GroupDav addressbook from egroupware cancels with "Unbekannter Fehler. (Unable to fetch item from backend)"
Summary: GroupDav addressbook from egroupware cancels with "Unbekannter Fehler. (Unabl...
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 4.8
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 09:06 UTC by Marcello Ceschia
Modified: 2012-10-20 21:58 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcello Ceschia 2012-02-12 09:06:37 UTC
Version:           4.8 (using KDE 4.8.0) 
OS:                Linux

Every time I start Kontact and choose the contacs tab:

"Unbekannter Fehler. (Unable to fetch item from backend)" 

Reproducible: Always

Steps to Reproduce:
Every time I start Kontact and choose the contacs tab:

"Unbekannter Fehler. (Unable to fetch item from backend)" 

Actual Results:  
no results for contacts with egroupware backend.


Expected Results:  
results from backend!
Comment 1 Marcello Ceschia 2012-02-12 09:10:13 UTC
KAddressBook::GlobalContactSession (0x849ec68) 8 OK List completed 
KAddressBook::GlobalContactSession (0x849ec68) 9 SELECT SILENT 21 
KAddressBook::GlobalContactSession (0x849ec68) 9 OK Completed 
KAddressBook::GlobalContactSession (0x849ec68) 10 FETCH 1:* FULLPAYLOAD ANCESTORS INF EXTERNALPAYLOAD (UID REMOTEID REMOTEREVISION COLLECTIONID FLAGS SIZE DATETIME ATR:ENTITYDISPLAY) 
KAddressBook::GlobalContactSession (0x849ec68) 10 OK FETCH completed 
KAddressBook::GlobalContactSession (0x849ec68) 11 SELECT SILENT 24 
KAddressBook::GlobalContactSession (0x849ec68) 11 OK Completed 
KAddressBook::GlobalContactSession (0x849ec68) 12 FETCH 1:* FULLPAYLOAD ANCESTORS INF EXTERNALPAYLOAD (UID REMOTEID REMOTEREVISION COLLECTIONID FLAGS SIZE DATETIME ATR:ENTITYDISPLAY) 
akonadi_davgroupware_resource_0 (0x84c1e80) 155 UID FETCH 1 CACHEONLY ANCESTORS INF EXTERNALPAYLOAD (UID REMOTEID REMOTEREVISION COLLECTIONID FLAGS SIZE DATETIME) 
akonadi_davgroupware_resource_0 (0x84c1e80) * 1 FETCH (UID 1 REV 0 REMOTEID "http://xxxxx/egroupware/groupdav.php/addressbook/" MIMETYPE "text/directory" COLLECTIONID 24 SIZE 0 DATETIME "12-Feb-2012 08:56:21 +0000" REMOTEREVISION "EGw-no-etag-wGE" FLAGS () ANCESTORS ((24 "http://xxxx/egroupware/groupdav.php/addressbook/") (21 "akonadi_davgroupware_resource_0") (0 ""))) 
akonadi_davgroupware_resource_0 (0x84c1e80) 155 OK UID FETCH completed 
KAddressBook::GlobalContactSession (0x849ec68) 12 NO Unable to fetch item from backend 


error message in akonadiconsole:
"AgentBase(akonadi_davgroupware_resource_0): Der Server hat ungültige Daten gesendet"
Comment 2 Grégory Oestreicher 2012-02-26 18:54:33 UTC
Hi Marcello,

This may be related to a bug that has been fixed and will shid in KDE 4.8.1. Can you retest when it will be available ?

Cheers,
Grégory
Comment 3 Marcello Ceschia 2012-03-10 08:20:50 UTC
The problem is not solved on my side, but there are some curiosities.
The installed packages have version number 4.8.1-327.1 but about kontact lists version 4.8.0, is I'm not realy sure what version this is
Comment 4 Grégory Oestreicher 2012-03-10 08:29:44 UTC
Hi Marcelo,

Can you check the version of the kdepim-runtime package? I've just check in Kontact sources and the version apparently was not bumped when 4.8.1 was released.

Cheers,
Grégory
Comment 5 Marcello Ceschia 2012-03-10 09:49:30 UTC
Hello Grégory,

thank you for you quick response. I reinstalled all kde packages from kde 4.8 repository to make sure that there ar no old version installed.
The kdepim4-runtime package has version 4.8.1-128.2.
Just need to mention that calendar entries from egroupware works as expected, only addressbook is the problem
Comment 6 Grégory Oestreicher 2012-03-10 10:13:11 UTC
OK, I've checked the source of the OpenSUSE package and the fix I thought would address this issue is present. I'll try to reproduce this issue.

Cheers,
Grégory
Comment 7 Aitor 2012-04-06 12:29:18 UTC
I used to have this problem as well. After updating to 4.8.2 it seems to be fixed.
My eGroupware's addressbook works fine now.
Can anyone confirm this?
Comment 8 ray-ven 2012-06-18 15:30:51 UTC
Same in Kubuntu (Precise and oneiric) with KDE 4.7-4.9 Beta2 and at my girlfriend's laptop with her profile.
I don't know it it's the plasma-desktop itself (because the errormessage is sometimes related to plasma sometimes to kde), so I'm not really able to give usefull information.
I've set up a CalDav with multiple calendars, a google contacts ressource and a few IMAPs and akonadi notes.
From 4.7 to 4.8 I deleted all my akonadi stuff and set it up again - error still occours.
There are about 3 of these "Unable to fetch item from backend" on startup of KDE, and about 5 when starting Kontact, about 3 again when clicking on calendar in Kontact.
This is killing my nerves!!!!
What about just let plasma-notifications handle "Unable to fetch item from backend" instead of popups which have to be confirmed. The message itself doesn't help much anyway, because it doesn't tell me from which backend (ressource) the item can't be fetched.
I think this is somehow network-connection related, because with no active connection kalendar goes totally crazy with these messages and sometimes if the connection breaks while using kontact the amount of messages (in the notification-widget this time) is almost endless.
I doubt it but hope this delivers somebody useful information.

Ray
Comment 9 Grégory Oestreicher 2012-10-20 21:58:05 UTC
(In reply to comment #8)
> Same in Kubuntu (Precise and oneiric) with KDE 4.7-4.9 Beta2 and at my
> girlfriend's laptop with her profile.

Hi,

Could you track this issue in 
https://bugs.kde.org/show_bug.cgi?id=295469 as your issue may be linked? This bug seems resolved.

Thanks,
Grégory