Bug 293831 - On close, a hidden window is shown before fading out
Summary: On close, a hidden window is shown before fading out
Status: RESOLVED DUPLICATE of bug 158262
Alias: None
Product: kwin
Classification: Plasma
Component: effects-window-management (show other bugs)
Version: 4.8.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-11 11:16 UTC by Lastique
Modified: 2012-02-11 11:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lastique 2012-02-11 11:16:56 UTC
Version:           4.8.0 (using KDE 4.8.0) 
OS:                Linux

Among others I have the Fade effect enabled. When a window hidden behind other windows closes, it shows in the front and then immediately fades out.


Reproducible: Always

Steps to Reproduce:
1. Start some application which opens a window and closes it after a while. Pretty much any application will do - in my case it's a software manager which opens a window showing package database refreshing progress.
2. Switch to another application that covers that window (e.g. a browser).
3. Wait until the covered window closes.

Actual Results:  
The covered window appears in front of the covering window and fades out.

Expected Results:  
The window should not be shown at all. It should close in background.

I have a nvidia video card with the latest proprietary drivers. The described behavior has been there for quite a few KDE releases, it's not new to 4.8.
Comment 1 Martin Flöser 2012-02-11 11:23:37 UTC

*** This bug has been marked as a duplicate of bug 158262 ***