Bug 293716 - KCM Telepathy Accounts crashed when removing an old account
Summary: KCM Telepathy Accounts crashed when removing an old account
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: accounts-kcm (show other bugs)
Version: git-latest
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: Future
Assignee: System Settings Bugs
URL:
Keywords:
: 298672 309892 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-09 14:34 UTC by Daniele E. Domenichelli
Modified: 2012-11-12 14:56 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele E. Domenichelli 2012-02-09 14:34:45 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.8.00 (4.8.0
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
I installed kde-telepathy packages from shadeslayers ppa.
The accounts were configured some time ago but were still using mc to store password instead of kwallet. When I started the kcm they were alredy there, but msn account was using butterfly, therefore I tried to remove it, and this caused kcm to crash

-- Backtrace:
Application: Impostazioni di sistema (systemsettings), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa2765ea780 (LWP 6382))]

Thread 2 (Thread 0x7fa260cc4700 (LWP 6383)):
#0  0x00007fa273ab4773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa27136ef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa27136f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa27421cf3e in QEventDispatcherGlib::processEvents (this=0x19bf080, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fa2741f0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa2741f0ef7 in QEventLoop::exec (this=0x7fa260cc3dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fa27410827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fa2741d3cbf in QInotifyFileSystemWatcherEngine::run (this=0x1dfc840) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa27410ad05 in QThreadPrivate::start (arg=0x1dfc840) at thread/qthread_unix.cpp:331
#9  0x00007fa271840efc in start_thread (arg=0x7fa260cc4700) at pthread_create.c:304
#10 0x00007fa273ac089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa2765ea780 (LWP 6382)):
[KCrash Handler]
#6  KCMTelepathyAccounts::onRemoveAccountClicked (this=0x2118650) at /build/buildd/ktp-accounts-kcm-0.3.0/src/kcm-telepathy-accounts.cpp:338
#7  0x00007fa260130544 in KCMTelepathyAccounts::qt_metacall (this=0x2118650, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5fa6d430) at /build/buildd/ktp-accounts-kcm-0.3.0/obj-x86_64-linux-gnu/src/kcm-telepathy-accounts.moc:104
#8  0x00007fa274204eba in QMetaObject::activate (sender=0x20b3120, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5fa6d430) at kernel/qobject.cpp:3278
#9  0x00007fa2754dd642 in QAbstractButton::clicked (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#10 0x00007fa2752231fe in QAbstractButtonPrivate::emitClicked (this=<optimized out>) at widgets/qabstractbutton.cpp:546
#11 0x00007fa27522453b in QAbstractButtonPrivate::click (this=0x20f7db0) at widgets/qabstractbutton.cpp:539
#12 0x00007fa2752247ac in QAbstractButton::mouseReleaseEvent (this=0x20b3120, e=0x7fff5fa6db40) at widgets/qabstractbutton.cpp:1121
#13 0x00007fa274ebccea in QWidget::event (this=0x20b3120, event=0x7fff5fa6db40) at kernel/qwidget.cpp:8295
#14 0x00007fa274e6c474 in notify_helper (e=0x7fff5fa6db40, receiver=0x20b3120, this=0x1822890) at kernel/qapplication.cpp:4486
#15 QApplicationPrivate::notify_helper (this=0x1822890, receiver=0x20b3120, e=0x7fff5fa6db40) at kernel/qapplication.cpp:4458
#16 0x00007fa274e71cbb in QApplication::notify (this=<optimized out>, receiver=0x20b3120, e=0x7fff5fa6db40) at kernel/qapplication.cpp:4047
#17 0x00007fa275b81ae6 in KApplication::notify (this=0x7fff5fa6e7a0, receiver=0x20b3120, event=0x7fff5fa6db40) at ../../kdeui/kernel/kapplication.cpp:311
#18 0x00007fa2741f1afc in QCoreApplication::notifyInternal (this=0x7fff5fa6e7a0, receiver=0x20b3120, event=0x7fff5fa6db40) at kernel/qcoreapplication.cpp:787
#19 0x00007fa274e6d442 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QApplicationPrivate::sendMouseEvent (receiver=0x20b3120, event=0x7fff5fa6db40, alienWidget=0x20b3120, nativeWidget=0x1995170, buttonDown=0x20b3120, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#21 0x00007fa274eec9d5 in QETWidget::translateMouseEvent (this=0x1995170, event=<optimized out>) at kernel/qapplication_x11.cpp:4571
#22 0x00007fa274eeb94e in QApplication::x11ProcessEvent (this=0x7fff5fa6e7a0, event=0x7fff5fa6e360) at kernel/qapplication_x11.cpp:3693
#23 0x00007fa274f144a2 in x11EventSourceDispatch (s=0x181b100, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#24 0x00007fa27136ea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fa27136f258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fa27136f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fa27421ced6 in QEventDispatcherGlib::processEvents (this=0x17eba10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#28 0x00007fa274f1410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007fa2741f0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007fa2741f0ef7 in QEventLoop::exec (this=0x7fff5fa6e730, flags=...) at kernel/qeventloop.cpp:201
#31 0x00007fa2741f5789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#32 0x000000000040a7d5 in main (argc=5, argv=0x7fff5fa6ea68) at ../../../systemsettings/app/main.cpp:49

Reported using DrKonqi
Comment 1 Martin Klapetek 2012-05-12 21:23:08 UTC
*** Bug 298672 has been marked as a duplicate of this bug. ***
Comment 2 Martin Klapetek 2012-05-12 21:24:39 UTC
Can we add an account directly and make MC store the password? This would help in reproducing (and fixing) the crash.
Comment 3 David Edmundson 2012-08-20 14:26:25 UTC
This is hopefully fixed in the wallet update.

Re-open (with a new backtrace) if this can still be reproduced
Comment 4 David Edmundson 2012-11-03 06:48:37 UTC
Git commit cd46494b035c3fa020019db2f6951945bfd63a66 by David Edmundson.
Committed on 08/08/2012 at 15:33.
Pushed by davidedmundson into branch 'model_refactor_1'.

Async wallet usage, using wallet-utils from common internals

Also fix some pointless code when deleting accounts which used to proxy via a model.
This should hopefully fix the crash when removing accounts

REVIEW: 105926
Related: bug 303060

M  +0    -13   KTp/Models/accounts-list-model.cpp
M  +0    -1    KTp/Models/accounts-list-model.h

http://commits.kde.org/telepathy-common-internals/cd46494b035c3fa020019db2f6951945bfd63a66
Comment 5 David Edmundson 2012-11-09 06:32:26 UTC
Git commit 82a26bbaddfd898374b039038e77702575cbe1e7 by David Edmundson.
Committed on 08/08/2012 at 15:33.
Pushed by davidedmundson into branch 'master'.

Async wallet usage, using wallet-utils from common internals

Also fix some pointless code when deleting accounts which used to proxy via a model.
This should hopefully fix the crash when removing accounts

REVIEW: 105926
Related: bug 303060

M  +0    -13   KTp/Models/accounts-list-model.cpp
M  +0    -1    KTp/Models/accounts-list-model.h

http://commits.kde.org/telepathy-common-internals/82a26bbaddfd898374b039038e77702575cbe1e7
Comment 6 Martin Klapetek 2012-11-12 14:56:53 UTC
*** Bug 309892 has been marked as a duplicate of this bug. ***