Bug 293600 - Keep-alive connections sometimes render pages incorrectly
Summary: Keep-alive connections sometimes render pages incorrectly
Status: RESOLVED DUPLICATE of bug 289029
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.8.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-08 04:20 UTC by Davor Cubranic
Modified: 2012-02-08 07:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot illustrating the problem (95.40 KB, image/png)
2012-02-08 04:20 UTC, Davor Cubranic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Davor Cubranic 2012-02-08 04:20:25 UTC
Created attachment 68608 [details]
Screenshot illustrating the problem

I've been increasingly seeing pages that get rendered with text that looks like raw HTTP traffic. This seems to happen when I click on a link before the page has completely loaded. I think the output always include a "Connection: keep-alive" header. I'm including a screenshot to demonstrate what happens
Comment 1 Davor Cubranic 2012-02-08 04:21:49 UTC
I should add that reloading the page always fixes the problem and renders it correctly. Perhaps clicking on the URL doesn't tear down the current page's rendering thread if it hasn't been completely loaded?
Comment 2 Andrea Diamantini 2012-02-08 07:15:52 UTC
This is a bug we had in 0.8 series. Nothing with network traffic or rendering, just a problem with kio usage. You'll find it fixed in the 0.9 series. I couldn't backport to 0.8, sorry.

*** This bug has been marked as a duplicate of bug 289029 ***