Bug 293491 - Improve activity bar to fit the panel
Summary: Improve activity bar to fit the panel
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-activitybar (show other bugs)
Version: 4.8.0
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2012-02-06 23:34 UTC by S. Burmeister
Modified: 2018-06-08 20:03 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2012-02-06 23:34:13 UTC
Version:           unspecified (using KDE 4.8.0) 
OS:                Linux

The current way the activity bar is displayed in a panel is a bad compromise between wasting too much horizontal space and allowing the user easy access to all activities (as he does to all virtual desktops).

Easy access to all activities demands that all items representing them are accessible without scrolling. Hence the way the items are displayed has to adapt to the space available.

Possibility 1: Enough horizontal space is available.
This could be the case if the user has placed the activity bar in its own panel.
Display: icons + text.

Possibility 2: Horizontal space is limited.
This will be the case in most panels.
Display: icons only and Name + info in a thumbnail window as implemented for tasks when hovering. This will allow the icons to be bigger than they currently are, i.e. as big as launchers etc. on the panel.

Possibility 3: Enough vertical space.
This can happen in panels that offer more space than is needed for one text line.
Display: a) if the horizontal space is enough to display all items that way, place the icon above the text.
b) if a) does not work arrange all icons in several rows.

Of course this can be extended to allow the user to force the bar to only show icons or show icons + text.

The user could also set a preference whether to prefer a horizontal vs. a vertical layout, i.e. if enough vertical space is available the activities could be arranged in several rows.

The user could set the number of rows.

Reproducible: Didn't try

Steps to Reproduce:
Add activity bar to the panel.

Actual Results:  
Scroll arrows

Expected Results:  
No scroll arrows but a smart arrangement of the items.
Comment 1 apache 2012-07-02 16:59:13 UTC
I think this has a lot to do with how panel handles size of different plasmoids:
http://forum.kde.org/viewtopic.php?f=93&t=39121
I think overall panel qualities should be improved because it affects ather plasmoids including activity bar.
Comment 2 Myriam Schweingruber 2012-08-06 09:24:36 UTC
Added to The Extra Mile
Comment 3 Nate Graham 2018-06-08 20:03:27 UTC
Hello!

This feature request was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this feature request is already implemented in Plasma 5, or is no longer applicable.

Accordingly, we hope you understand why we must close this feature request. If the requested feature is still desired but not implemented in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham