Bug 293315 - Cannot resize Details View columns by double-clicking between the headers
Summary: Cannot resize Details View columns by double-clicking between the headers
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: details mode (show other bugs)
Version: 2.1
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: regression, reproducible
: 317438 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-04 18:27 UTC by
Modified: 2014-02-06 12:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.13


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2012-02-04 18:27:19 UTC
Version:           2.0 (using Devel) 
OS:                Linux

When a tab is too big or too small, i double click in the division of the tab so that can be resized to some default size, like it was possible before dolphin 2.

Reproducible: Always

Steps to Reproduce:
For example resize a tab to some bigger or smaller and then double click on the tab division to see what happens.

Actual Results:  
nothing happens when double clicking in the tab division to allow resize.

Expected Results:  
Should be possible to resize tabs to a default size like it was possible before dolphin 2

OS: Linux (x86_64) release 3.2.2-1.1-desktop
Compiler: gcc
Comment 1 Peter Penz 2012-02-04 19:16:40 UTC
Thanks for the detailed report. This is a known regression and we'll try to fix this during the KDE 4.8.x cycle
Comment 2 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:20:03 UTC
Resetting assignee to default as per bug #305719
Comment 3 2012-11-07 17:01:15 UTC
Well i cant see the bug #305719, it says this:
You are not authorized to access bug

anyway i have seen that in dolphin Peter Penz did adopted a different approach to resolve this problem and in my view did not fixed this problem, because when double clicking in columns separators it continues to not doing anything, where the default/expected behavior would be adjust the column size with the size of the files text.

It would be much better if we could double click in columns separators and have them resized and also have the right click approach implemented in Peter Penz time.
Comment 4 Frank Reininghaus 2013-03-28 08:57:53 UTC
*** Bug 317438 has been marked as a duplicate of this bug. ***
Comment 5 Emmanuel Pescosta 2014-02-05 16:17:22 UTC
In my opinion we should always use "automatic column widths" and remove the custom column width code completely.
Comment 6 Frank Reininghaus 2014-02-05 16:32:57 UTC
(In reply to comment #5)
> In my opinion we should always use "automatic column widths" and remove the
> custom column width code completely.

AFAIK, this was also Peter's original idea, but he dropped it after there were many complaints from users for whom custom column widths are an important feature (see bug 264434).
Comment 7 Emmanuel Pescosta 2014-02-05 16:50:19 UTC
Ah ok, thanks for the info, I wasn't aware of that.
Comment 8 Emmanuel Pescosta 2014-02-05 17:33:51 UTC
Review-Request: https://git.reviewboard.kde.org/r/115503/
Comment 9 Emmanuel Pescosta 2014-02-06 12:02:46 UTC
Git commit 15f409de33dad14e4ceefff81960a6c974e161b9 by Emmanuel Pescosta.
Committed on 06/02/2014 at 12:00.
Pushed by emmanuelp into branch 'master'.

Set the Details View colummns width to the preferred column width, by double-clicking the header grips.
FIXED-IN: 4.13
REVIEW: 115503

M  +16   -0    dolphin/src/kitemviews/private/kitemlistheaderwidget.cpp
M  +1    -0    dolphin/src/kitemviews/private/kitemlistheaderwidget.h

http://commits.kde.org/kde-baseapps/15f409de33dad14e4ceefff81960a6c974e161b9