Bug 293281 - KWin crashes when playing 1080p mkv file
Summary: KWin crashes when playing 1080p mkv file
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 10:59 UTC by ozu
Modified: 2012-07-03 12:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
mgraesslin: nouveau+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ozu 2012-02-04 10:59:59 UTC
Application: kwin (4.6.5 (4.6.5))
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-12-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

1) Stat smplayer
2) Play a 1080p mkv file
3) After 15 sec aprox, KWin crashes


- Custom settings of the application:

1)Desktop effects activated using OpenGL:
   *Disable-functionality-check option was activated
   *Genral options: +Only running windows
                                  +Smooth
                                  +Suspend-desktop-effects-full-scree-window option was activated
   *OpenGL options: +Frame from image
                                    +Use-VSync option was activated
                                    +Enable-direct-representation
2) Use of nvidia-driver
3) 'gl' was smplayer video-output

- Others:
3) Smplayer gets very slow, so that movie is not played on-demand, it sometimes gets stuck....it seems that resources are very congested at that time....

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb42ff8d7a0 (LWP 1845))]

Thread 3 (Thread 0x7fb410cee700 (LWP 1850)):
#0  0x00007fb42f7da143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fb42bbb732c in qt_safe_select (nfds=17, fdread=0x2e0e0b0, fdwrite=0x2e0e348, fdexcept=0x2e0e5e0, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007fb42bbbc3d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x2e0def0, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007fb42bbbd04a in QEventDispatcherUNIX::processEvents (this=0x2eb9bc0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007fb42bb8e882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb42bb8eabc in QEventLoop::exec (this=0x7fb410ceddb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb42baa5924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fb42bb70c2f in QInotifyFileSystemWatcherEngine::run (this=0x2e0cee0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb42baa8175 in QThreadPrivate::start (arg=0x2e0cee0) at thread/qthread_unix.cpp:320
#9  0x00007fb426195d8c in start_thread (arg=0x7fb410cee700) at pthread_create.c:304
#10 0x00007fb42f7e204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb40afbf700 (LWP 1851)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb42e6402a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fb42e959180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fb42e6402d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fb42e967254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fb426195d8c in start_thread (arg=0x7fb40afbf700) at pthread_create.c:304
#4  0x00007fb42f7e204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb42ff8d7a0 (LWP 1845)):
[KCrash Handler]
#6  prepare_wm_surfaces (brw=0x1a79330) at brw_wm_surface_state.c:602
#7  0x00007fb41270305e in brw_validate_state (brw=0x1a79330) at brw_state_upload.c:397
#8  0x00007fb4126f20bd in brw_try_draw_prims (ctx=0x1a79330, arrays=0x2744828, prim=0x2742f44, nr_prims=0, ib=0x0, index_bounds_valid=<value optimized out>, min_index=0, max_index=3) at brw_draw.c:362
#9  brw_draw_prims (ctx=0x1a79330, arrays=0x2744828, prim=0x2742f44, nr_prims=0, ib=0x0, index_bounds_valid=<value optimized out>, min_index=0, max_index=3) at brw_draw.c:447
#10 0x00007fb412379100 in vbo_exec_vtx_flush (exec=0x2742c60, unmap=1 '\001') at vbo/vbo_exec_draw.c:381
#11 0x00007fb412376e2c in vbo_exec_FlushVertices_internal (ctx=<value optimized out>, unmap=<value optimized out>) at vbo/vbo_exec_api.c:911
#12 0x00007fb41237702a in vbo_exec_FlushVertices (ctx=<value optimized out>, flags=1) at vbo/vbo_exec_api.c:945
#13 0x00007fb4122b40ce in _mesa_PopAttrib () at main/attrib.c:858
#14 0x00007fb42dc2bac5 in KWin::PaintClipper::Iterator::~Iterator (this=0x7fff0c99d770, __in_chrg=<value optimized out>) at ../../../kwin/lib/kwineffects.cpp:873
#15 0x00007fb42dc34d62 in KWin::renderGLGeometry (region=..., count=4, vertices=0x4139f00, texture=0x4106020, color=0x0, dim=2, stride=0) at ../../../kwin/lib/kwinglutils.cpp:180
#16 0x00007fb42fb5bbf8 in KWin::SceneOpenGL::Window::renderQuads (this=<value optimized out>, region=..., quads=...) at ../../kwin/scene_opengl.cpp:1678
#17 0x00007fb42fb63573 in KWin::SceneOpenGL::Window::performPaint (this=0x40a74e0, mask=9, region=..., data=...) at ../../kwin/scene_opengl.cpp:1559
#18 0x00007fb42fb4e379 in KWin::Scene::finalDrawWindow (this=<value optimized out>, w=<value optimized out>, mask=9, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:332
#19 0x00007fb42fb690c3 in KWin::EffectsHandlerImpl::drawWindow (this=<value optimized out>, w=0x3fe9470, mask=9, region=<value optimized out>, data=<value optimized out>) at ../../kwin/effects.cpp:247
#20 0x00007fb42fb4dc38 in KWin::Scene::finalPaintWindow (this=<value optimized out>, w=0x3fe9470, mask=9, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:323
#21 0x00007fb42fb691b3 in KWin::EffectsHandlerImpl::paintWindow (this=0x2b9b170, w=0x3fe9470, mask=9, region=<value optimized out>, data=<value optimized out>) at ../../kwin/effects.cpp:204
#22 0x00007fb42fb4e577 in KWin::Scene::paintWindow (this=<value optimized out>, w=0x40a74e0, mask=9, region=..., quads=<value optimized out>) at ../../kwin/scene.cpp:317
#23 0x00007fb42fb4eeca in KWin::Scene::paintSimpleScreen (this=0x1a6bf40, orig_mask=8, region=...) at ../../kwin/scene.cpp:288
#24 0x00007fb42fb4db81 in KWin::Scene::finalPaintScreen (this=0x1a6bf40, mask=8, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:180
#25 0x00007fb42fb69293 in KWin::EffectsHandlerImpl::paintScreen (this=0x2b9b170, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#26 0x00007fb42fb5000f in KWin::Scene::paintScreen (this=0x1a6bf40, mask=0x7fff0c99e1fc, region=0x7fff0c99e2e0) at ../../kwin/scene.cpp:137
#27 0x00007fb42fb63e53 in KWin::SceneOpenGL::paint (this=0x1a6bf40, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#28 0x00007fb42fb4b1d5 in KWin::Workspace::performCompositing (this=0x7fb40c354070) at ../../kwin/composite.cpp:442
#29 0x00007fb42bba31c9 in QObject::event (this=0x7fb40c354070, e=<value optimized out>) at kernel/qobject.cpp:1190
#30 0x00007fb42af4c9f4 in QApplicationPrivate::notify_helper (this=0x1987a20, receiver=0x7fb40c354070, e=0x7fff0c99ea50) at kernel/qapplication.cpp:4462
#31 0x00007fb42af513ba in QApplication::notify (this=<value optimized out>, receiver=0x7fb40c354070, e=0x7fff0c99ea50) at kernel/qapplication.cpp:4341
#32 0x00007fb42f2dd6c6 in KApplication::notify (this=0x7fff0c99ee50, receiver=0x7fb40c354070, event=0x7fff0c99ea50) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007fb42bb8f49c in QCoreApplication::notifyInternal (this=0x7fff0c99ee50, receiver=0x7fb40c354070, event=0x7fff0c99ea50) at kernel/qcoreapplication.cpp:731
#34 0x00007fb42bbbcf12 in sendEvent (this=0x19884d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x19884d0) at kernel/qeventdispatcher_unix.cpp:604
#36 0x00007fb42bbbd05b in QEventDispatcherUNIX::processEvents (this=0x192c340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#37 0x00007fb42aff72ec in QEventDispatcherX11::processEvents (this=0x192c340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#38 0x00007fb42bb8e882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007fb42bb8eabc in QEventLoop::exec (this=0x7fff0c99ed90, flags=...) at kernel/qeventloop.cpp:201
#40 0x00007fb42bb92ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#41 0x00007fb42fae914c in kdemain (argc=<value optimized out>, argv=0x7fff0c99f4e8) at ../../kwin/main.cpp:542
#42 0x00007fb42f71aeff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff0c99f4e8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff0c99f4d8) at libc-start.c:226
#43 0x0000000000400669 in _start ()

Possible duplicates by query: bug 287641, bug 280730, bug 279514, bug 279310, bug 277972.

Reported using DrKonqi
Comment 1 Martin Flöser 2012-02-04 11:08:16 UTC

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 Martin Flöser 2012-07-03 12:07:55 UTC
as I just noticed: the backtrace shows that Mesa is used thought the initial comment says the NVIDIA blob is used.