Bug 293231 - Konsole should migrate user's tab settins from the profile to the global settings
Summary: Konsole should migrate user's tab settins from the profile to the global sett...
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources FreeBSD
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 18:08 UTC by Raphael Kubo da Costa
Modified: 2012-04-20 05:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa 2012-02-03 18:08:34 UTC
Version:           unspecified (using Devel) 
OS:                FreeBSD

It looks like git commit 56f3805ac1d5c9b884865dd448c0fa88794b0f54 has moved the tab settings (position, where a new tab should be opened etc) from profiles to the global settings.

However, currently all settings seem to be reset to the defaults instead of being migrated, causing some confusion (I only understood what had happened after looking at the commit log).

Reproducible: Always

Steps to Reproduce:
Upgrade konsole to the mentioned git revision.

Actual Results:  
The tab settings are lost and reset to the default values.

Expected Results:  
Either the settings are automatically migrated via kconf_update (if there's a single profile) or Konsole asks the user what to do with the old data.
Comment 1 Jekyll Wu 2012-02-05 08:23:50 UTC
Sorry for the trouble caused by those commits.

I agree such automatically migration is nice and needed. I have written a simple and stupid script for the kconf_update framework after reading this report and it seems to work. However, I prefer to delay the introduction of such script, since we are still in the early stage of the 4.9 cycle and those global options might change. 

Thanks for your suggestion.
Comment 2 Jekyll Wu 2012-03-18 18:36:26 UTC
Git commit f542899f13a7a7e9aab297a4e45877b862ceacba by Jekyll Wu.
Committed on 18/03/2012 at 19:32.
Pushed by jekyllwu into branch 'master'.

Add kconf-update script for migrating exising tabbar and menubar settings
FIXED-IN:4.9

REVIEW: 104253

M  +1    -0    data/CMakeLists.txt
A  +2    -0    data/updaters/CMakeLists.txt
A  +82   -0    data/updaters/konsole-2.9.0-global-options.sh
A  +3    -0    data/updaters/konsole.upd

http://commits.kde.org/konsole/f542899f13a7a7e9aab297a4e45877b862ceacba