Bug 293165 - KMail crashed after imap settings window close
Summary: KMail crashed after imap settings window close
Status: RESOLVED DUPLICATE of bug 288268
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 18:05 UTC by Paulius
Modified: 2012-02-12 13:22 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.30 KB, text/plain)
2012-02-12 13:22 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paulius 2012-02-02 18:05:38 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
every time Kmail is crashing when i try to close imap server settings window.

-- Backtrace:
Application: KTU IMAP of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f044cdbf780 (LWP 3562))]

Thread 3 (Thread 0x7f0439bda700 (LWP 3566)):
#0  0x00007f044712defa in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f044712e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f044c227f3e in QEventDispatcherGlib::processEvents (this=0x19f5780, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007f044c1fbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f044c1fbef7 in QEventLoop::exec (this=0x7f0439bd9de0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007f044c11327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#6  0x00007f044ae39c13 in KIMAP::SessionThread::run (this=0x1de44e0) at ../../kimap/sessionthread.cpp:169
#7  0x00007f044c115d05 in QThreadPrivate::start (arg=0x1de44e0) at thread/qthread_unix.cpp:331
#8  0x00007f0448096efc in start_thread (arg=0x7f0439bda700) at pthread_create.c:304
#9  0x00007f04487e789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f043aa00700 (LWP 4308)):
#0  0x00007f04487db773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f044712df68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f044712e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f044c227f3e in QEventDispatcherGlib::processEvents (this=0x1d8fb30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f044c1fbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f044c1fbef7 in QEventLoop::exec (this=0x7f043a9ffdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f044c11327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f044c1decbf in QInotifyFileSystemWatcherEngine::run (this=0x1a0ebd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f044c115d05 in QThreadPrivate::start (arg=0x1a0ebd0) at thread/qthread_unix.cpp:331
#9  0x00007f0448096efc in start_thread (arg=0x7f043aa00700) at pthread_create.c:304
#10 0x00007f04487e789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f044cdbf780 (LWP 3562)):
[KCrash Handler]
#6  0x00007f044c20394d in indexOfMethodRelative<4> (normalizeStringData=false, method=0x1ae4d89 "connectionLost()", baseObject=0x7fff7f4555b0) at kernel/qmetaobject.cpp:498
#7  QMetaObjectPrivate::indexOfSignalRelative (baseObject=0x7fff7f4555b0, signal=0x1ae4d89 "connectionLost()", normalizeStringData=false) at kernel/qmetaobject.cpp:601
#8  0x00007f044c20f747 in QObject::disconnect (sender=0x1d24450, signal=0x1ae4d89 "connectionLost()", receiver=0x19b97f0, method=0x1ae4b49 "onEarlyConnectionLost()") at kernel/qobject.cpp:2732
#9  0x0000000000453931 in SessionPool::killSession (this=0x19b97f0, session=0x1d24450, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#10 0x0000000000453ef5 in SessionPool::disconnect (this=0x19b97f0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:119
#11 0x00000000004168c3 in ImapResource::doSetOnline (this=0x19156c0, online=false) at ../../../resources/imap/imapresource.cpp:421
#12 0x00007f044c827ee8 in Akonadi::AgentBase::setOnline (this=0x19156c0, state=false) at ../../akonadi/agentbase.cpp:630
#13 0x0000000000416b88 in ImapResource::reconnect (this=0x19156c0) at ../../../resources/imap/imapresource.cpp:445
#14 0x00007f044c95dc25 in configure (windowId=<optimized out>, this=0x1983710) at controladaptor.cpp:51
#15 Akonadi__ControlAdaptor::qt_metacall (this=0x1983710, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7f4558e0) at controladaptor.moc:102
#16 0x00007f044c5540e9 in QDBusConnectionPrivate::deliverCall (this=0x189b9b0, object=0x1983710, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:942
#17 0x00007f044c55519b in QDBusConnectionPrivate::activateCall (this=0x189b9b0, object=0x1983710, flags=273, msg=...) at qdbusintegrator.cpp:845
#18 0x00007f044c555b22 in QDBusConnectionPrivate::activateObject (this=0x189b9b0, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1410
#19 0x00007f044c555bf8 in QDBusActivateObjectEvent::placeMetaCall (this=0x1bf59d0) at qdbusintegrator.cpp:1524
#20 0x00007f044c213a5e in QObject::event (this=0x19156c0, e=<optimized out>) at kernel/qobject.cpp:1217
#21 0x00007f044b5ac474 in notify_helper (e=0x1bf59d0, receiver=0x19156c0, this=0x184c1f0) at kernel/qapplication.cpp:4486
#22 QApplicationPrivate::notify_helper (this=0x184c1f0, receiver=0x19156c0, e=0x1bf59d0) at kernel/qapplication.cpp:4458
#23 0x00007f044b5b12e1 in QApplication::notify (this=0x7fff7f4563c0, receiver=0x19156c0, e=0x1bf59d0) at kernel/qapplication.cpp:4365
#24 0x00007f04496c3466 in KApplication::notify (this=0x7fff7f4563c0, receiver=0x19156c0, event=0x1bf59d0) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f044c1fcafc in QCoreApplication::notifyInternal (this=0x7fff7f4563c0, receiver=0x19156c0, event=0x1bf59d0) at kernel/qcoreapplication.cpp:787
#26 0x00007f044c20051f in sendEvent (event=0x1bf59d0, receiver=0x19156c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1827800) at kernel/qcoreapplication.cpp:1428
#28 0x00007f044c227a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#29 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007f044712da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f044712e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f044712e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f044c227ed6 in QEventDispatcherGlib::processEvents (this=0x1829210, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#34 0x00007f044b65410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f044c1fbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f044c1fbef7 in QEventLoop::exec (this=0x7fff7f456340, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f044c200789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#38 0x00007f044c8f0fa6 in Akonadi::ResourceBase::init (r=0x19156c0) at ../../akonadi/resourcebase.cpp:393
#39 0x000000000041a726 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#40 0x00007f044872730d in __libc_start_main (main=0x415050 <main(int, char**)>, argc=3, ubp_av=0x7fff7f4564d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7f4564c8) at libc-start.c:226
#41 0x0000000000415205 in _start ()

Possible duplicates by query: bug 290773.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-02-03 13:04:11 UTC
Fixed in 4.8.0

*** This bug has been marked as a duplicate of bug 288268 ***
Comment 2 Christian 2012-02-12 13:22:45 UTC
Created attachment 68729 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.7) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

I only changed the mail check interval in e-mail settings. After I closed the setting window, the crash happend.

-- Backtrace (Reduced):
#7  0x00007f364455f714 in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x0000000000453931 in SessionPool::killSession (this=0xa3ff20, session=0xc7e0c0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#9  0x0000000000453ef5 in SessionPool::disconnect (this=0xa3ff20, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:119
#10 0x00000000004168c3 in ImapResource::doSetOnline (this=0x9787d0, online=false) at ../../../resources/imap/imapresource.cpp:421
#11 0x00007f3644b77ee8 in Akonadi::AgentBase::setOnline(bool) () from /usr/lib/libakonadi-kde.so.4