Bug 293110 - Okular ignores CUPS defaults for printers
Summary: Okular ignores CUPS defaults for printers
Status: RESOLVED DUPLICATE of bug 180051
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 01:52 UTC by reescf
Modified: 2012-02-03 01:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description reescf 2012-02-02 01:52:17 UTC
Version:           unspecified (using KDE 4.8.0) 
OS:                Linux

Okular does not use default options set for printers in CUPS. The only default it uses is the default printer (which I would just as soon it ignored).

In addition, there is no way to set Okular-specific defaults for printers that I've found.

This means that for every document I print, I have to manually select the correct printer and then set the appropriate options for that printer.

Reproducible: Always

Steps to Reproduce:
Set up some printers in CUPS (I use the web interface).

Set some default options for those printers e.g. for every printer, I change the default paper from letter to A4, for all printers which have additional trays etc., I mark those as installed, for printers which allow it, I enable duplex long-sided flip as default, I may also need to change print quality etc.

Open some PDF documents.

Print them, checking that the settings are correct for the printer you select for each document.

Actual Results:  
Okular defaults to non-customised default settings for all printers for every document.

So for document one, if I check the settings, I find: letter, single-sided etc. If I print this, it indeed prints single-sided etc. So instead I adjust the options - I select the printer I'm using and I set all the default options for this job which I enabled in CUPS.

Now I print document two. Again, I need to select the printer and set all of the options which are default in CUPS i.e. A4, duplex etc.

Repeat as necessary.

Change to a different printer.

Repeat as necessary.

Expected Results:  
Okular should default to the default settings assigned to each printer in CUPS. So if I just select the printer I'm using and immediately OK printing, I should get duplex, A4 etc. Whatever is set for that printer.

acroread does a lot wrong but it does this right. It picks up default settings for each printer from CUPS.

It also defaults to the last-used printer if you print several documents during the same session. (This is hard because it keeps crashing but if by some miracle it doesn't, it does this.) This is good because the last-used printer is the one I'm most likely to want to print to. And whatever that printer is, it uses the default settings I assigned via CUPS.
Comment 1 reescf 2012-02-03 01:35:34 UTC
This is a duplicate. Searching didn't find this because the original summary didn't mention CUPS and only mentioned duplex when all settings are affected.

Had I known how little notice such an important usability issue gets - no, wait, did I say "little"? that suggests "some" and that's just not right... - I wouldn't have wasted my electronic breath.

*** This bug has been marked as a duplicate of bug 180051 ***