Bug 292990 - Kontact crashed right after opening
Summary: Kontact crashed right after opening
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: 4.8
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 293069 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-31 19:01 UTC by Sven Eden
Modified: 2012-10-17 11:28 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Eden 2012-01-31 19:01:38 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.2.1-gentoo-r2 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
Resumed from hibernation, started Kontact, half a second after the window appeared, kontact went away and Dr.Konqi showed up.

This is the first time I had such a crash since I started using KDE-4.1. 

- I just tried to start kontact again, and a window informed me, that it would be running on another display. So I try again after sending this report.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2d34657780 (LWP 10309))]

Thread 5 (Thread 0x7f2d1d1ee700 (LWP 10311)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2d31083b64 in scavengerThread (this=0x7f2d318a74e0) at wtf/FastMalloc.cpp:2378
#2  WTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f2d318a74e0) at wtf/FastMalloc.cpp:1497
#3  0x00007f2d2c968f2c in start_thread (arg=0x7f2d1d1ee700) at pthread_create.c:301
#4  0x00007f2d31bfa50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f2d1c8ed700 (LWP 10312)):
#0  0x00007f2d31bf18d3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2d2b7a5de4 in g_main_context_poll (n_fds=1, fds=0x1d85ed0, timeout=-1, context=0x1d86210, priority=<optimized out>) at gmain.c:3402
#2  g_main_context_iterate (context=0x1d86210, block=1, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x00007f2d2b7a62a1 in g_main_context_iteration (context=0x1d86210, may_block=1) at gmain.c:3152
#4  0x00007f2d32fbb946 in QEventDispatcherGlib::processEvents (this=0x1d85ef0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f2d32f8fce2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f2d32f8ff24 in QEventLoop::exec (this=0x7f2d1c8ece00, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f2d32ea4644 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f2d32ea6e95 in QThreadPrivate::start (arg=0x1d85250) at thread/qthread_unix.cpp:331
#9  0x00007f2d2c968f2c in start_thread (arg=0x7f2d1c8ed700) at pthread_create.c:301
#10 0x00007f2d31bfa50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f2d0f8d3700 (LWP 10361)):
[KCrash Handler]
#6  _int_free (av=0x7f2d18000020, p=0x7f2d1801c650) at malloc.c:4892
#7  0x00007f2d31b99ff3 in _int_realloc (av=0x7f2d18000020, oldp=0x7f2d1801c650, oldsize=80, nb=<optimized out>) at malloc.c:5341
#8  0x00007f2d31b9b649 in __GI___libc_realloc (oldmem=0x7f2d1801c660, bytes=128) at malloc.c:3821
#9  0x00007f2d32ea929a in QByteArray::realloc (this=0x7f2d0f8d2640, alloc=96) at tools/qbytearray.cpp:1440
#10 0x00007f2d32ea9f01 in QByteArray::append (this=0x7f2d0f8d2640, ba=...) at tools/qbytearray.cpp:1584
#11 0x00007f2d32f50af2 in operator+= (a=..., this=0x7f2d0f8d2640) at ../../include/QtCore/../../src/corelib/tools/qbytearray.h:492
#12 QUrlPrivate::toEncoded (this=0x7f2d0f8d26d0, options=...) at io/qurl.cpp:3962
#13 0x00007f2d32f502be in QUrlPrivate::normalized (this=0x2438740) at io/qurl.cpp:4059
#14 0x00007f2d32f51975 in QUrl::operator== (this=0x7f2d0f8d29d0, url=...) at io/qurl.cpp:5959
#15 0x00007f2d2a5add6d in Nepomuk::ResourceData::updateKickOffLists (this=0x7f2d1801a710, prop=..., v=...) at /home/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/nepomuk/core/resourcedata.cpp:675
#16 0x00007f2d2a5ae632 in Nepomuk::ResourceData::load (this=0x7f2d1801a710) at /home/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/nepomuk/core/resourcedata.cpp:392
#17 0x00007f2d2a5aec2c in Nepomuk::ResourceData::property (this=0x7f2d1801a710, uri=...) at /home/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/nepomuk/core/resourcedata.cpp:240
#18 0x00007f2d2a5c25f3 in Nepomuk::Resource::property (this=0x7f2d0f8d2cf0, uri=...) at /home/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/nepomuk/core/resource.cpp:301
#19 0x00007f2d138e5f2a in MessageCore::NepomukResourceRetrieverRunnable::run (this=0x27e18e0) at /home/portage/kde-base/kdepim-common-libs-4.8.0-r1/work/kdepim-common-libs-4.8.0/messagecore/asyncnepomukresourceretriever.cpp:47
#20 0x00007f2d32e9bf28 in QThreadPoolThread::run (this=0x24c88e0) at concurrent/qthreadpool.cpp:106
#21 0x00007f2d32ea6e95 in QThreadPrivate::start (arg=0x24c88e0) at thread/qthread_unix.cpp:331
#22 0x00007f2d2c968f2c in start_thread (arg=0x7f2d0f8d3700) at pthread_create.c:301
#23 0x00007f2d31bfa50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f2d0eb1f700 (LWP 10440)):
#0  __lll_lock_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:136
#1  0x00007f2d2c96b1c5 in _L_lock_884 () from /lib64/libpthread.so.0
#2  0x00007f2d2c96b01a in __pthread_mutex_lock (mutex=0x1d75868) at pthread_mutex_lock.c:61
#3  0x00007f2d2b7a74e4 in g_main_context_wakeup (context=0x1d75860) at gmain.c:3781
#4  0x00007f2d32f9390a in QCoreApplication::postEvent (receiver=0x24327f8, event=0x229ffb0, priority=0) at kernel/qcoreapplication.cpp:1250
#5  0x00007f2d32fa24c6 in queued_activate (sender=0x280a9e0, signal=10, c=0x2865c30, argv=<optimized out>, semaphore=0x0) at kernel/qobject.cpp:3156
#6  0x00007f2d32fa502c in QMetaObject::activate (sender=0x280a9e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f2d0eb1e630) at kernel/qobject.cpp:3249
#7  0x00007f2d2d8e7351 in QLocalSocket::error (this=<optimized out>, _t1=QLocalSocket::UnknownSocketError) at .moc/release-shared/moc_qlocalsocket.cpp:117
#8  0x00007f2d2d8ea9a6 in QLocalSocketPrivate::_q_error (this=<optimized out>, socketError=QAbstractSocket::UnknownSocketError) at socket/qlocalsocket_unix.cpp:102
#9  0x00007f2d2d8e74cc in QLocalSocket::qt_metacall (this=0x280a9e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7f2d0eb1e7a0) at .moc/release-shared/moc_qlocalsocket.cpp:91
#10 0x00007f2d32fa50e7 in QMetaObject::activate (sender=0x28653a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f2d0eb1e7a0) at kernel/qobject.cpp:3278
#11 0x00007f2d2d8df811 in QAbstractSocket::error (this=<optimized out>, _t1=QAbstractSocket::UnknownSocketError) at .moc/release-shared/moc_qabstractsocket.cpp:156
#12 0x00007f2d2d8e3cee in QAbstractSocket::waitForReadyRead (this=0x28653a0, msecs=<optimized out>) at socket/qabstractsocket.cpp:1877
#13 0x00007f2d27437a64 in Soprano::Client::ClientConnection::iteratorNext (this=0x24352c0, id=331735314) at /var/tmp/portage/dev-libs/soprano-2.7.3/work/soprano-2.7.3/client/clientconnection.cpp:516
#14 0x00007f2d2743bc3b in Soprano::Client::ClientQueryResultIteratorBackend::next (this=0x27fa020) at /var/tmp/portage/dev-libs/soprano-2.7.3/work/soprano-2.7.3/client/clientqueryresultiteratorbackend.cpp:46
#15 0x00007f2d2a5b1579 in Soprano::Iterator<Soprano::BindingSet>::next (this=<optimized out>) at /usr/include/Soprano/../soprano/iterator.h:239
#16 0x00007f2d2a5ae4f9 in Nepomuk::ResourceData::load (this=0x2823ec0) at /home/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/nepomuk/core/resourcedata.cpp:382
#17 0x00007f2d2a5aec2c in Nepomuk::ResourceData::property (this=0x2823ec0, uri=...) at /home/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/nepomuk/core/resourcedata.cpp:240
#18 0x00007f2d2a5c25f3 in Nepomuk::Resource::property (this=0x7f2d0eb1ecf0, uri=...) at /home/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/nepomuk/core/resource.cpp:301
#19 0x00007f2d138e5f2a in MessageCore::NepomukResourceRetrieverRunnable::run (this=0x27e1460) at /home/portage/kde-base/kdepim-common-libs-4.8.0-r1/work/kdepim-common-libs-4.8.0/messagecore/asyncnepomukresourceretriever.cpp:47
#20 0x00007f2d32e9bf28 in QThreadPoolThread::run (this=0x1ef1420) at concurrent/qthreadpool.cpp:106
#21 0x00007f2d32ea6e95 in QThreadPrivate::start (arg=0x1ef1420) at thread/qthread_unix.cpp:331
#22 0x00007f2d2c968f2c in start_thread (arg=0x7f2d0eb1f700) at pthread_create.c:301
#23 0x00007f2d31bfa50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f2d34657780 (LWP 10309)):
#0  0x00007f2d31becd9d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f2d2b7e9600 in read (__nbytes=16, __buf=0x7fff6a2bdb60, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#2  g_wakeup_acknowledge (wakeup=0x1d74c10) at gwakeup.c:212
#3  0x00007f2d2b7a5519 in g_main_context_check (context=0x1d75860, max_priority=2147483647, fds=0x26f4200, n_fds=14) at gmain.c:2912
#4  0x00007f2d2b7a5e02 in g_main_context_iterate (context=0x1d75860, block=1, dispatch=1, self=<optimized out>) at gmain.c:3086
#5  0x00007f2d2b7a62a1 in g_main_context_iteration (context=0x1d75860, may_block=1) at gmain.c:3152
#6  0x00007f2d32fbb8ef in QEventDispatcherGlib::processEvents (this=0x1d7a830, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#7  0x00007f2d3240b79e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#8  0x00007f2d32f8fce2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007f2d32f8ff24 in QEventLoop::exec (this=0x7fff6a2bdd50, flags=...) at kernel/qeventloop.cpp:201
#10 0x00007f2d32f943ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#11 0x0000000000403709 in main (argc=1, argv=0x7fff6a2be3f8) at /home/portage/kde-base/kontact-4.8.0/work/kontact-4.8.0/kontact/src/main.cpp:218

Possible duplicates by query: bug 228333.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-01-31 19:57:11 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 2 Christophe Giboudeaux 2012-02-06 10:45:26 UTC
reopen. Wrong report.
Comment 3 Christophe Giboudeaux 2012-02-13 11:04:50 UTC
*** Bug 293069 has been marked as a duplicate of this bug. ***
Comment 4 David Faure 2012-10-17 11:28:25 UTC
This is a crash in Nepomuk::ResourceData::updateKickOffLists. I believe it's either bug 305626 (fixed in Qt-4.8.3) or bug 308524 (fixed just now in nepomuk-core).

Closing.