Bug 292917 - VLC can't block KDE screensaver
Summary: VLC can't block KDE screensaver
Status: RESOLVED NOT A BUG
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 140 votes (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 00:01 UTC by RussianNeuroMancer
Modified: 2013-11-19 22:35 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RussianNeuroMancer 2012-01-31 00:01:22 UTC
Version:           unspecified (using KDE 4.8.0) 
OS:                Linux

VLC can't block KDE screensaver.



Reproducible: Didn't try

Steps to Reproduce:
1. Enable KDE screensaver.
2. Be sure blocking screensaver is enabled in VLC (by default it's enabled, if didn't disable it).
3. Watch movie in VLC.

Actual Results:  
Screensaver is enabled while watching movie.

Expected Results:  
Screensaver is not enabled while watching movie.

https://trac.videolan.org/vlc/ticket/5957
According to VLC developers: notvlc bug. With no further data, I have to assume KDE 4.8 again broke compatibility with xdg-utils. Neither of those packages are maintained through this bug tracker. 

Kubuntu 11.10 x86_64 with KDE 4.8 from Kubuntu Backports PPA.
Bug reproduceable for both of latest stable VLC and latest development version of VLC.
Comment 1 zless 2012-04-01 21:09:00 UTC
This is a long time bug not specific to KDE 4.8. If I'm not mistaken I've seen this since the 4.6 era (when I started using KDE).

I don't know if it's just the screen-saver part. For me it's more like the whole power management isn't inhibited because initially the screen gets dimmed and after that the monitor goes blank (blank screen-saver here).
Comment 2 Krasnikov Nikolay 2012-04-03 12:17:47 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Martin Bříza 2013-01-24 14:46:39 UTC
VLC (only when video is playing or paused) does block the screensaver on my installation with Fedora 18 and KDE SC 4.9.4.
Comment 4 RussianNeuroMancer 2013-01-24 14:51:43 UTC
You know, for me VLC was block screensaver on KDE 4.9 too (but only on one laptop; on another laptop with KDE 4.9 screensaver still doesn't get blocked while playback video in VLC). But after upgrade to KDE 4.10 VLC can't block screensaver again.
Comment 5 RussianNeuroMancer 2013-02-02 13:29:05 UTC
Tickets with additional data:
http://trac.videolan.org/vlc/ticket/7824
http://trac.videolan.org/vlc/ticket/4739
Comment 6 HT 2013-02-11 08:03:59 UTC
Same problem, after upgrade to KDE 4.10 (distro ArchLinux) VLC can't block screensaver again.
Comment 7 Patrick 2013-02-15 16:58:13 UTC
It's easy to reproduce this bug with Konsole (KDE 4.10) instead of VLC.

1. Enable the Screen Locker and change the time at 'Start automatically after' to 1 minute.
2. Open Konsole.
3. Find the window id of the Konsole window by using 'xwininfo'.
4. Enter the command 'xdg-screensaver suspend <window id>' where <window id> is the window id of the Konsole window.
5. Wait a minute without using the mouse or keyboard. The Screen Locker activates even though it is inhibited.
Comment 8 Oliver Henshaw 2013-03-08 17:49:40 UTC
As mentioned in http://trac.videolan.org/vlc/ticket/4739#comment:33

* vlc 2.0 and earlier mostly worked with 4.9 and earlier but it only worked as well it did by accident.
* The upcoming vlc 2.1 should work perfectly with kde 4.10

xdg-screensaver again is quite fragile and worked as well as it used to by accident. It's been even more unreliable for gnome for even longer I believe.

This bug is variously INVALID, WONTFIX and FIXED. But we've already fixed a few quirks on the kde side for 4.10.0 and just need vlc 2.1 to be released to (hopefully) settle this.

In the meantime you could untick "Enable power management" in the battery applet while you're watching the movie.
Comment 9 Oscar 2013-11-19 22:11:12 UTC
Doesn't work with Kubuntu 13.10, KDE 4.11.2 and VLC 2.1.
Comment 10 Oscar 2013-11-19 22:35:50 UTC
Disregard my last comment. I thought I had updated to 2.1 but I was still on 2.08. Didn't manage to install 2.1 for some reason, but I now have 2.2.0 (daily build) which works as it should (screensaver doesn't turn on while watching video).