Bug 292510 - Recently added albums widget not displaying with phonon-vlc backend after a songis played
Summary: Recently added albums widget not displaying with phonon-vlc backend after a s...
Status: RESOLVED FIXED
Alias: None
Product: phonon-backend-vlc
Classification: Unclassified
Component: general (show other bugs)
Version: 0.5
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-01-26 20:15 UTC by bill p. (aka google01103)
Modified: 2012-08-21 19:34 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bill p. (aka google01103) 2012-01-26 20:15:18 UTC
Version:           2.5.0
OS:                Linux

Recently added albums widget not displaying with phonon-vlc backend after a song is played. When first started recently added albums widget displays list of new albums as it should but once a track in played the widget is empty with only the heading shown immediately followed with no space by the next widget.

Switching to the Gstreamer backend solves this

Albums widget (showing albums of currently played artist) works fine

This is a recent regression

running:
4.8
Amarok 2.5 from git
phonon-backend-vlc 0.5.0git.1325523840-8.1
libphonon4-4.6.0-79.1.x86_64


Reproducible: Always

Steps to Reproduce:
play a song

Actual Results:  
recent albums is blank

Expected Results:  
recent albums if populated
Comment 1 Myriam Schweingruber 2012-01-27 07:02:48 UTC
Harald, any idea?
Comment 2 bill p. (aka google01103) 2012-02-01 20:23:13 UTC
as of today the widget again works correctly, why? I don't know but it is working so I will close this
Comment 3 bill p. (aka google01103) 2012-02-02 18:38:59 UTC
and of course today it disappears again
Comment 4 Patrick Peronny 2012-06-19 09:51:30 UTC
Hello, 
I can confirm this on Debian testing :
Qt: 4.8.1
KDE Development Platform: 4.7.4 (4.7.4)
Amarok: 2.5.0 (from repository)
phonon-vlc backend 0.5.0

Albums widget not displaying anything at the end of a playlist. If I press stop button on a song, the widget shows correctly.
The bug wasn't here with Amarok 2.4.3.
Can't test with gstreamer backend, I have a recent hardware problem and I have sound only with vlc backend.

Sorry for my bad english.
Comment 5 Myriam Schweingruber 2012-06-19 10:02:16 UTC
Bill and Patrick: could you please try with the 2.6 beta1? We all use post Amarok 2.5 here in the team, might simply be already solved, so no use on insisting on a 2.5 bug that is not reproducible in git :)
Comment 6 bill p. (aka google01103) 2012-06-19 10:19:10 UTC
Myriam - I'm running git ("about Amarok" still says 2.5-git) but I clone and compile weekly (give or take).
Comment 7 Harald Sitter 2012-06-19 15:16:24 UTC
Random guess of the day: it is because amarok ties too many unrelated things to the aboutToFinish signal, which then leads to weird issues when that signal is emitted twice.

I am now going to introduce protection against multi-emission.
Comment 8 Harald Sitter 2012-06-20 15:23:59 UTC
Git commit eff46365383a4faa585a0ca525a749bab241367d by Harald Sitter.
Committed on 20/06/2012 at 17:23.
Pushed by sitter into branch 'master'.

Don't reset members all over the place

resetting too early leads to many abouttofinish signals which screws with
Amarok which likes to bind half it's playback bound features to that
particularly signal.

Hence only reset once we got a new call to PlayInternal at which point
we throw away the old media anyway, so we can be sure that this is the
last point anything from the old media might leak through.

M  +2    -5    src/mediaobject.cpp

http://commits.kde.org/phonon-vlc/eff46365383a4faa585a0ca525a749bab241367d
Comment 9 bill p. (aka google01103) 2012-06-20 15:50:21 UTC
unfortunately can not test 'cause it will not comile for me  phonon-vlc/src/mediacontroller.cpp:326:10: error: ‘BluRay’ was not declared in this scope
Comment 10 Harald Sitter 2012-06-20 16:07:23 UTC
Needs phonon from git master too
Comment 11 Edward Hades 2012-08-18 10:28:12 UTC
phonon-vlc-0.6 has been released with the fix included.

Please test against this version.
Comment 12 Patrick Peronny 2012-08-21 16:24:32 UTC
Problem fixed on my side with the upstream release phonon-vlc-0.6.

My system Debian, everything installed from repository :
Qt: 4.8.2
KDE Development Platform: 4.8.4 (4.8.4)
Amarok: 2.5-GIT
phonon-backend-vlc 0.6.0-1


Thanks !
Comment 13 Myriam Schweingruber 2012-08-21 19:34:02 UTC
Thank you for the feedback.