Bug 292462 - Screen not redrawn properly when returning from full screen
Summary: Screen not redrawn properly when returning from full screen
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 13:46 UTC by Janek Bevendorff
Modified: 2012-01-26 16:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek Bevendorff 2012-01-26 13:46:27 UTC
Version:           unspecified (using Devel) 
OS:                Linux

First of all: I'm not sure whether this is really a KDE problem. It could also be a general problem with X or specifically with TwinView (which only NVIDIA could fix). If this can't be fixed in KDE, please let me know and close this as INVALID.

The problem is that when an application exists full screen mode, the screen isn't redrawn properly and ugly artifacts appear (such as parts of the full screen window still being drawn over the whole screen, gray bars over the plasma panels etc.).
This happens with every application. It happens with Gwenview, it happens with VLC. It even happens with Kwin's full screen mode.

This issue only appears when both my screens are activated (TwinView). It does not appear when using a single-monitor setup.

Reproducible: Always

Steps to Reproduce:
Toggle between normal and full screen mode in an application of your choice.
You can also use Kwin's full screen feature (assign a keyboard shortcut to it).

Actual Results:  
When exiting full screen, artifacts appear on the screen. I have to minimize a window or switch the virtual desktop etc. to redraw the screen.

Note: if you use Kwin's full screen feature and can't reproduce it, retry several times. In Kwin it doesn't happen each time, but often enough.

Expected Results:  
Screen should be redrawn properly.
Comment 1 Martin Flöser 2012-01-26 15:51:29 UTC
are you using desktop effects? If yes do you suspend desktop effects for fullscreen windows?
Comment 2 Janek Bevendorff 2012-01-26 16:09:13 UTC
Yes, indeed. "Suspend desktop effects for fullscreen windows" is checked. When I turn it off, the problem seems to be gone until I turn it on again.

Anyway, no setting should cause such problems. :-)
Comment 3 Martin Flöser 2012-01-26 16:13:49 UTC

*** This bug has been marked as a duplicate of bug 177495 ***