Bug 292420 - KDE Servises crashe on startsystem
Summary: KDE Servises crashe on startsystem
Status: RESOLVED DUPLICATE of bug 284052
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-25 23:49 UTC by Inga_Nest
Modified: 2012-01-26 15:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Inga_Nest 2012-01-25 23:49:11 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.1-2-fbcondecor x86_64
Distribution: "Arch Linux"

-- Information about the crash:
Everytime, when I start my computer, KDE services crashe. When I create a new user it happens again. I have this problem from KDE 4.7.3 only in Archlinux and had not such problem in Kubuntu. KDE was installed from belorus mirrow of official repository. Sometimes later kdelibs and qt were recompiled with abs system for debuging.

The crash can be reproduced every time.

-- Backtrace:
Application: Служба KDE (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff8e26ba780 (LWP 1157))]

Thread 2 (Thread 0x7ff8c7dd6700 (LWP 1164)):
#0  0x00007fff159ff83e in ?? ()
#1  0x00007ff8dce79e6d in clock_gettime () from /lib/librt.so.1
#2  0x00007ff8e123c808 in do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007ff8e130ade9 in QTimerInfoList::updateCurrentTime (this=0x7ff8c00020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007ff8e130b13d in QTimerInfoList::timerWait (this=0x7ff8c00020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007ff8e13099df in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7ff8c7dd5c0c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007ff8e1309a82 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007ff8dcbc4de2 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#9  0x00007ff8dcbc5bed in ?? () from /usr/lib/libglib-2.0.so.0
#10 0x00007ff8dcbc6219 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#11 0x00007ff8e130a1be in QEventDispatcherGlib::processEvents (this=0x7ff8c00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007ff8e12da7cd in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007ff8e12daa04 in QEventLoop::exec (this=0x7ff8c7dd5dc0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007ff8e11e3e7a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007ff8e12bc066 in QInotifyFileSystemWatcherEngine::run (this=0x960cf0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007ff8e11e69b2 in QThreadPrivate::start (arg=0x960cf0) at thread/qthread_unix.cpp:298
#17 0x00007ff8e0f57e7a in start_thread () from /lib/libpthread.so.0
#18 0x00007ff8dfc97bad in clone () from /lib/libc.so.6
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff8e26ba780 (LWP 1157)):
[KCrash Handler]
#6  0x00007ff8e12eced0 in QObject::thread (this=0xa4ea20) at kernel/qobject.cpp:1371
#7  0x00007ff8de004d2f in QDBusConnectionPrivate::activateCall (this=0xa46740, object=0xa4ea20, flags=273, msg=...) at qdbusintegrator.cpp:802
#8  0x00007ff8de0058ba in QDBusConnectionPrivate::activateObject (this=0xa46740, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#9  0x00007ff8de005a95 in QDBusActivateObjectEvent::placeMetaCall (this=0xb2ec10) at qdbusintegrator.cpp:1537
#10 0x00007ff8e12f08d8 in QObject::event (this=0x9b0480, e=<optimized out>) at kernel/qobject.cpp:1195
#11 0x00007ff8e0425903 in QApplicationPrivate::notify_helper (this=0x7fb8b0, receiver=0x9b0480, e=0xb2ec10) at kernel/qapplication.cpp:4550
#12 0x00007ff8e042db8d in QApplication::notify (this=0x7fff15950530, receiver=0x9b0480, e=0xb2ec10) at kernel/qapplication.cpp:3932
#13 0x00007ff8e20a3ef6 in KApplication::notify (this=0x7fff15950530, receiver=0x9b0480, event=0xb2ec10) at /var/abs/local/kdelibs/src/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#14 0x00007ff8e12dbc87 in QCoreApplication::notifyInternal (this=0x7fff15950530, receiver=0x9b0480, event=0xb2ec10) at kernel/qcoreapplication.cpp:876
#15 0x00007ff8e12def21 in sendEvent (event=0xb2ec10, receiver=0x9b0480) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x7372b0) at kernel/qcoreapplication.cpp:1500
#17 0x00007ff8e12df191 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#18 0x00007ff8e130a028 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#20 0x00007ff8dcbc584d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0x00007ff8dcbc6048 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0x00007ff8dcbc6219 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0x00007ff8e130a1a1 in QEventDispatcherGlib::processEvents (this=0x7397d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007ff8e04c81a4 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007ff8e12da7cd in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007ff8e12daa04 in QEventLoop::exec (this=0x7fff159504b0, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007ff8e12df26f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x00007ff8e0423c64 in QApplication::exec () at kernel/qapplication.cpp:3811
#29 0x00007ff8ce68ae35 in kdemain (argc=1, argv=0x7d4a20) at /var/abs/local/kdelibs/src/kdelibs-4.7.4/kded/kded.cpp:924
#30 0x00000000004083e4 in launch (argc=1, _name=0x40af63 "kded4", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40adea "0") at /var/abs/local/kdelibs/src/kdelibs-4.7.4/kinit/kinit.cpp:734
#31 0x00000000004059c9 in main (argc=4, argv=0x7fff00000001, envp=0x7fff15951620) at /var/abs/local/kdelibs/src/kdelibs-4.7.4/kinit/kinit.cpp:1849

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-26 15:47:15 UTC
Please read bug 284052 comment #1, and add the required information to that bug.

*** This bug has been marked as a duplicate of bug 284052 ***