Bug 292323 - Akonadi crashes on startup: MySQL cannot deal with a socket path this long
Summary: Akonadi crashes on startup: MySQL cannot deal with a socket path this long
Status: RESOLVED DUPLICATE of bug 277839
Alias: None
Product: Akonadi
Classification: Unclassified
Component: server (show other bugs)
Version: 4.7
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-24 12:49 UTC by Jörg Steffens
Modified: 2013-06-08 12:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
akonadictl start crash message (6.43 KB, text/x-log)
2012-01-24 12:49 UTC, Jörg Steffens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Steffens 2012-01-24 12:49:43 UTC
Created attachment 68137 [details]
akonadictl start crash message

Version:           4.7 (using KDE 4.7.2) 
OS:                Linux

we are working with long path names as home directories, eg. 
/net/lxclust1.testka.somewhere/space/export/home/dreitest for the user dreitest.

Akonadi can not handle this and crashes on startup.

Reproducible: Always

Steps to Reproduce:
  * create an user account with a long path as home directory: eg. /local/veeeeeeeeeeeeeeeeeeeeeeeeeeeeeerylongpath/testaccount
  * login into KDE with this account
  * start akonadi by: akonadictl start



Actual Results:  
error messages, akonadi not started

Expected Results:  
akonadi should be running

Messages from  "akonadictl start" attached
Comment 1 Rex Dieter 2012-06-25 16:11:25 UTC
long hostnames can trigger this too, witnessed a user hit this today. marking confirmed.
Comment 2 gustavo 2012-07-11 16:51:05 UTC
I've seen the same problem with network users with a home directory at

/home/DOMAIN/USERNAME

whereas for local users the problem doesn't happen.

0: akonadiserver() [0x805d566]
1: akonadiserver() [0x805d821]
2: [0xb76f8400]
3: [0xb76f8424]
4: /lib/i386-linux-gnu/libc.so.6(gsignal+0x4f) [0xb6dce1ef]
5: /lib/i386-linux-gnu/libc.so.6(abort+0x175) [0xb6dd1835]
6: /usr/lib/i386-linux-gnu/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x136) [0xb745f616]
7: akonadiserver() [0x805f9d8]
8: /usr/lib/i386-linux-gnu/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0xc9) [0xb7508e59]
9: /usr/lib/i386-linux-gnu/libQtCore.so.4(+0x112c7d) [0xb7515c7d]
10: /usr/lib/i386-linux-gnu/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3e) [0xb751f7ce]
11: akonadiserver() [0x8056b35]
12: akonadiserver() [0x8055fdb]
13: /lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0xb6db94d3]
14: akonadiserver() [0x80569d1]
Comment 3 Christophe Giboudeaux 2013-06-08 12:41:02 UTC

*** This bug has been marked as a duplicate of bug 277839 ***