Bug 292246 - Closing two-slide presentation
Summary: Closing two-slide presentation
Status: RESOLVED DUPLICATE of bug 291858
Alias: None
Product: calligrastage
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: T Zachmann
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-23 02:25 UTC by Robert Downing
Modified: 2012-01-24 14:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Downing 2012-01-23 02:25:52 UTC
Application: calligrastage (2.4 Beta 6)
KDE Platform Version: 4.7.97 (4.8 RC2 (4.7.97)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Closing the application. It had a two-slide (titles only, no content) presentation open.

-- Backtrace:
Application: Stage (calligrastage), signal: Segmentation fault
[Current thread is 1 (Thread 0xb40d1950 (LWP 13396))]

Thread 3 (Thread 0xb0222b70 (LWP 13397)):
#0  0xb52b5dbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb7653f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb51dd839 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb51ddc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb6579b37 in QEventDispatcherGlib::processEvents (this=0x9cb5738, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb654a1dd in QEventLoop::processEvents (this=0xb02222a0, flags=...) at kernel/qeventloop.cpp:149
#6  0xb654a421 in QEventLoop::exec (this=0xb02222a0, flags=...) at kernel/qeventloop.cpp:201
#7  0xb644d90b in QThread::exec (this=0x9cca870) at thread/qthread.cpp:498
#8  0xb652ae2d in QInotifyFileSystemWatcherEngine::run (this=0x9cca870) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb64507b3 in QThreadPrivate::start (arg=0x9cca870) at thread/qthread_unix.cpp:331
#10 0xb52b3d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb76460ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xae539b70 (LWP 13401)):
#0  0xb4d47d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb64a77d5 in do_gettime (frac=0xae539010, sec=0xae539008) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb657a4b6 in QTimerInfoList::updateCurrentTime (this=0x9ea70d4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb657a80a in QTimerInfoList::timerWait (this=0x9ea70d4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6579053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xae53911c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb65790ed in timerSourcePrepare (source=0x9ea70a0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb51dc88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb51dd637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb51ddc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6579b37 in QEventDispatcherGlib::processEvents (this=0x9e329e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb654a1dd in QEventLoop::processEvents (this=0xae5392a0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb654a421 in QEventLoop::exec (this=0xae5392a0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb644d90b in QThread::exec (this=0x9c3e558) at thread/qthread.cpp:498
#14 0xb652ae2d in QInotifyFileSystemWatcherEngine::run (this=0x9c3e558) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb64507b3 in QThreadPrivate::start (arg=0x9c3e558) at thread/qthread_unix.cpp:331
#16 0xb52b3d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb76460ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb40d1950 (LWP 13396)):
[KCrash Handler]
#7  0xb5d450d4 in KoList::listContinuedFrom (this=0x0) at /build/buildd/calligra-2.3.86/libs/kotext/KoList.cpp:233
#8  0xb5fabdc8 in ListItemsHelper::recalculateBlock (this=0xbfb5189c, block=...) at /build/buildd/calligra-2.3.86/libs/textlayout/ListItemsHelper.cpp:263
#9  0xb5f8ebe5 in KoTextLayoutArea::layoutBlock (this=0xa3207c8, cursor=0xa7d39b8) at /build/buildd/calligra-2.3.86/libs/textlayout/KoTextLayoutArea.cpp:748
#10 0xb5f92204 in KoTextLayoutArea::layout (this=0xa3207c8, cursor=0xa7d39b8) at /build/buildd/calligra-2.3.86/libs/textlayout/KoTextLayoutArea.cpp:580
#11 0xb5fa455c in KoTextLayoutRootArea::layoutRoot (this=0xa3207c8, cursor=0xa7d39b8) at /build/buildd/calligra-2.3.86/libs/textlayout/KoTextLayoutRootArea.cpp:63
#12 0xb5fa6bb3 in KoTextDocumentLayout::doLayout (this=0xa2fd460) at /build/buildd/calligra-2.3.86/libs/textlayout/KoTextDocumentLayout.cpp:620
#13 0xb5fa7678 in layout (this=0xa2fd460) at /build/buildd/calligra-2.3.86/libs/textlayout/KoTextDocumentLayout.cpp:569
#14 KoTextDocumentLayout::layout (this=0xa2fd460) at /build/buildd/calligra-2.3.86/libs/textlayout/KoTextDocumentLayout.cpp:552
#15 0xb5fa4f98 in KoTextDocumentLayout::executeScheduledLayout (this=0xa2fd460) at /build/buildd/calligra-2.3.86/libs/textlayout/KoTextDocumentLayout.cpp:760
#16 0xb5fa529c in KoTextDocumentLayout::qt_metacall (this=0xa2fd460, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xa7ac928) at /build/buildd/calligra-2.3.86/obj-i686-linux-gnu/libs/textlayout/KoTextDocumentLayout.moc:89
#17 0xb6551b7d in metacall (argv=0xa7ac928, idx=18, cl=QMetaObject::InvokeMetaMethod, object=0xa2fd460) at kernel/qmetaobject.cpp:237
#18 QMetaObject::metacall (object=0xa2fd460, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0xa7ac928) at kernel/qmetaobject.cpp:232
#19 0xb655c685 in QMetaCallEvent::placeMetaCall (this=0xa848d68, object=0xa2fd460) at kernel/qobject.cpp:535
#20 0xb6563b52 in QObject::event (this=0xa2fd460, e=0xa848d68) at kernel/qobject.cpp:1217
#21 0xb6aa6d84 in notify_helper (e=0xa848d68, receiver=0xa2fd460, this=0x992f790) at kernel/qapplication.cpp:4486
#22 QApplicationPrivate::notify_helper (this=0x992f790, receiver=0xa2fd460, e=0xa848d68) at kernel/qapplication.cpp:4458
#23 0xb6aac133 in QApplication::notify (this=0xa848d68, receiver=0xa2fd460, e=0xa848d68) at kernel/qapplication.cpp:3886
#24 0xb558a011 in KApplication::notify (this=0xbfb52550, receiver=0xa2fd460, event=0xa848d68) at ../../kdeui/kernel/kapplication.cpp:311
#25 0xb654b19e in QCoreApplication::notifyInternal (this=0xbfb52550, receiver=0xa2fd460, event=0xa848d68) at kernel/qcoreapplication.cpp:787
#26 0xb654ef93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x98e0520) at kernel/qcoreapplication.cpp:1428
#28 0xb654f0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#29 0xb65796a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=0x9931fc8) at kernel/qeventdispatcher_glib.cpp:277
#31 0xb51dd25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb51dd990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb51ddc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb6579ada in QEventDispatcherGlib::processEvents (this=0x98e1248, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#35 0xb6b5ee7a in QGuiEventDispatcherGlib::processEvents (this=0x98e1248, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#36 0xb654a1dd in QEventLoop::processEvents (this=0xbfb524e4, flags=...) at kernel/qeventloop.cpp:149
#37 0xb654a421 in QEventLoop::exec (this=0xbfb524e4, flags=...) at kernel/qeventloop.cpp:201
#38 0xb654f19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#39 0xb6aa4924 in QApplication::exec () at kernel/qapplication.cpp:3760
#40 0xb770afdd in kdemain (argc=1, argv=0xbfb52654) at /build/buildd/calligra-2.3.86/stage/part/main.cpp:44
#41 0x0804850b in main (argc=1, argv=0xbfb52654) at /build/buildd/calligra-2.3.86/obj-i686-linux-gnu/stage/part/calligrastage_dummy.cpp:3

Reported using DrKonqi
Comment 1 Gopalakrishna Bhat 2012-01-24 14:09:25 UTC
Please check with the latest code and feel free to reopen if the problem still exists.

*** This bug has been marked as a duplicate of bug 291858 ***