Bug 292053 - Amarok crashes when launched
Summary: Amarok crashes when launched
Status: RESOLVED DUPLICATE of bug 280774
Alias: None
Product: amarok
Classification: Applications
Component: Collections/DAAP (show other bugs)
Version: 2.5.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 18:10 UTC by shaddowy2
Modified: 2012-01-21 14:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shaddowy2 2012-01-20 18:10:42 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.2.1-030201-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was launching Amarok as normal, but after seeing the main window for about 1 second it crashes everytime. I think its related to the daap plugin, as I was running at the same time Rhythmbox 2.95 with a daap server enabled. Maybe Amarok has some problems with the correct discovery the daap share? 
I tagged it as a possible duplicate of another bug report which was for Amarok 2.4. Maybe a developer can comfirm it's the same bug still present in version 2.5 and close my report.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8d24af87a0 (LWP 14485))]

Thread 9 (Thread 0x7f8d075b1700 (LWP 14487)):
#0  0x00007f8d1dc47034 in __pthread_mutex_lock (mutex=0x1e816c8) at pthread_mutex_lock.c:61
#1  0x00007f8d1c19ee5d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8d1c19fdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8d1c1a0792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8d0f19a516 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5  0x00007f8d1c1c52b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f8d1dc44efc in start_thread (arg=0x7f8d075b1700) at pthread_create.c:304
#7  0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f8ccb29e700 (LWP 14491)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8cfcd2fd54 in ?? () from /usr/lib/libvlccore.so.4
#2  0x00007f8d1dc44efc in start_thread (arg=0x7f8ccb29e700) at pthread_create.c:304
#3  0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f8cc5883700 (LWP 14494)):
#0  0x00007fff2db307b6 in ?? ()
#1  0x00007f8d1a9d107b in __GI_clock_gettime (clock_id=1, tp=0x7f8cc5882b20) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f8d21cf7074 in do_gettime (frac=0x7f8cc5882b38, sec=0x7f8cc5882b30) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f8d21db96ed in QTimerInfoList::updateCurrentTime (this=0x2773e60) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007f8d21db9a33 in QTimerInfoList::timerWait (this=0x2773e60, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007f8d21db844c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f8cc5882c1c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f8d21db84f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f8d1c19eff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f8d1c19fdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f8d1c1a0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f8d21db8f3e in QEventDispatcherGlib::processEvents (this=0x23d7e90, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007f8d21d8ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f8d21d8cef7 in QEventLoop::exec (this=0x7f8cc5882db0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007f8d21ca427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007f8d21d6fcbf in QInotifyFileSystemWatcherEngine::run (this=0x2742ab0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f8d21ca6d05 in QThreadPrivate::start (arg=0x2742ab0) at thread/qthread_unix.cpp:331
#17 0x00007f8d1dc44efc in start_thread (arg=0x7f8cc5883700) at pthread_create.c:304
#18 0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f8cc31cc700 (LWP 14495)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8d21ca71ab in wait (time=18446744073709551615, this=0x2cb2c90) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2bc37c0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8d1f1d7864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2cb2480, th=0x2cb1ac0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8d1f1d9e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb1ac0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb1ac0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f8d1f1d8ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f8cc31cbe00, parent=0x2cb2480, th=0x2cb1ac0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f8d1f1d8d5b in ThreadWeaver::Thread::run (this=0x2cb1ac0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f8d21ca6d05 in QThreadPrivate::start (arg=0x2cb1ac0) at thread/qthread_unix.cpp:331
#9  0x00007f8d1dc44efc in start_thread (arg=0x7f8cc31cc700) at pthread_create.c:304
#10 0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f8cc29cb700 (LWP 14496)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8d21ca71ab in wait (time=18446744073709551615, this=0x2cb2c90) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2bc37c0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8d1f1d7864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2cb2480, th=0x2cb2950) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8d1f1d9e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb2950) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb2950) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb2950) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb2950) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb2950) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#9  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb2950) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#10 0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb2950) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0x00007f8d1f1d8ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f8cc29cae00, parent=0x2cb2480, th=0x2cb2950) at ../../../threadweaver/Weaver/Thread.cpp:87
#12 0x00007f8d1f1d8d5b in ThreadWeaver::Thread::run (this=0x2cb2950) at ../../../threadweaver/Weaver/Thread.cpp:142
#13 0x00007f8d21ca6d05 in QThreadPrivate::start (arg=0x2cb2950) at thread/qthread_unix.cpp:331
#14 0x00007f8d1dc44efc in start_thread (arg=0x7f8cc29cb700) at pthread_create.c:304
#15 0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#16 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f8cc21ca700 (LWP 14497)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8d21ca71ab in wait (time=18446744073709551615, this=0x2cb2c90) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2bc37c0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8d1f1d7864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2cb2480, th=0x2cb5c20) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8d1f1d9e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2cb5c20) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8d1f1d8ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f8cc21c9e00, parent=0x2cb2480, th=0x2cb5c20) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f8d1f1d8d5b in ThreadWeaver::Thread::run (this=0x2cb5c20) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f8d21ca6d05 in QThreadPrivate::start (arg=0x2cb5c20) at thread/qthread_unix.cpp:331
#8  0x00007f8d1dc44efc in start_thread (arg=0x7f8cc21ca700) at pthread_create.c:304
#9  0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f8cc159a700 (LWP 14498)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8d21ca71ab in wait (time=18446744073709551615, this=0x2cb2c90) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2bc37c0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8d1f1d7864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2cb2480, th=0x2d1a640) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8d1f1d9e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2d1a640) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2d1a640) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f8d1f1d9e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cb5380, th=0x2d1a640) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f8d1f1d8ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f8cc1599e00, parent=0x2cb2480, th=0x2d1a640) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f8d1f1d8d5b in ThreadWeaver::Thread::run (this=0x2d1a640) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f8d21ca6d05 in QThreadPrivate::start (arg=0x2d1a640) at thread/qthread_unix.cpp:331
#10 0x00007f8d1dc44efc in start_thread (arg=0x7f8cc159a700) at pthread_create.c:304
#11 0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f8cc0174700 (LWP 14501)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8d1e220fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f8d1e221019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f8d1dc44efc in start_thread (arg=0x7f8cc0174700) at pthread_create.c:304
#4  0x00007f8d2144689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8d24af87a0 (LWP 14485)):
[KCrash Handler]
#6  qVariantToHelper<QString> (t=QVariant::String, d=<optimized out>, handler=<optimized out>) at kernel/qvariant.cpp:2101
#7  QVariant::toString (this=0x21) at kernel/qvariant.cpp:2133
#8  0x00007f8ccae87d95 in Daap::Reader::contentCodesReceived (this=0x7f8cb4002350, error=<optimized out>) at ../../../../../src/core-impl/collections/daap/daapreader/Reader.cpp:124
#9  0x00007f8ccae8a519 in Daap::Reader::qt_metacall (this=0x7f8cb4002350, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2da642c0) at ./Reader.moc:94
#10 0x00007f8d21da0eba in QMetaObject::activate (sender=0x7f8cb4002dc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff2da642c0) at kernel/qobject.cpp:3278
#11 0x00007f8d2075a54f in QHttp::requestFinished (this=<optimized out>, _t1=1, _t2=false) at .moc/release-shared/moc_qhttp.cpp:191
#12 0x00007f8d20762c68 in QHttpPrivate::finishedWithSuccess (this=0x7f8cb4002eb0) at access/qhttp.cpp:2530
#13 0x00007f8d2076315a in QHttp::qt_metacall (this=0x7f8cb4002dc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2bc7450) at .moc/release-shared/moc_qhttp.cpp:135
#14 0x00007f8ccae8c850 in Daap::ContentFetcher::qt_metacall (this=0x7f8cb4002dc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2bc7450) at ./contentfetcher.moc:71
#15 0x00007f8d21da4a5e in QObject::event (this=0x7f8cb4002dc0, e=<optimized out>) at kernel/qobject.cpp:1217
#16 0x00007f8d2278e474 in notify_helper (e=0x42378f0, receiver=0x7f8cb4002dc0, this=0x1d4e200) at kernel/qapplication.cpp:4486
#17 QApplicationPrivate::notify_helper (this=0x1d4e200, receiver=0x7f8cb4002dc0, e=0x42378f0) at kernel/qapplication.cpp:4458
#18 0x00007f8d227932e1 in QApplication::notify (this=0x7fff2da64b70, receiver=0x7f8cb4002dc0, e=0x42378f0) at kernel/qapplication.cpp:4365
#19 0x00007f8d24502466 in KApplication::notify (this=0x7fff2da64b70, receiver=0x7f8cb4002dc0, event=0x42378f0) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f8d21d8dafc in QCoreApplication::notifyInternal (this=0x7fff2da64b70, receiver=0x7f8cb4002dc0, event=0x42378f0) at kernel/qcoreapplication.cpp:787
#21 0x00007f8d21d9151f in sendEvent (event=0x42378f0, receiver=0x7f8cb4002dc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1bc8430) at kernel/qcoreapplication.cpp:1428
#23 0x00007f8d21db8a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#25 0x00007f8d1c19fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f8d1c1a0258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f8d1c1a0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f8d21db8ed6 in QEventDispatcherGlib::processEvents (this=0x1bc9f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#29 0x00007f8d2283610e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f8d21d8ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f8d21d8cef7 in QEventLoop::exec (this=0x7fff2da64b00, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007f8d21d91789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#33 0x0000000000408e2e in main (argc=1, argv=0x7fff2da66ff8) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 280774.

Possible duplicates by query: bug 280774.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-01-21 14:17:29 UTC

*** This bug has been marked as a duplicate of bug 280774 ***