Bug 292016 - first boot muon cannot start.. (reproducible easily)
Summary: first boot muon cannot start.. (reproducible easily)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 06:52 UTC by marcandrebenoit
Modified: 2012-01-20 07:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.14 KB, text/plain)
2012-01-20 07:06 UTC, marcandrebenoit
Details
New crash information added by DrKonqi (7.14 KB, text/plain)
2012-01-20 07:06 UTC, marcandrebenoit
Details
New crash information added by DrKonqi (7.14 KB, text/plain)
2012-01-20 07:06 UTC, marcandrebenoit
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marcandrebenoit 2012-01-20 06:52:38 UTC
Version:           unspecified (using KDE 4.7.3) 
OS:                Linux

starting it up to update a fresh new install
doesn't start completely, only shows emptied main window
when the cash reporter starts i accept to install the debug symbols.. so i have the backtrace.. when i try to send it.. the reporter bugs as well :) 
(gives me : unknown protocol https ...)
so now the backtrace i have is in additional information.. enjoy!
tell me if you need other logs.. 

Reproducible: Always

Steps to Reproduce:
just start it up.. then it just open main window emptied.. then crash reporting assistant starts..

Actual Results:  
same as above.. just crashes..

Expected Results:  
expecting it not to crash and start properly :)

Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb776e930 (LWP 3861))]

Thread 2 (Thread 0xb596db70 (LWP 3862)):
#0  0x009bd416 in __kernel_vsyscall ()
#1  0x00a8140e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x057b334b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x057a4896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x057a4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00563b37 in QEventDispatcherGlib::processEvents (this=0x8dd17b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x005341dd in QEventLoop::processEvents (this=0xb596d2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00534421 in QEventLoop::exec (this=0xb596d2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0043790b in QThread::exec (this=0x8de1740) at thread/qthread.cpp:498
#9  0x00514e2d in QInotifyFileSystemWatcherEngine::run (this=0x8de1740) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0043a7b3 in QThreadPrivate::start (arg=0x8de1740) at thread/qthread_unix.cpp:331
#11 0x00990d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00a900ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb776e930 (LWP 3861)):
[KCrash Handler]
#7  0x0048ee11 in QtPrivate::QStringList_contains (that=0xbf9d9234, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9d9234) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8d81348) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8d81348, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9d9454) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0053bb7d in metacall (argv=0xbf9d9454, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8d81348) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8d81348, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9d9454) at kernel/qmetaobject.cpp:232
#13 0x0054aa6a in QMetaObject::activate (sender=0x8ed03c8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8ed03c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8ed03c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9d9598) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0053bb7d in metacall (argv=0xbf9d9598, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8ed03c8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8ed03c8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9d9598) at kernel/qmetaobject.cpp:232
#18 0x0054aa6a in QMetaObject::activate (sender=0x8d81348, m=0x80950c0, local_signal_index=0, argv=0xbf9d9598) at kernel/qobject.cpp:3278
#19 0x00fa47c5 in MuonMainWindow::backendReady (this=0x8d81348, _t1=0x8da3438) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00fa4933 in MuonMainWindow::initObject (this=0x8d81348) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8d81348) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8d81348, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9d96c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0053bb7d in metacall (argv=0xbf9d96c4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8d81348) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8d81348, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9d96c4) at kernel/qmetaobject.cpp:232
#25 0x0054aa6a in QMetaObject::activate (sender=0x8de5f88, m=0x66b238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00552375 in QSingleShotTimer::timeout (this=0x8de5f88) at .moc/release-shared/qtimer.moc:82
#27 0x0055242c in QSingleShotTimer::timerEvent (this=0x8de5f88) at kernel/qtimer.cpp:308
#28 0x0054d994 in QObject::event (this=0x8de5f88, e=0xbf9d9abc) at kernel/qobject.cpp:1181
#29 0x0386ed54 in notify_helper (e=0xbf9d9abc, receiver=0x8de5f88, this=0x8c9a5e0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8c9a5e0, receiver=0x8de5f88, e=0xbf9d9abc) at kernel/qapplication.cpp:4458
#31 0x03874103 in QApplication::notify (this=0xbf9d9abc, receiver=0x8de5f88, e=0xbf9d9abc) at kernel/qapplication.cpp:3886
#32 0x011bf681 in KApplication::notify (this=0xbf9d9dd0, receiver=0x8de5f88, event=0xbf9d9abc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0053519e in QCoreApplication::notifyInternal (this=0xbf9d9dd0, receiver=0x8de5f88, event=0xbf9d9abc) at kernel/qcoreapplication.cpp:787
#34 0x00565c10 in sendEvent (event=0xbf9d9abc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8c9bc34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00563122 in timerSourceDispatch (source=0x8c9bc00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x057a425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x057a4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x057a4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00563ada in QEventDispatcherGlib::processEvents (this=0x8c7d238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03926e3a in QGuiEventDispatcherGlib::processEvents (this=0x8c7d238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005341dd in QEventLoop::processEvents (this=0xbf9d9d34, flags=...) at kernel/qeventloop.cpp:149
#43 0x00534421 in QEventLoop::exec (this=0xbf9d9d34, flags=...) at kernel/qeventloop.cpp:201
#44 0x0053919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0386c8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61
Comment 1 marcandrebenoit 2012-01-20 07:06:33 UTC
Created attachment 68029 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

i shutdown the computer,then booted up again..
then waited for the system to bootup after login in..
then just started muon again.. the main window (all emptied up) appared for a longer period but still crashed in the end.. i closed the crash reporter by clicking try to restart button..
crashed again.. and here is this one..

as a side note.. i used an iso downloaded from the cdimage.mirror torrent file..in case you were wondering.. and i did a cd crc check before install.. and my ram is just fine.. did a memory test aswell..

-- Backtrace (Reduced):
#7  0x001cfe11 in QtPrivate::QStringList_contains (that=0xbfc3b7c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc3b7c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x991ccf0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x991ccf0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc3b9e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0027cb7d in metacall (argv=0xbfc3b9e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x991ccf0) at kernel/qmetaobject.cpp:237
Comment 2 marcandrebenoit 2012-01-20 07:06:33 UTC
Created attachment 68030 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

i shutdown the computer,then booted up again..
then waited for the system to bootup after login in..
then just started muon again.. the main window (all emptied up) appared for a longer period but still crashed in the end.. i closed the crash reporter by clicking try to restart button..
crashed again.. and here is this one..

as a side note.. i used an iso downloaded from the cdimage.mirror torrent file..in case you were wondering.. and i did a cd crc check before install.. and my ram is just fine.. did a memory test aswell..

-- Backtrace (Reduced):
#7  0x001cfe11 in QtPrivate::QStringList_contains (that=0xbfc3b7c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc3b7c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x991ccf0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x991ccf0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc3b9e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0027cb7d in metacall (argv=0xbfc3b9e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x991ccf0) at kernel/qmetaobject.cpp:237
Comment 3 marcandrebenoit 2012-01-20 07:06:33 UTC
Created attachment 68031 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

i shutdown the computer,then booted up again..
then waited for the system to bootup after login in..
then just started muon again.. the main window (all emptied up) appared for a longer period but still crashed in the end.. i closed the crash reporter by clicking try to restart button..
crashed again.. and here is this one..

as a side note.. i used an iso downloaded from the cdimage.mirror torrent file..in case you were wondering.. and i did a cd crc check before install.. and my ram is just fine.. did a memory test aswell..

-- Backtrace (Reduced):
#7  0x001cfe11 in QtPrivate::QStringList_contains (that=0xbfc3b7c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc3b7c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x991ccf0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x991ccf0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc3b9e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0027cb7d in metacall (argv=0xbfc3b9e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x991ccf0) at kernel/qmetaobject.cpp:237
Comment 4 marcandrebenoit 2012-01-20 07:09:37 UTC
i'm now in the process of doing a sudo apt-get upgrade.. to see if this changes anything..
Comment 5 Thijs 2012-01-20 07:47:40 UTC
This is a known bug, but unfortunately not something that seems to be on KDEs side, but rather an ubuntu specific bug.

*** This bug has been marked as a duplicate of bug 291262 ***