Bug 291998 - regression in kde4rc handling
Summary: regression in kde4rc handling
Status: RESOLVED INTENTIONAL
Alias: None
Product: plasma4
Classification: Unclassified
Component: desktop (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 22:23 UTC by Nicolas L.
Modified: 2012-01-29 12:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas L. 2012-01-19 22:23:38 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Hi,

in mandriva we use /etc/kde4rc to define profiles where we store our default configuration.

we have /var/lib/mandriva/kde4-profiles/common/share/config/plasma-desktop- appletsrc which was used at first login as default config file but since kde 4.7.95 this doesn't work anymore ( was working in kde 4.7.91 )

Reproducible: Always

Steps to Reproduce:
use a kde4rc file to point to config files, in mdv we have :

[Directories-default]
prefixes=/var/lib/mandriva/kde4-profiles/common,/var/lib/mandriva/kde4-profiles/free

Actual Results:  
Default vanilla kde desktop is started

Expected Results:  
Mandriva customised desktop
Comment 1 Balcaen John 2012-01-19 22:52:46 UTC
Since we're using currently the same solution to provides a different panel we're also affected on mageia.
Is there anything i can do to provides more information ?
Comment 2 Balcaen John 2012-01-20 00:56:26 UTC
Reversing this commit ( https://projects.kde.org/projects/kde/kdelibs/repository/revisions/7daa7c1f96a092ca8a72a2c0686d0f5adb6cfe35 ) fix the issue for me.
Comment 3 Aaron J. Seigo 2012-01-29 12:11:53 UTC
using rc files for defaults for plasma-desktop is incorrect and can lead to other issues. there has been a replacement mechanism that is far more powerful for at least the last 3 releases, perhaps 4: javascript desktop scripting.

see: http://techbase.kde.org/KDE_System_Administration/PlasmaDesktopScripting

there are also a number of examples to be found in the kdeexamples git module (https://projects.kde.org/projects/kde/kdeexamples) in the plasma/javascript/shell-scripting directory.