Bug 291779 - Missing "Open with" context menu entry on for unpacking and opening in a dedicated viewer
Summary: Missing "Open with" context menu entry on for unpacking and opening in a dedi...
Status: RESOLVED DUPLICATE of bug 179066
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.16
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 14:42 UTC by René Krell
Modified: 2012-01-17 16:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Krell 2012-01-17 14:42:15 UTC
Version:           2.16 (using KDE 4.7.4) 
OS:                Linux

Currently I see no possibility in Ark to view a packed file in a dedicated application. For example an XML file cannot be opened as a text file in kwrite, but there is chosen some default setting (from Kate) or what'o'ever, opening the XML in some preview, not showing elements and tags.

A gimmick would be unpacking all files in a temporary folder and launch/open some file in a dedicated application, using the root directory of the unpacked files as working directory.

Reproducible: Always

Steps to Reproduce:
Open an archive containing XML files (tested from a mail in Thunderbird).

Actual Results:  
Clicking on a XML file in Ark opens some standard preview not showing tags and elements (and syntax highlighting). A context menu doesn't exist.

Expected Results:  
There should be a context menu entry "Open with ..." on each packaged file in the Ark viewer, adding the ability to open the packaged file in an explicit application of my choice.


OS: Linux (x86_64) release 3.2.0-2-desktop
Compiler: gcc
Comment 1 Raphael Kubo da Costa 2012-01-17 16:46:12 UTC
Hi. You report touches two separate issues: the issue with previewing XML is that the KHTML KPart is usually associated with the XML mimetype with a higher priority than Katepart, so Ark uses it to preview the file instead of Kate. This is bug 201162. Currently, a possible workaround involves going to System Settings -> File Associations, choosing the "application/xml" mimetype and giving Katepart a higher proriority in the "Embedding" tab.

As for the "open with" problem, this is a long-known issue, and is being tracked in bug 179066. I'm closing this one as a duplicate of it.

*** This bug has been marked as a duplicate of bug 179066 ***