Bug 291733 - aterm and xterm don't maximize correctly
Summary: aterm and xterm don't maximize correctly
Status: RESOLVED DUPLICATE of bug 265568
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.7.1
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 06:46 UTC by draggor
Modified: 2012-01-17 07:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description draggor 2012-01-17 06:46:49 UTC
Version:           4.7.1 (using KDE 4.7.1) 
OS:                Linux

When maximizing aterm and xterm, there is still space along all the edges.  If the taskbar is hidden, and borders are removed, this should fill the screen, and has in previous versions of KDE4.  It should look like you have made the window full screen, but still get access to the auto-hide task bar.  Here is a link to an album with screenshots for comparison: http://imgur.com/a/xcGfQ

Reproducible: Didn't try

Steps to Reproduce:
Start aterm, and through any means, maximize the window.

Actual Results:  
It "maximized" but still left space surrounding the window.

Expected Results:  
There should be no view of the desktop around a maximized window.

Imgur album link: http://imgur.com/a/xcGfQ
Comment 1 Thomas Lübking 2012-01-17 07:34:12 UTC
kcmshell4 kwinrules, size & position, obey geometry restrictions, force: no

those windows carry hints to only have sizes by multiples of n,m != 1,1 and therefore cannot be resized to arbitrary dimensions.

those hints used to be ignored while the window was maximized, but
a) *term clients set those hints for debatable reasons (to make window managers show their dimensions by chars instead of pixels)
b) ignoring the hints breaks clients which set them for actually a reason (and you had to add a workaround for those clients which made correct use of them)

*** This bug has been marked as a duplicate of bug 265568 ***