Bug 291676 - Device Items resize on hover due to visibility change of the status text
Summary: Device Items resize on hover due to visibility change of the status text
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-devicenotifier (show other bugs)
Version: 4.9-git
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-01-16 17:35 UTC by Marc Schiffbauer
Modified: 2012-08-26 11:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer 2012-01-16 17:35:00 UTC
Version:           unspecified (using Devel) 
OS:                Linux

The devicenotifier widget has some major glitches in the recent 4.8 RCs which are regressions compared to 4.7.

It would be nice if this could be addressed before 4.8. final release, thanks.


Reproducible: Didn't try

Steps to Reproduce:
Click on the device manager with some devices in it, I have 8 NFS devices here.
Hover the mouse over the listed entries, play with it: e.g. Mount some devices
then unmount them.


Actual Results:  
Its very hard to mount/unmount devices because the space that each entry
consumes is changing as soon as the mouse pointer is over it, which make the
whole list extremely bumpy und jumpy.

The last item in the list is worst: its not completely unusable.


Expected Results:  
Items should not change their height while hovering the ouse over it. Please either resever enough space so that one additional line can be shown or wait until item is cliked.
Comment 1 Marc Schiffbauer 2012-03-19 10:13:12 UTC
Bug still present in 4.8.1
Comment 2 Marc Schiffbauer 2012-04-22 08:00:26 UTC
Bug still present in 4.8.2+ and very annoying
Comment 3 Janek Bevendorff 2012-06-07 22:18:59 UTC
Still jumpy in 4.8.80 due to free space shown on mounted devices only.
A possible fix would be the reserve the space or implement #223687.
Comment 4 Marc Schiffbauer 2012-06-29 23:18:41 UTC
This really annoying regression is still present in current KDE/4.9 branch
Comment 5 Jacopo De Simoi 2012-08-26 11:33:09 UTC
Git commit 1707b49a320fa5837fafde1524ce5485e58bc56f by Jacopo De Simoi.
Committed on 26/08/2012 at 13:22.
Pushed by jacopods into branch 'KDE/4.8'.

Reserve space for text and free space bar

Reserve the height for the text and the
free space bar while invisible, to avoid jumpyness
FIXED-IN:4.9.1

M  +31   -19   plasma/generic/applets/devicenotifier/package/contents/ui/DeviceItem.qml

http://commits.kde.org/kde-workspace/1707b49a320fa5837fafde1524ce5485e58bc56f
Comment 6 Jacopo De Simoi 2012-08-26 11:33:10 UTC
Git commit ef51c94291b85918ccfc8a1f27fae5f0f67622fb by Jacopo De Simoi.
Committed on 26/08/2012 at 13:22.
Pushed by jacopods into branch 'KDE/4.9'.

Reserve space for text and free space bar

Reserve the height for the text and the
free space bar while invisible, to avoid jumpyness
FIXED-IN:4.9.1

M  +31   -19   plasma/generic/applets/devicenotifier/package/contents/ui/DeviceItem.qml

http://commits.kde.org/kde-workspace/ef51c94291b85918ccfc8a1f27fae5f0f67622fb
Comment 7 Jacopo De Simoi 2012-08-26 11:33:11 UTC
Git commit 5b1cf302c6bc344807558a3cb5b3ee8e72e4a52a by Jacopo De Simoi.
Committed on 26/08/2012 at 13:22.
Pushed by jacopods into branch 'master'.

Reserve space for text and free space bar

Reserve the height for the text and the
free space bar while invisible, to avoid jumpyness
FIXED-IN:4.9.1

M  +31   -19   plasma/generic/applets/devicenotifier/package/contents/ui/DeviceItem.qml

http://commits.kde.org/kde-workspace/5b1cf302c6bc344807558a3cb5b3ee8e72e4a52a