Bug 291643 - ALT-TAB shows switcher on wrong X screen (dual head) most of the time
Summary: ALT-TAB shows switcher on wrong X screen (dual head) most of the time
Status: RESOLVED DUPLICATE of bug 256242
Alias: None
Product: kwin
Classification: Unclassified
Component: tabbox (show other bugs)
Version: 4.7.4
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 10:30 UTC by Thomas Boerkel
Modified: 2012-01-16 17:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
xorg.conf (4.89 KB, text/plain)
2012-01-16 10:30 UTC, Thomas Boerkel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Boerkel 2012-01-16 10:30:29 UTC
Created attachment 67883 [details]
xorg.conf

Version:           4.7.4 (using KDE 4.7.4) 
OS:                Linux

I have a dual head configuration (2 separate X screens). No Xinerama, no Nvidia TwinView. I am using the main X screen (1920x1200) on my TFT display for working and the second X screen (800x600) on the TV for watching TV and videos. KDE is only being used on the main X screen.

When I press ALT-TAB, most of the time the switcher does not show on the main X screen and so I cannot switch to the next application. Instead, the switcher shows (partly in the lower right) on the second X screen. Looks like it centers like if it ran on 1920x1200, but shows on the 800x600 screen. Sometimes it works however and shows on the main X screen.

Even though I would want KDE to not use the other X screen, it displays the desktop background there.

Adding "disableMultihead=true" in ~.kde4/share/config/kcmdisplayrc prevents KDE from showing the desktop background on the other X screen, but the ALT-TAB behavior is the same.

I think this problem started with KDE 4.6 or 4.7.

There is also a thread in the Gentoo forums about this:
http://forums.gentoo.org/viewtopic.php?p=6907954

ALT-F2 also does not work most of the time. But I can't say, if this one opens on the other X screen, too (I don't see it there).



Reproducible: Always

Steps to Reproduce:
Configure 2 X screens in xorg.conf (dual head, no Xinerama or TwinView, but totally separate X screens).

Try to switch between applications with ALT-TAB.

Actual Results:  
The switcher most of the time opens on the other X screen. Holding ALT and pressing TAB multiple times does not switch between the applications on the current X screen.

Expected Results:  
Always show switcher on current desktop.

Attaching xorg.conf.
Comment 1 Thomas Lübking 2012-01-16 17:03:07 UTC
Not a matter of the window manager but kglobalaccel (needs to be screen aware, there's only one instance passing the action to its known, ie. 1/2 of all cases the "wrong" WM)

cross check bug #256242

This behavior btw. didn't like "start" with 4.6 or 4.7 but before you simply wouldn't have a kwin instance on each screen at all.

While the other bug is a dumpster, i'll still dupe this one since a fix to either will fix both and the kglobalaccel maintainer is already attached to the other bug.

*** This bug has been marked as a duplicate of bug 256242 ***