Bug 291269 - Alphabetical glossary not sorted
Summary: Alphabetical glossary not sorted
Status: RESOLVED FIXED
Alias: None
Product: khelpcenter
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Documentation Editorial Team
URL:
Keywords:
: 310056 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-11 13:52 UTC by lutz.wrage
Modified: 2012-12-08 16:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lutz.wrage 2012-01-11 13:52:57 UTC
Version:           unspecified (using KDE 4.7.3) 
OS:                Linux

The alphabetical lists in the glossary tab are not sorted. 

Reproducible: Always

Steps to Reproduce:
In kickoff application launcher type help, select Help to start khelpcenter. Select Glossary tab, expand Alphabetically

Actual Results:  
First letter order is A, D, F I, K, ... Also lists under the first letter are not sorted, e.g., for first letter S, the entries are Solid, System Settings, Soprano, Strigi, SVN, ...

Expected Results:  
Alphabetical order

Encoding is set to Default.
locale settings:
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Comment 1 Burkhard Lück 2012-01-11 17:00:23 UTC
Confirmed using master (will be 4.8)
List By Topics is not sorted as well.
Comment 2 Burkhard Lück 2012-11-21 04:07:57 UTC
*** Bug 310056 has been marked as a duplicate of this bug. ***
Comment 3 Albert Astals Cid 2012-11-21 23:17:43 UTC
I'll have a look, shouldn't be that hard (last famous words)
Comment 4 Albert Astals Cid 2012-12-08 16:23:32 UTC
Git commit 7e3f9ec3b5f2cf16fc30615fc93b48d6072c2045 by Albert Astals Cid.
Committed on 08/12/2012 at 17:22.
Pushed by aacid into branch 'KDE/4.9'.

Sort alphabetically

It's a bit sad that our alphabetical list was not sorted alphabetically
FIXED-IN: 4.9.5

M  +1    -0    khelpcenter/glossary.cpp

http://commits.kde.org/kde-runtime/7e3f9ec3b5f2cf16fc30615fc93b48d6072c2045
Comment 5 Albert Astals Cid 2012-12-08 16:33:31 UTC
Git commit ad67c7057eafda44a2b6470c8efb0d6957358967 by Albert Astals Cid.
Committed on 08/12/2012 at 17:22.
Pushed by aacid into branch 'master'.

Sort alphabetically

It's a bit sad that our alphabetical list was not sorted alphabetically
FIXED-IN: 4.9.5
(cherry picked from commit 7e3f9ec3b5f2cf16fc30615fc93b48d6072c2045)

M  +1    -0    khelpcenter/glossary.cpp

http://commits.kde.org/kde-runtime/ad67c7057eafda44a2b6470c8efb0d6957358967