Bug 290880 - Amarok Crashes on startup after installing
Summary: Amarok Crashes on startup after installing
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-07 14:30 UTC by koldo
Modified: 2012-01-07 23:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description koldo 2012-01-07 14:30:58 UTC
+++ This bug was initially created as a clone of Bug #270781 +++

Application: amarok (2.4.0)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Installed Amarok and tried to start application but it crashes, this happens every time

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1c4a770 (LWP 3841))]

Thread 13 (Thread 0xb1912b70 (LWP 3842)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb577bdf6 in poll () from /lib/libc.so.6
#2  0xb4427a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb441a43c in ?? () from /lib/libglib-2.0.so.0
#4  0xb441aba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0xb1fcf9c4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0xb444148f in ?? () from /lib/libglib-2.0.so.0
#7  0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#8  0xb578a69e in clone () from /lib/libc.so.6

Thread 12 (Thread 0xa92dcb70 (LWP 3843)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e9884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797df4 in pthread_cond_timedwait () from /lib/libc.so.6
#3  0xae13db3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 11 (Thread 0xa8adbb70 (LWP 3844)):
#0  0xb45e73f4 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb5797f66 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb441a3f1 in ?? () from /lib/libglib-2.0.so.0
#3  0xb441a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0xb5ab159f in QEventDispatcherGlib::processEvents (this=0x9616570, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0xb5a81609 in QEventLoop::processEvents (this=0xa8adb220, flags=) at kernel/qeventloop.cpp:149
#6  0xb5a81a8a in QEventLoop::exec (this=0xa8adb220, flags=...) at kernel/qeventloop.cpp:201
#7  0xb597db7e in QThread::exec (this=0x9614220) at thread/qthread.cpp:490
#8  0xae18dd7a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#9  0xb5980df9 in QThreadPrivate::start (arg=0x9614220) at thread/qthread_unix.cpp:266
#10 0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#11 0xb578a69e in clone () from /lib/libc.so.6

Thread 10 (Thread 0xa82dab70 (LWP 3845)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb577bdf6 in poll () from /lib/libc.so.6
#2  0xb40d4562 in ?? () from /usr/lib/libpulse.so.0
#3  0xb40c0ab9 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0xb40c2a73 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0xb40c2b44 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0xb40d4303 in ?? () from /usr/lib/libpulse.so.0
#7  0xb25ccbd5 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#9  0xb578a69e in clone () from /lib/libc.so.6

Thread 9 (Thread 0xa38ffb70 (LWP 3846)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e94dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xae14fb54 in ?? () from /usr/lib/libxine.so.1
#4  0x00000000 in ?? ()

Thread 8 (Thread 0xa2effb70 (LWP 3847)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e94dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xae14fb54 in ?? () from /usr/lib/libxine.so.1
#4  0x00000000 in ?? ()

Thread 7 (Thread 0xa22ffb70 (LWP 3848)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e94dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xae14fb54 in ?? () from /usr/lib/libxine.so.1
#4  0x00000000 in ?? ()

Thread 6 (Thread 0xa14a9b70 (LWP 3850)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb577bdf6 in poll () from /lib/libc.so.6
#2  0xb4427a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb441a43c in ?? () from /lib/libglib-2.0.so.0
#4  0xb441a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb5ab159f in QEventDispatcherGlib::processEvents (this=0x96d2db0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0xb5a81609 in QEventLoop::processEvents (this=0xa14a9230, flags=) at kernel/qeventloop.cpp:149
#7  0xb5a81a8a in QEventLoop::exec (this=0xa14a9230, flags=...) at kernel/qeventloop.cpp:201
#8  0xb597db7e in QThread::exec (this=0x96d21f8) at thread/qthread.cpp:490
#9  0xb5a6035b in QInotifyFileSystemWatcherEngine::run (this=0x96d21f8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb5980df9 in QThreadPrivate::start (arg=0x96d21f8) at thread/qthread_unix.cpp:266
#11 0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#12 0xb578a69e in clone () from /lib/libc.so.6

Thread 5 (Thread 0x9e490b70 (LWP 3851)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e94dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb3b6a3a5 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb3b6a481 in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#6  0xb578a69e in clone () from /lib/libc.so.6

Thread 4 (Thread 0x9d289b70 (LWP 3854)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e94dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb59819c7 in wait (this=0x9755f88, mutex=0x97d2ad8, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9755f88, mutex=0x97d2ad8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0xb4f05520 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9755f70, th=0x97b43b8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb4f08ccc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x97b76b0, th=0x97b43b8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb4f04a4b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9755f70, th=0x97b43b8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb4f08dc2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x97b76b0, th=0x97b43b8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb4f05a23 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9755f70, th=0x97b43b8, previous=0x97677c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb4f06e4e in ThreadWeaver::ThreadRunHelper::run (this=0x9d289294, parent=0x9755f70, th=0x97b43b8) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb4f0756b in ThreadWeaver::Thread::run (this=0x97b43b8) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb5980df9 in QThreadPrivate::start (arg=0x97b43b8) at thread/qthread_unix.cpp:266
#13 0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#14 0xb578a69e in clone () from /lib/libc.so.6

Thread 3 (Thread 0x9ca88b70 (LWP 3855)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e94dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb59819c7 in wait (this=0x9755f88, mutex=0x97d2ad8, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9755f88, mutex=0x97d2ad8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0xb4f05520 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9755f70, th=0x97554d8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb4f08ccc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x97b76b0, th=0x97554d8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb4f04a4b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9755f70, th=0x97554d8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb4f08dc2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x97b76b0, th=0x97554d8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb4f05a23 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9755f70, th=0x97554d8, previous=0x989b058) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb4f06e4e in ThreadWeaver::ThreadRunHelper::run (this=0x9ca88294, parent=0x9755f70, th=0x97554d8) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb4f0756b in ThreadWeaver::Thread::run (this=0x97554d8) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb5980df9 in QThreadPrivate::start (arg=0x97554d8) at thread/qthread_unix.cpp:266
#13 0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#14 0xb578a69e in clone () from /lib/libc.so.6

Thread 2 (Thread 0x9c07bb70 (LWP 3856)):
#0  0xb770e424 in __kernel_vsyscall ()
#1  0xb45e94dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5797d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb48c3877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb49c21a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb48c38c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb49c21a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb45e4cc9 in start_thread () from /lib/libpthread.so.0
#6  0xb578a69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb1c4a770 (LWP 3841)):
[KCrash Handler]
#7  operator!= (this=0x9a8e748, t=...) at /usr/include/qt4/QtCore/qbasicatomic.h:75
#8  QList<QWeakPointer<QAbstractAnimation> >::append (this=0x9a8e748, t=...) at /usr/include/qt4/QtCore/qlist.h:495
#9  0xb6a5da68 in enqueue (this=0x9a8e710, anim=0x972cea0) at /usr/include/qt4/QtCore/qqueue.h:59
#10 Context::ContextView::addCollapseAnimation (this=0x9a8e710, anim=0x972cea0) at ../../src/context/ContextView.cpp:257
#11 0xb6a5603b in Context::Applet::collapse (this=0x9a937c8, on=true) at ../../src/context/Applet.cpp:315
#12 0xb6a561e5 in Context::Applet::setCollapseOn (this=0x9a937c8) at ../../src/context/Applet.cpp:273
#13 0xa243a390 in LyricsApplet::dataUpdated (this=0x9a937c8, name=..., data=...) at ../../../../../src/context/applets/lyrics/LyricsApplet.cpp:579
#14 0xa243d154 in LyricsApplet::qt_metacall (this=0x9a937c8, _c=QMetaObject::InvokeMetaMethod, _id=70, _a=0xbfdfb204) at ./LyricsApplet.moc:98
#15 0xb5a888ca in QMetaObject::metacall (object=0x9a937c8, cl=162064144, idx=70, argv=0xbfdfb204) at kernel/qmetaobject.cpp:237
#16 0xb5a9b6ad in QMetaObject::activate (sender=0x9ada808, m=0xb4d19ae4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#17 0xb4b4af59 in Plasma::DataContainer::dataUpdated (this=0x9ada808, _t1=..., _t2=...) at ./datacontainer.moc:112
#18 0xb4b4b72b in Plasma::DataContainer::checkForUpdate (this=0x9ada808) at ../../plasma/datacontainer.cpp:327
#19 0xb4b514c6 in Plasma::DataEngine::timerEvent (this=0x9ac5760, event=0xbfdfb7f0) at ../../plasma/dataengine.cpp:386
#20 0xb5a95504 in QObject::event (this=0x9ac5760, e=0x9a8e748) at kernel/qobject.cpp:1183
#21 0xb5f8afdc in QApplicationPrivate::notify_helper (this=0x94c78b0, receiver=0x9ac5760, e=0xbfdfb7f0) at kernel/qapplication.cpp:4396
#22 0xb5f9104e in QApplication::notify (this=0xbfdfbb58, receiver=0x9ac5760, e=0xbfdfb7f0) at kernel/qapplication.cpp:3798
#23 0xb750982a in KApplication::notify (this=0xbfdfbb58, receiver=0x9ac5760, event=0xbfdfb7f0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0xb5a82b3b in QCoreApplication::notifyInternal (this=0xbfdfbb58, receiver=0x9ac5760, event=0xbfdfb7f0) at kernel/qcoreapplication.cpp:732
#25 0xb5ab4ad6 in sendEvent (this=0x94cd6cc) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x94cd6cc) at kernel/qeventdispatcher_unix.cpp:602
#27 0xb5ab1874 in timerSourceDispatch (source=0x94cd698) at kernel/qeventdispatcher_glib.cpp:184
#28 0xb4416855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#29 0xb441a668 in ?? () from /lib/libglib-2.0.so.0
#30 0xb441a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#31 0xb5ab1565 in QEventDispatcherGlib::processEvents (this=0x93c9048, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#32 0xb604cbe5 in QGuiEventDispatcherGlib::processEvents (this=0x93c9048, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb5a81609 in QEventLoop::processEvents (this=0xbfdfbab4, flags=) at kernel/qeventloop.cpp:149
#34 0xb5a81a8a in QEventLoop::exec (this=0xbfdfbab4, flags=...) at kernel/qeventloop.cpp:201
#35 0xb5a8600f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#36 0xb5f89e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#37 0x08050e75 in main (argc=1, argv=0xbfdfc514) at ../../src/main.cpp:268

This bug may be a duplicate of or related to bug 258741.

Possible duplicates by query: bug 269740, bug 259378.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-01-07 23:11:34 UTC
Sorry, but Amarok 2.4.0 is rather old, please upgrade your installation.

I suggest you disable the Animation option for the Context View in the $HOME/.kde/share/config/amarokrc file in the section [General Options]

*** This bug has been marked as a duplicate of bug 258741 ***