Bug 290828 - Widget selections scrolling broken
Summary: Widget selections scrolling broken
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget explorer (show other bugs)
Version: 4.8.90 (beta2)
Platform: Archlinux Packages Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 277614 301754 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-06 20:42 UTC by Luke
Modified: 2012-06-21 19:49 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2012-01-06 20:42:52 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Scrolling with mouse scroll is real pain = not fluid, to slow, stuttering. It has been this way since new UI for adding widgets (long time).

Reproducible: Always

Steps to Reproduce:
Add widgets -> scroll with mouse scroll


Expected Results:  
Smooth scrolling
Comment 1 Myriam Schweingruber 2012-06-02 21:30:47 UTC
Which exact KDE version is this about?
Comment 2 Luke 2012-06-05 09:56:29 UTC
Hmm it was that way since new horizontal widget UI. Right now in 4.9 beta 1 scrolling is fluid and awesome but responds only to scroll-wheel tilting (aka horizontal scrolling) which is not necessarily a bug. Up to 4.8.x it was working with regular scrolling (vertical scroll) and with tilting but in both cases it was broken, not fluid and painfully.
Comment 3 Myriam Schweingruber 2012-06-05 19:59:08 UTC
Partially solved then?
Comment 4 Luke 2012-06-05 21:10:39 UTC
I'm not sure, if it should respond only to horizontal scrolling/tilting by design then it's solved, but for me if there is only one scroll-bar it should respond to scroll-wheel, right?
Comment 5 Myriam Schweingruber 2012-06-07 05:42:09 UTC
Indeed it should. Thank you for the fast feedback.
Comment 6 Janek Bevendorff 2012-06-13 16:31:37 UTC
Still valid for 4.8.90.
Marked it as regression (although one might say that no scrolling is better than that laggy scrolling in 4.8 :-)).
Comment 7 Janek Bevendorff 2012-06-13 16:32:56 UTC
*** Bug 277614 has been marked as a duplicate of this bug. ***
Comment 8 Janek Bevendorff 2012-06-13 16:33:12 UTC
*** Bug 301754 has been marked as a duplicate of this bug. ***
Comment 9 Kai Uwe Broulik 2012-06-13 16:47:13 UTC
Probably a bug in our QML components? i.e. horizontal scrolling is _only_ working with horizontal mouse wheel regardless if there is a vertical scroll possible?
Comment 10 Janek Bevendorff 2012-06-13 16:56:26 UTC
Until I read this bug I didn't even know that scrolling by tilting the wheel is possible here. I would have reported it as "No scrolling with mouse wheel whatsoever".

This bug only happens for the QML rewrite in 4.9. Before 4.9 scrolling with the mouse wheel was possible but cumbersome.
Comment 11 Marco Martin 2012-06-21 09:08:31 UTC
Git commit 920397e9f161133b72ca6ffdbc0814bf1d91a15e by Marco Martin.
Committed on 21/06/2012 at 11:07.
Pushed by mart into branch 'master'.

manage vertical wheel in horizontal lists

M  +33   -19   libs/plasmagenericshell/widgetsexplorer/package/contents/ui/main.qml
M  +30   -17   plasma/desktop/shell/activitymanager/package/contents/ui/main.qml

http://commits.kde.org/kde-workspace/920397e9f161133b72ca6ffdbc0814bf1d91a15e