Bug 290735 - starting kde git KDE/4.8 for a new user crashes kded/powerdevil
Summary: starting kde git KDE/4.8 for a new user crashes kded/powerdevil
Status: RESOLVED DUPLICATE of bug 287560
Alias: None
Product: solid
Classification: Unclassified
Component: powermanagement-daemon (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-05 19:32 UTC by Martin Koller
Modified: 2012-01-15 01:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2012-01-05 19:32:26 UTC
Version:           0.0.1 (using Devel) 
OS:                Linux

Application: kded4 ($Id$)
KDE Platform Version: 4.7.97 (4.8 RC2 (4.7.97)
Qt Version: 4.8.0
Operating System: Linux 2.6.34.10-0.4-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0xb566d710 (LWP 27699))]

Thread 2 (Thread 0xb0b6eb70 (LWP 27744)):
#0  0xb590a22b in clock_gettime () from /lib/librt.so.1
#1  0xb6d4e5d5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6e39466 in updateCurrentTime (this=0x8184674, tm=...) at kernel/qeventdispatcher_unix.cpp:343
#4  QTimerInfoList::timerWait (this=0x8184674, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb6e37c7b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb0b6e0fc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6e37d1d in timerSourcePrepare (source=0x8184640, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb585e0c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb585ef22 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb585f60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6e38567 in QEventDispatcherGlib::processEvents (this=0x8206c10, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb6e0453d in QEventLoop::processEvents (this=0xb0b6e2a0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6e047d1 in QEventLoop::exec (this=0xb0b6e2a0, flags=...) at kernel/qeventloop.cpp:204
#13 0xb6ce900d in QThread::exec (this=0x8200908) at thread/qthread.cpp:501
#14 0xb6de098d in QInotifyFileSystemWatcherEngine::run (this=0x8200908) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6cebacd in QThreadPrivate::start (arg=0x8200908) at thread/qthread_unix.cpp:298
#16 0xb6c6ab25 in start_thread () from /lib/libpthread.so.0
#17 0xb5f3934e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb566d710 (LWP 27699)):
[KCrash Handler]
#7  0xffffe424 in __kernel_vsyscall ()
#8  0xb5e917af in raise () from /lib/libc.so.6
#9  0xb5e930f0 in abort () from /lib/libc.so.6
#10 0xb6ce10aa in qt_message_output (msgType=QtFatalMsg, buf=
    0x82558c8 "ASSERT failure in KConfigGroup::groupImpl: \"can not have an unnamed child group\", file /home/KDE4/source/kdelibs/kdecore/config/kconfiggroup.cpp, line 516")
    at global/qglobal.cpp:2252
#11 0xb6ce12af in qt_message (msgType=QtFatalMsg, msg=0xb6e7365c "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0xbfa45df4 "O\300\"\267h\300\"\267\b\275\"\267\004\002")
    at global/qglobal.cpp:2298
#12 0xb6ce13c8 in qFatal (msg=0xb6e7365c "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2481
#13 0xb6ce140d in qt_assert_x (where=0xb722c04f "KConfigGroup::groupImpl", what=0xb722c068 "can not have an unnamed child group", file=
    0xb722bd08 "/home/KDE4/source/kdelibs/kdecore/config/kconfiggroup.cpp", line=516) at global/qglobal.cpp:2007
#14 0xb707ae37 in KConfigGroup::groupImpl (this=0xbfa45f40, aGroup=...) at /home/KDE4/source/kdelibs/kdecore/config/kconfiggroup.cpp:516
#15 0xb7077eeb in KConfigBase::group (this=0xbfa45f40, str=...) at /home/KDE4/source/kdelibs/kdecore/config/kconfigbase.cpp:51
#16 0xb0de39ea in PowerDevil::Core::loadProfile (this=0x81c1dc8, force=true) at /home/KDE4/source/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:267
#17 0xb0de35c4 in PowerDevil::Core::refreshStatus (this=0x81c1dc8) at /home/KDE4/source/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:236
#18 0xb0de2ba1 in PowerDevil::Core::onBackendReady (this=0x81c1dc8) at /home/KDE4/source/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:153
#19 0xb0de70ab in PowerDevil::Core::qt_static_metacall (_o=0x81c1dc8, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0xbfa4643c)
    at /home/KDE4/build/kde-workspace/powerdevil/daemon/powerdevilcore.moc:145
#20 0xb6e1db4f in QMetaObject::activate (sender=0x81b4ba8, m=0x0, local_signal_index=-1327600308, argv=0x0) at kernel/qobject.cpp:3556
#21 0xb0de0edd in PowerDevil::BackendInterface::backendReady (this=0x81b4ba8) at /home/KDE4/build/kde-workspace/powerdevil/daemon/powerdevilbackendinterface.moc:160
#22 0xb0de0893 in PowerDevil::BackendInterface::setBackendIsReady (this=0x81b4ba8, availableBrightnessControls=..., supportedSuspendMethods=...)
    at /home/KDE4/source/kde-workspace/powerdevil/daemon/powerdevilbackendinterface.cpp:120
#23 0xb0f9af7b in PowerDevilUPowerBackend::init (this=0x81b4ba8) at /home/KDE4/source/kde-workspace/powerdevil/daemon/backends/upower/powerdevilupowerbackend.cpp:151
#24 0xb0de2472 in PowerDevil::Core::loadCore (this=0x81c1dc8, backend=0x81b4ba8) at /home/KDE4/source/kde-workspace/powerdevil/daemon/powerdevilcore.cpp:84
#25 0xb0f96571 in KDEDPowerDevil::init (this=0x8158750) at /home/KDE4/source/kde-workspace/powerdevil/daemon/kdedpowerdevil.cpp:89
#26 0xb0f968f9 in KDEDPowerDevil::qt_static_metacall (_o=0x8158750, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x816da68) at /home/KDE4/build/kde-workspace/powerdevil/daemon/kdedpowerdevil.moc:50
#27 0xb6e175d1 in QMetaCallEvent::placeMetaCall (this=0x80c0bf8, object=0x8158750) at kernel/qobject.cpp:525
#28 0xb6e1ba3b in QObject::event (this=0x8158750, e=0x80c0bf8) at kernel/qobject.cpp:1204
#29 0xb62aa924 in QApplicationPrivate::notify_helper (this=0x80c1850, receiver=0x8158750, e=0x80c0bf8) at kernel/qapplication.cpp:4550
#30 0xb62b37ab in QApplication::notify (this=0xbfa46fa4, receiver=0x8158750, e=0x80c0bf8) at kernel/qapplication.cpp:3932
#31 0xb75f48da in KApplication::notify (this=0xbfa46fa4, receiver=0x8158750, event=0x80c0bf8) at /home/KDE4/source/kdelibs/kdeui/kernel/kapplication.cpp:311
#32 0xb6e0563e in QCoreApplication::notifyInternal (this=0xbfa46fa4, receiver=0x8158750, event=0x80c0bf8) at kernel/qcoreapplication.cpp:876
#33 0xb6e09310 in sendEvent (receiver=0x0, event_type=0, data=0x805c758) at kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x805c758) at kernel/qcoreapplication.cpp:1500
#35 0xb6e0953c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#36 0xb6e38394 in sendPostedEvents (s=0x80c3b10) at kernel/qcoreapplication.h:236
#37 postEventSourceDispatch (s=0x80c3b10) at kernel/qeventdispatcher_glib.cpp:279
#38 0xb585eb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#39 0xb585f350 in ?? () from /usr/lib/libglib-2.0.so.0
#40 0xb585f60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#41 0xb6e3851b in QEventDispatcherGlib::processEvents (this=0x805d8c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#42 0xb6361fba in QGuiEventDispatcherGlib::processEvents (this=0x805d8c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0xb6e0453d in QEventLoop::processEvents (this=0xbfa46f14, flags=...) at kernel/qeventloop.cpp:149
#44 0xb6e047d1 in QEventLoop::exec (this=0xbfa46f14, flags=...) at kernel/qeventloop.cpp:204
#45 0xb6e09610 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#46 0xb62a85f4 in QApplication::exec () at kernel/qapplication.cpp:3811
#47 0xb514c9cd in kdemain (argc=1, argv=0x80a2a10) at /home/KDE4/source/kdelibs/kded/kded.cpp:924
#48 0x0804de64 in launch (argc=1, _name=0x8053e00 "kded4", args=0x0, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80536ef "0")
    at /home/KDE4/source/kdelibs/kinit/kinit.cpp:734
#49 0x08050caf in main (argc=4, argv=0xbfa47374, envp=0xbfa47388) at /home/KDE4/source/kdelibs/kinit/kinit.cpp:1849

Reproducible: Always

Steps to Reproduce:
I start KDE for a user which has no kde4 settings
(in HOME rm -Rf /tmp/kde-kdetrunk /var/tmp/kdecache-kdetrunk .kde4 .config .local .qt .strigi .xine)
and this crash happens every time.


Expected Results:  
no crash

OS: Linux (i686) release 2.6.34.10-0.4-desktop
Compiler: gcc
Comment 1 Dario Freddi 2012-01-15 01:39:22 UTC

*** This bug has been marked as a duplicate of bug 287560 ***