Bug 290714 - loading a GPX file takes a long time (~3 minutes)
Summary: loading a GPX file takes a long time (~3 minutes)
Status: RESOLVED DUPLICATE of bug 288612
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: 1.3 (KDE 4.8)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-05 17:03 UTC by Jonathan Marten
Modified: 2012-01-05 21:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
GPX file that takes a long time to load (11.82 KB, application/xml)
2012-01-05 17:03 UTC, Jonathan Marten
Details
Debug log from Marble (117.81 KB, text/x-log)
2012-01-05 17:04 UTC, Jonathan Marten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Marten 2012-01-05 17:03:49 UTC
Created attachment 67490 [details]
GPX file that takes a long time to load

Version:           unspecified (using Devel) 
OS:                Linux

Loading a GPX file - from the command line, or via File - Open in the application - seems to take a long time, several minutes even for a simple file.  This is on a 3-core 2.6GHz CPU with 8Gb memory.  Neither Marble nor any other process is taking 100% CPU or an unreasonable amount of memory.

Attached is a GPX file which demonstrates the problem, which is a GPS recording trimmed to only the relevant parts.  Starting Marble with the command

  marble --debug-info /full/path/to/file.gpx

shows debug information as per the attached log.  The long delay happens near the end, there is a pause of about 3 minutes between the last

StackedTileLoader::loadTile "0:13:4288:2885" 

line and the first

QPixmap: It is not safe to use pixmaps outside the GUI thread

The GPX tracks and waypoints do not appear on the map until the first of the "QPixmap:" messages start coming out.

(To view the GPX file, scroll to Engelberg which is about 25km south of Luzern, Switzerland).


Reproducible: Always

Steps to Reproduce:
Attempt to load the attached GPX file.


Actual Results:  
Long delay before the contents are shown on the map.


Expected Results:  
There should not be such a delay.
Comment 1 Jonathan Marten 2012-01-05 17:04:56 UTC
Created attachment 67491 [details]
Debug log from Marble
Comment 2 Dennis Nienhüser 2012-01-05 21:53:15 UTC

*** This bug has been marked as a duplicate of bug 288612 ***