Bug 290570 - When bookmarks are moved into a folder the operation fails and all folders lost.
Summary: When bookmarks are moved into a folder the operation fails and all folders lost.
Status: RESOLVED DUPLICATE of bug 226187
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-04 09:27 UTC by john smeed
Modified: 2012-01-06 16:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
rekonq editor crash report 1 (6.34 KB, application/octet-stream)
2012-01-04 23:37 UTC, john smeed
Details
rekonq editor crash report 2 (12.57 KB, application/octet-stream)
2012-01-04 23:41 UTC, john smeed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john smeed 2012-01-04 09:27:47 UTC
Version:           0.7.0 (using Devel) 
OS:                Linux

Moved a large number of bookmarks (about 12) into a folder and lost all the folders and the moved bookmarks. Could not undo. The editor behaves strangely or crashes. Since preparing the bug report behavior has changed. I can move bookmarks one at a time only. That sucks.

Reproducible: Always

Steps to Reproduce:
Move a group of bookmarks into a folder. Size of group unknown.

Actual Results:  
Lost bookmarks, lost folders. no undo.

Expected Results:  
That all selected bookmarks be placed in the selected folder.

OS: Linux (i686) release 2.6.38-13-generic
Compiler: cc
Comment 1 Andrea Diamantini 2012-01-04 10:45:26 UTC
John, I need more explanations about. How can you move bookmarks? Using the "edit bookmarks" UI? Do you have a crash backtrace to attach here? What do you mean by "lost bookmarks"? You mean your changes are lost, isn't it?
Comment 2 john smeed 2012-01-04 23:37:29 UTC
Created attachment 67463 [details]
rekonq editor crash report 1
Comment 3 john smeed 2012-01-04 23:41:07 UTC
Created attachment 67467 [details]
rekonq editor crash report 2
Comment 4 Andrea Diamantini 2012-01-05 09:35:33 UTC
Just to NOT download it everytime, attaching it here:


Application: keditbookmarks (4.6.5 (4.6.5))
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-13-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
<In detail, tell us what you were doing  when the application crashed.>

The crash can be reproduced every time.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0xb784bb10 (LWP 2631))]

Thread 2 (Thread 0xb494ab70 (LWP 2632)):
#0  0x0041b416 in __kernel_vsyscall ()
#1  0x001d1f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0287584b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x028651af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02865524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x06f0b577 in QEventDispatcherGlib::processEvents (this=0x82dc620, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x06edd289 in QEventLoop::processEvents (this=0xb494a290, flags=...) at kernel/qeventloop.cpp:149
#7  0x06edd522 in QEventLoop::exec (this=0xb494a290, flags=...) at kernel/qeventloop.cpp:201
#8  0x06de72a0 in QThread::exec (this=0x834a2c0) at thread/qthread.cpp:492
#9  0x06ebefdb in QInotifyFileSystemWatcherEngine::run (this=0x834a2c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x06de9da2 in QThreadPrivate::start (arg=0x834a2c0) at thread/qthread_unix.cpp:320
#11 0x0099ce99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb784bb10 (LWP 2631)):
[KCrash Handler]
#7  0x00ca1489 in QDomNode::QDomNode (this=0xbf884a2c, n=...) at dom/qdom.cpp:2038
#8  0x00ca3664 in QDomElement::QDomElement (this=0xbf884a2c, x=...) at dom/qdom.cpp:4738
#9  0x009928ec in KBookmark (this=0x0) at /usr/include/kbookmark.h:35
#10 TreeItem::bookmark (this=0x0) at ../../../keditbookmarks/kbookmarkmodel/treeitem.cpp:87
#11 0x00990740 in KBookmarkModel::bookmarkForIndex (this=0x82a80b0, index=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:396
#12 0x009907c6 in KBookmarkModel::parent (this=0x82a80b0, index=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:263
#13 0x05d838dd in parent (this=0x8302f98, source_parent=...) at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:389
#14 QSortFilterProxyModelPrivate::can_create_mapping (this=0x8302f98, source_parent=...) at itemviews/qsortfilterproxymodel.cpp:399
#15 0x05d8666e in QSortFilterProxyModelPrivate::_q_sourceRowsAboutToBeInserted (this=0x8302f98, source_parent=..., start=12, end=12) at itemviews/qsortfilterproxymodel.cpp:1271
#16 0x05d8a0e7 in QSortFilterProxyModel::qt_metacall (this=0x83029c0, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf884bf0) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:134
#17 0x00ed98e2 in BookmarkFolderViewFilterModel::qt_metacall (this=0x83029c0, _c=QMetaObject::InvokeMetaMethod, _id=36, _a=0xbf884bf0) at ./bookmarklistview.moc:172
#18 0x06ee46ba in QMetaObject::metacall (object=0x83029c0, cl=QMetaObject::InvokeMetaMethod, idx=36, argv=0xbf884bf0) at kernel/qmetaobject.cpp:237
#19 0x06ef44ff in QMetaObject::activate (sender=0x82a80b0, m=0x7019198, local_signal_index=4, argv=0xbf884bf0) at kernel/qobject.cpp:3287
#20 0x06f401bf in QAbstractItemModel::rowsAboutToBeInserted (this=0x82a80b0, _t1=..., _t2=12, _t3=12) at .moc/release-shared/moc_qabstractitemmodel.cpp:174
#21 0x06ed5eda in QAbstractItemModel::beginInsertRows (this=0x82a80b0, parent=..., first=12, last=12) at kernel/qabstractitemmodel.cpp:2395
#22 0x00990dd6 in KBookmarkModel::beginInsert (this=0x82a80b0, group=..., first=12, last=12) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:404
#23 0x0098c21f in CreateCommand::redo (this=0x828e560) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:113
#24 0x0098d81b in MoveCommand::redo (this=0x842a678) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:374
#25 0x05e4fc93 in QUndoCommand::redo (this=0x81f3a40) at util/qundostack.cpp:208
#26 0x05e51415 in QUndoStack::push (this=0x829a374, cmd=0x81f3a40) at util/qundostack.cpp:541
#27 0x0098ba76 in CommandHistory::addCommand (this=0x829bad0, cmd=0x81f3a40) at ../../../keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#28 0x00991d57 in KBookmarkModel::dropMimeData (this=0x82a80b0, data=0x84f0ea8, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:380
#29 0x00ed9840 in BookmarkFolderViewFilterModel::dropMimeData (this=0x83029c0, data=0x84f0ea8, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../keditbookmarks/bookmarklistview.cpp:187
#30 0x05cfea00 in QAbstractItemView::dropEvent (this=0x82724b8, event=0xbf8858c0) at itemviews/qabstractitemview.cpp:1990
#31 0x057d6677 in QWidget::event (this=0x82724b8, event=0xbf8858c0) at kernel/qwidget.cpp:8449
#32 0x05bca9f3 in QFrame::event (this=0x82724b8, e=0xbf8858c0) at widgets/qframe.cpp:557
#33 0x05c59062 in QAbstractScrollArea::viewportEvent (this=0x82724b8, e=0xbf8858c0) at widgets/qabstractscrollarea.cpp:1043
#34 0x05cf8227 in QAbstractItemView::viewportEvent (this=0x82724b8, event=0xbf8858c0) at itemviews/qabstractitemview.cpp:1628
#35 0x05d3fe83 in QTreeView::viewportEvent (this=0x82724b8, event=0xbf8858c0) at itemviews/qtreeview.cpp:1256
#36 0x05c5b965 in viewportEvent (this=0x8272268, o=0x8272a50, e=0xbf8858c0) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0x8272268, o=0x8272a50, e=0xbf8858c0) at widgets/qabstractscrollarea_p.h:116
#38 0x06ede25a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x81f8188, receiver=0x8272a50, event=0xbf8858c0) at kernel/qcoreapplication.cpp:846
#39 0x0577dd00 in QApplicationPrivate::notify_helper (this=0x81f8188, receiver=0x8272a50, e=0xbf8858c0) at kernel/qapplication.cpp:4458
#40 0x05782d35 in QApplication::notify (this=0xbf887c1c, receiver=0x8272a50, e=0xbf8858c0) at kernel/qapplication.cpp:4266
#41 0x010c732a in KApplication::notify (this=0xbf887c1c, receiver=0x8272a50, event=0xbf8858c0) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x06ede0bb in QCoreApplication::notifyInternal (this=0xbf887c1c, receiver=0x8272a50, event=0xbf8858c0) at kernel/qcoreapplication.cpp:731
#43 0x05815539 in sendEvent (this=0x81fb888, xe=0xbf8859cc, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QX11Data::xdndHandleDrop (this=0x81fb888, xe=0xbf8859cc, passive=false) at kernel/qdnd_x11.cpp:1183
#45 0x0581671e in QDragManager::drop (this=0x8324cc0) at kernel/qdnd_x11.cpp:1725
#46 0x058194ba in QDragManager::eventFilter (this=0x8324cc0, o=0x82c3b70, e=0xbf885f34) at kernel/qdnd_x11.cpp:1312
#47 0x06ede18c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x81f8188, receiver=0x82c3b70, event=0xbf885f34) at kernel/qcoreapplication.cpp:827
#48 0x0577dca3 in QApplicationPrivate::notify_helper (this=0x81f8188, receiver=0x82c3b70, e=0xbf885f34) at kernel/qapplication.cpp:4437
#49 0x05783201 in QApplication::notify (this=0xbf887c1c, receiver=0x82c3b70, e=0xbf885f34) at kernel/qapplication.cpp:4023
#50 0x010c732a in KApplication::notify (this=0xbf887c1c, receiver=0x82c3b70, event=0xbf885f34) at ../../kdeui/kernel/kapplication.cpp:311
#51 0x06ede0bb in QCoreApplication::notifyInternal (this=0xbf887c1c, receiver=0x82c3b70, event=0xbf885f34) at kernel/qcoreapplication.cpp:731
#52 0x0577ec3b in sendSpontaneousEvent (receiver=0x82c3b70, event=0xbf885f34, alienWidget=0x0, nativeWidget=0x82c3b70, buttonDown=0x60ccc60, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#53 QApplicationPrivate::sendMouseEvent (receiver=0x82c3b70, event=0xbf885f34, alienWidget=0x0, nativeWidget=0x82c3b70, buttonDown=0x60ccc60, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#54 0x0580a04c in QETWidget::translateMouseEvent (this=0x82c3b70, event=0xbf88645c) at kernel/qapplication_x11.cpp:4558
#55 0x058089b5 in QApplication::x11ProcessEvent (this=0xbf887c1c, event=0xbf88645c) at kernel/qapplication_x11.cpp:3680
#56 0x058345f4 in x11EventSourceDispatch (s=0x81fb2e8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#57 0x02864aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0x02865270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0x02865524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0x06f0b53c in QEventDispatcherGlib::processEvents (this=0x81bfaa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#61 0x058341e5 in QGuiEventDispatcherGlib::processEvents (this=0x81bfaa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#62 0x06edd289 in QEventLoop::processEvents (this=0x84f0498, flags=...) at kernel/qeventloop.cpp:149
#63 0x06edd522 in QEventLoop::exec (this=0x84f0498, flags=...) at kernel/qeventloop.cpp:201
#64 0x05819199 in QDragManager::drag (this=0x8324cc0, o=0x84ee878) at kernel/qdnd_x11.cpp:1981
#65 0x05790d6e in QDrag::exec (this=0x84ee878, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#66 0x05d02047 in QAbstractItemView::startDrag (this=0x82fd0b0, supportedActions=...) at itemviews/qabstractitemview.cpp:3448
#67 0x05d00d32 in QAbstractItemView::mouseMoveEvent (this=0x82fd0b0, event=0xbf887294) at itemviews/qabstractitemview.cpp:1709
#68 0x05d3fd14 in QTreeView::mouseMoveEvent (this=0x82fd0b0, event=0xbf887294) at itemviews/qtreeview.cpp:1902
#69 0x057d6172 in QWidget::event (this=0x82fd0b0, event=0xbf887294) at kernel/qwidget.cpp:8244
#70 0x05bca9f3 in QFrame::event (this=0x82fd0b0, e=0xbf887294) at widgets/qframe.cpp:557
#71 0x05c59062 in QAbstractScrollArea::viewportEvent (this=0x82fd0b0, e=0xbf887294) at widgets/qabstractscrollarea.cpp:1043
#72 0x05cf8227 in QAbstractItemView::viewportEvent (this=0x82fd0b0, event=0xbf887294) at itemviews/qabstractitemview.cpp:1628
#73 0x05d3fe83 in QTreeView::viewportEvent (this=0x82fd0b0, event=0xbf887294) at itemviews/qtreeview.cpp:1256
#74 0x05c5b965 in viewportEvent (this=0x82fdb00, o=0x82fcde0, e=0xbf887294) at widgets/qabstractscrollarea_p.h:100
#75 QAbstractScrollAreaFilter::eventFilter (this=0x82fdb00, o=0x82fcde0, e=0xbf887294) at widgets/qabstractscrollarea_p.h:116
#76 0x06ede25a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x81f8188, receiver=0x82fcde0, event=0xbf887294) at kernel/qcoreapplication.cpp:846
#77 0x0577dd00 in QApplicationPrivate::notify_helper (this=0x81f8188, receiver=0x82fcde0, e=0xbf887294) at kernel/qapplication.cpp:4458
#78 0x05783201 in QApplication::notify (this=0xbf887c1c, receiver=0x82fcde0, e=0xbf887294) at kernel/qapplication.cpp:4023
#79 0x010c732a in KApplication::notify (this=0xbf887c1c, receiver=0x82fcde0, event=0xbf887294) at ../../kdeui/kernel/kapplication.cpp:311
#80 0x06ede0bb in QCoreApplication::notifyInternal (this=0xbf887c1c, receiver=0x82fcde0, event=0xbf887294) at kernel/qcoreapplication.cpp:731
#81 0x0577ec3b in sendSpontaneousEvent (receiver=0x82fcde0, event=0xbf887294, alienWidget=0x82fcde0, nativeWidget=0x829b260, buttonDown=0x60ccc60, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#82 QApplicationPrivate::sendMouseEvent (receiver=0x82fcde0, event=0xbf887294, alienWidget=0x82fcde0, nativeWidget=0x829b260, buttonDown=0x60ccc60, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#83 0x0580a04c in QETWidget::translateMouseEvent (this=0x829b260, event=0xbf8877bc) at kernel/qapplication_x11.cpp:4558
#84 0x058089b5 in QApplication::x11ProcessEvent (this=0xbf887c1c, event=0xbf8877bc) at kernel/qapplication_x11.cpp:3680
#85 0x058345f4 in x11EventSourceDispatch (s=0x81fb2e8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#86 0x02864aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#87 0x02865270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#88 0x02865524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#89 0x06f0b53c in QEventDispatcherGlib::processEvents (this=0x81bfaa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#90 0x058341e5 in QGuiEventDispatcherGlib::processEvents (this=0x81bfaa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#91 0x06edd289 in QEventLoop::processEvents (this=0xbf887a84, flags=...) at kernel/qeventloop.cpp:149
#92 0x06edd522 in QEventLoop::exec (this=0xbf887a84, flags=...) at kernel/qeventloop.cpp:201
#93 0x06ee1ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#94 0x0577b8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#95 0x00ec0021 in kdemain (argc=4, argv=0xbf887fb4) at ../../keditbookmarks/main.cpp:212
#96 0x080485bb in main (argc=4, argv=0xbf887fb4) at keditbookmarks_dummy.cpp:3
Comment 5 Christoph Feck 2012-01-06 16:48:11 UTC

*** This bug has been marked as a duplicate of bug 226187 ***