Bug 290529 - Animations are always shown above all other windows even if they should be behind
Summary: Animations are always shown above all other windows even if they should be be...
Status: RESOLVED DUPLICATE of bug 158262
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-03 20:44 UTC by ultr
Modified: 2012-01-03 21:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ultr 2012-01-03 20:44:51 UTC
Version:           unspecified (using KDE 4.7.4) 
OS:                Linux

Animations of hiding panels or closed windows (Glide effect) are shown above all other windows even in the situations when they should be shown behind.

Reproducible: Always

Steps to Reproduce:
A1) set Plasma Panel to auto-hide
A2) open a new window
A3) set the window to Always-On-Top
A4) place the window over the place occupied by panel when shown
A5) touch screen edge to show the panel - it is animated and shown behind the window (ok)
A6) move the mouse away, the panel gets hidden - the animation of panel hiding is shown above the Konsole window (bug)

B1) enable Glide effect for windows
B2) open two Konsole windows
B3) place the windows so that they partially overlap themselves
B4) set one of them to stay Always-On-Top
B5) close the other window - the glide animation will be shown above the Always-On-Top window while it should appear behind it

Actual Results:  
animations are always shown above

Expected Results:  
animations should appear with correct z-order
Comment 1 Martin Flöser 2012-01-03 21:01:41 UTC

*** This bug has been marked as a duplicate of bug 158262 ***