Bug 290391 - Kontact
Summary: Kontact
Status: RESOLVED DUPLICATE of bug 279322
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-02 12:15 UTC by Anders Karlsson
Modified: 2012-01-03 07:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Karlsson 2012-01-02 12:15:40 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was trying to create a DAVical calendar (always fails) and gui crashed

-- Backtrace:
Application: Plasma skrivbordskal (plasma-desktop), signal: Aborted
[Current thread is 1 (Thread 0xb1e9ab20 (LWP 1618))]

Thread 5 (Thread 0xaafe8b70 (LWP 1620)):
#0  0xb7722424 in __kernel_vsyscall ()
#1  0xb75f1063 in ?? () from /lib/i386-linux-gnu/libc.so.6
#2  0xb7585135 in ?? () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 4 (Thread 0xa9324b70 (LWP 1621)):
#0  0xb7722424 in __kernel_vsyscall ()
#1  0xb75f1063 in ?? () from /lib/i386-linux-gnu/libc.so.6
#2  0xb7585135 in ?? () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0xa79bab70 (LWP 1627)):
#0  0xb7722424 in __kernel_vsyscall ()
#1  0xb75d440e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2ec534b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2eb6896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2eb6f9b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xa827ccea in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb2edd5f4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb2fd0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb75e30ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa6d20b70 (LWP 1628)):
#0  0xb7722424 in __kernel_vsyscall ()
#1  0xb75f1063 in ?? () from /lib/i386-linux-gnu/libc.so.6
#2  0xb7585135 in ?? () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb1e9ab20 (LWP 1618)):
[KCrash Handler]
#7  0xb7722424 in __kernel_vsyscall ()
#8  0xb753ec8f in raise () from /lib/i386-linux-gnu/libc.so.6
#9  0xb75422b5 in abort () from /lib/i386-linux-gnu/libc.so.6
#10 0xb7574dfc in ?? () from /lib/i386-linux-gnu/libc.so.6
#11 0xb757fbc2 in ?? () from /lib/i386-linux-gnu/libc.so.6
#12 0xb7580862 in ?? () from /lib/i386-linux-gnu/libc.so.6
#13 0xb758394d in free () from /lib/i386-linux-gnu/libc.so.6
#14 0xb6ad60a0 in openSocket () at ../../kdeui/util/kcrash.cpp:789
#15 startFromKdeinit (argc=2, argv=0x853bc28) at ../../kdeui/util/kcrash.cpp:569
#16 0xb6ad64f4 in startProcessInternal (argc=2, argv=0x853bc28, waitAndExit=false, directly=false) at ../../kdeui/util/kcrash.cpp:537
#17 0xb6ad6e73 in KCrash::startProcess (argc=2, argv=0x853bc28, waitAndExit=false) at ../../kdeui/util/kcrash.cpp:524
#18 0xb6ad702f in KCrash::defaultCrashHandler (sig=11) at ../../kdeui/util/kcrash.cpp:311
#19 <signal handler called>
#20 0xb762dd27 in ?? () from /lib/i386-linux-gnu/libc.so.6
#21 0xb6325fd3 in QListData::remove (this=0x99e3718, i=-1) at /usr/include/i386-linux-gnu/bits/string3.h:58
#22 0xab1f3f87 in takeAt (i=<optimized out>, this=<optimized out>) at /usr/include/qt4/QtCore/qlist.h:474
#23 Akonadi::EntityTreeModelPrivate::monitoredItemRemoved (this=0x85546a0, item=...) at ../../akonadi/entitytreemodel_p.cpp:1026
#24 0xab1e3852 in Akonadi::EntityTreeModel::qt_metacall (this=0x90dff58, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf89bda8) at ./entitytreemodel.moc:168
#25 0xab47a4a3 in CalendarSupport::CalendarModel::qt_metacall (this=0x90dff58, _c=QMetaObject::InvokeMetaMethod, _id=50, _a=0xbf89bda8) at moc_calendarmodel.cpp:66
#26 0xb6406b7d in metacall (argv=0xbf89bda8, idx=50, cl=QMetaObject::InvokeMetaMethod, object=0x90dff58) at kernel/qmetaobject.cpp:237
#27 QMetaObject::metacall (object=0x90dff58, cl=QMetaObject::InvokeMetaMethod, idx=50, argv=0xbf89bda8) at kernel/qmetaobject.cpp:232
#28 0xb6415a6a in QMetaObject::activate (sender=0x88f3d10, m=0xab337618, local_signal_index=3, argv=0xbf89bda8) at kernel/qobject.cpp:3278
#29 0xab2332e5 in Akonadi::Monitor::itemRemoved (this=0x88f3d10, _t1=...) at ./monitor.moc:190
#30 0xab238457 in Akonadi::MonitorPrivate::emitItemNotification (this=0x9111168, msg=..., item=..., collection=..., collectionDest=...) at ../../akonadi/monitor_p.cpp:525
#31 0xab239699 in Akonadi::MonitorPrivate::emitNotification (this=0x9111168, msg=...) at ../../akonadi/monitor_p.cpp:284
#32 0xab190989 in Akonadi::ChangeRecorderPrivate::emitNotification (this=0x9111168, msg=...) at ../../akonadi/changerecorder_p.h:60
#33 0xab239316 in Akonadi::MonitorPrivate::flushPipeline (this=0x9111168) at ../../akonadi/monitor_p.cpp:425
#34 0xab239840 in Akonadi::MonitorPrivate::dataAvailable (this=0x9111168) at ../../akonadi/monitor_p.cpp:434
#35 0xab233916 in Akonadi::Monitor::qt_metacall (this=0x88f3d10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf89c0e4) at ./monitor.moc:156
#36 0xab18fb8e in Akonadi::ChangeRecorder::qt_metacall (this=0x88f3d10, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbf89c0e4) at ./changerecorder.moc:72
#37 0xb6406b7d in metacall (argv=0xbf89c0e4, idx=27, cl=QMetaObject::InvokeMetaMethod, object=0x88f3d10) at kernel/qmetaobject.cpp:237
#38 QMetaObject::metacall (object=0x88f3d10, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbf89c0e4) at kernel/qmetaobject.cpp:232
#39 0xb6415a6a in QMetaObject::activate (sender=0x90f6728, m=0xab3362dc, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#40 0xab1dbe25 in Akonadi::EntityCacheBase::dataAvailable (this=0x90f6728) at ./entitycache_p.moc:88
#41 0xab23bf2e in Akonadi::EntityCache<Akonadi::Item, Akonadi::ItemFetchJob, Akonadi::ItemFetchScope>::fetchResult (this=0x90f6728, job=0x9dc67d8) at ../../akonadi/entitycache_p.h:190
#42 0xab1dbeca in Akonadi::EntityCacheBase::qt_metacall (this=0x90f6728, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf89c2a8) at ./entitycache_p.moc:77
#43 0xb6406b7d in metacall (argv=0xbf89c2a8, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x90f6728) at kernel/qmetaobject.cpp:237
#44 QMetaObject::metacall (object=0x90f6728, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xbf89c2a8) at kernel/qmetaobject.cpp:232
#45 0xb6415a6a in QMetaObject::activate (sender=0x9dc67d8, m=0xb687658c, local_signal_index=3, argv=0xbf89c2a8) at kernel/qobject.cpp:3278
#46 0xb66c8ea5 in KJob::result (this=0x9dc67d8, _t1=0x9dc67d8) at ./kjob.moc:194
#47 0xb66c8ef8 in KJob::emitResult (this=0x9dc67d8) at ../../kdecore/jobs/kjob.cpp:312
#48 0xab22f39e in Akonadi::JobPrivate::delayedEmitResult (this=0x983e090) at ../../akonadi/job.cpp:144
#49 0xab2300af in Akonadi::Job::qt_metacall (this=0x9dc67d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x99df6b0) at ./job.moc:91
#50 0xab21bc52 in Akonadi::ItemFetchJob::qt_metacall (this=0x9dc67d8, _c=QMetaObject::InvokeMetaMethod, _id=34, _a=0x99df6b0) at ./itemfetchjob.moc:73
#51 0xb6406b7d in metacall (argv=0x99df6b0, idx=34, cl=QMetaObject::InvokeMetaMethod, object=0x9dc67d8) at kernel/qmetaobject.cpp:237
#52 QMetaObject::metacall (object=0x9dc67d8, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0x99df6b0) at kernel/qmetaobject.cpp:232
#53 0xb6411685 in QMetaCallEvent::placeMetaCall (this=0x9aa5eb0, object=0x9dc67d8) at kernel/qobject.cpp:535
#54 0xb6418b52 in QObject::event (this=0x9dc67d8, e=0x9aa5eb0) at kernel/qobject.cpp:1217
#55 0xb592bd54 in notify_helper (e=0x9aa5eb0, receiver=0x9dc67d8, this=0x84835b8) at kernel/qapplication.cpp:4486
#56 QApplicationPrivate::notify_helper (this=0x84835b8, receiver=0x9dc67d8, e=0x9aa5eb0) at kernel/qapplication.cpp:4458
#57 0xb5931103 in QApplication::notify (this=0x9aa5eb0, receiver=0x9dc67d8, e=0x9aa5eb0) at kernel/qapplication.cpp:3886
#58 0xb6a65681 in KApplication::notify (this=0x846e0e0, receiver=0x9dc67d8, event=0x9aa5eb0) at ../../kdeui/kernel/kapplication.cpp:311
#59 0xb640019e in QCoreApplication::notifyInternal (this=0x846e0e0, receiver=0x9dc67d8, event=0x9aa5eb0) at kernel/qcoreapplication.cpp:787
#60 0xb6403f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#61 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x842f2e0) at kernel/qcoreapplication.cpp:1428
#62 0xb64040ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#63 0xb642e6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=0x8485800) at kernel/qeventdispatcher_glib.cpp:277
#65 0xb2eb625f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#66 0xb2eb6990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#67 0xb2eb6c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#68 0xb642eada in QEventDispatcherGlib::processEvents (this=0x8430218, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#69 0xb59e3e3a in QGuiEventDispatcherGlib::processEvents (this=0x8430218, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#70 0xb63ff1dd in QEventLoop::processEvents (this=0xbf89c9d4, flags=...) at kernel/qeventloop.cpp:149
#71 0xb63ff421 in QEventLoop::exec (this=0xbf89c9d4, flags=...) at kernel/qeventloop.cpp:201
#72 0xb640419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#73 0xb59298f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#74 0xb76d718b in kdemain (argc=1, argv=0xbf89cbd4) at ../../../../plasma/desktop/shell/main.cpp:120
#75 0x0804850b in main (argc=1, argv=0xbf89cbd4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 286990, bug 285777, bug 285571, bug 284223, bug 283111.

Reported using DrKonqi
Comment 1 Thijs 2012-01-03 07:55:07 UTC

*** This bug has been marked as a duplicate of bug 279322 ***