Bug 290373 - regression: opening "My Bugs" on BKO opens "Configure Validator Plugin"
Summary: regression: opening "My Bugs" on BKO opens "Configure Validator Plugin"
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: Git
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-02 08:50 UTC by Martin Koller
Modified: 2014-04-21 16:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2012-01-02 08:50:29 UTC
Version:           0.0.1 (using Devel) 
OS:                Linux

I open konqueror/khtml with bugs.kde.org, click in the Saved Searches area on "My Bugs" and the "Configure Validator Plugin" dialog appears ... ???

Reproducible: Always

Steps to Reproduce:
see above

Actual Results:  
Dialog shows

Expected Results:  
no dialog

OS: Linux (i686) release 2.6.34.10-0.4-desktop
Compiler: gcc
Comment 1 Christoph Feck 2012-01-03 17:05:45 UTC
What happens if you only copy the page URL, quit Konqueror, and restart it with the URL from clipboard?
Comment 2 Martin Koller 2012-01-03 17:12:31 UTC
The same (dialog appears). In konsole I see the following messages, don't know if related:

Object::connect: No such signal KHTMLPartBrowserExtension::openURLNotify()
Object::connect:  (sender name:   'KHTMLBrowserExtension')
Object::connect: No such signal KHTMLPartBrowserExtension::setLocationBarURL( const QString& )
Object::connect:  (sender name:   'KHTMLBrowserExtension')
Comment 3 Martin Koller 2012-01-23 19:05:23 UTC
I have since updated my Laptop to openSuse 12.1 with KDE 4.7.2 and I see the same problem. So this is not a regression in 4.8 but one after 4.6.5 which I used before. But it does not happen with a different user account.

I now analyzed what's the origin and found out that it happens always when the "Website Validators" extension is enabled. (even if the checkbox "run after loading a page" in this configuration dialog is unchecked, which is the default anyway)
Comment 4 Christoph Feck 2012-01-23 21:17:47 UTC
I do not have "Website Validators" enabled, and can reproduce the issue by simply reloading a bko page.
Comment 5 Martin Koller 2014-04-21 16:31:04 UTC
I can no longer reproduce this with openSuse 13.1, KDE 4.13.0