Bug 290344 - Collection becomes empty, stats loss
Summary: Collection becomes empty, stats loss
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Collections/Local (show other bugs)
Version: 2.4.3
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-01 19:46 UTC by Fabsk
Modified: 2012-03-11 09:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabsk 2012-01-01 19:46:42 UTC
Version:           2.4.3 (using KDE 4.7.3) 
OS:                Linux

The first thing I noticed is that after starting my machine, my collection was empty. Doing a full-scan repopulated it, but it happened again many times after the login in the next days. It also happened one day in the middle of a session.

Then, I switched to my local MySQL (easier to track issues, no need to stop amarok and mount its db on a mysql). A couple of times, the collection was rebuilt automatically  at start-up (takes some time).
I also noticed that after some partial updates (automatic or not), my collection would only contain a few tracks. A full scan would repopulate it.
At that moment, I realized that I lost a big part of my stats, including the ratings that took my quite some time to do. In the DB, I saw that there were new entries for the tracks in the table 'urls', so the entries in the table statistics were pointing on urls that were not existing any more (they also had the flag 'deleted').

For the moment, the only solutions I have are:
- restore the dump of the previous day
- manually apply the ratings I saved (using a joint between urls and statistics)

Reproducible: Sometimes

Steps to Reproduce:
Start amarok, play and rate tracks 

Actual Results:  
Collection get empty or only have a few tracks
Stats are lost

Expected Results:  
Stats should not be lost
Comment 1 Fabsk 2012-01-01 19:49:58 UTC
platform: amd64

mysql 5.1.58-1ubuntu1
amarok 2:2.4.3-1ubuntu2.1
Comment 2 Myriam Schweingruber 2012-01-02 00:19:36 UTC
Please upgrade to Amarok 2.5, this should be solved now. See also http://kubuntu.org/news
Comment 3 Fabsk 2012-01-04 19:28:38 UTC
Thank you for your help. I upgraded and since I did not lose any stat, thought that I had an automatic full rescan this evening at startup.
I noticed that the difference between today and yesterday in the table «urls» is that:
- yesterday full paths where used (/mnt/storage/music/…)
- today it's back to relative paths (./music/…) as it used to be
It may explain the full rescan…
Comment 4 Myriam Schweingruber 2012-02-29 11:08:01 UTC
Than you for the feedback, closing correctly.
Comment 5 auxsvr 2012-03-11 09:11:09 UTC
I have exactly the same issue with amarok 2.5.0 on opensuse 12.1. Is there any way to work around this? Amarok is useless here since 2.4.3.