Bug 290314 - KDevelop 4 crash when using builtin shell
Summary: KDevelop 4 crash when using builtin shell
Status: RESOLVED DUPLICATE of bug 260741
Alias: None
Product: kdevplatform
Classification: Unclassified
Component: filemanager (show other bugs)
Version: 0.9.94
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 1.2.3
Assignee: kdevelop-bugs-null
URL:
Keywords:
: 290738 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-01 13:08 UTC by yp1995
Modified: 2012-12-01 16:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yp1995 2012-01-01 13:08:17 UTC
Application: kdevelop (4.2.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
After I start KDevelop it crashes after a time when I use the builtin shell.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7c81981780 (LWP 9414))]

Thread 11 (Thread 0x7f7c6895c700 (LWP 9415)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00007f7c7fe8e11e in wait (time=1000, this=0x3870d90) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x3857450, time=1000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7c7c255c7b in ?? () from /usr/lib/libkdevplatformlanguage.so.3
#4  0x00007f7c7fe8dd05 in QThreadPrivate::start (arg=0x3857430) at thread/qthread_unix.cpp:331
#5  0x00007f7c7dee3efc in start_thread (arg=0x7f7c6895c700) at pthread_create.c:304
#6  0x00007f7c7eb6489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f7c5ebd8700 (LWP 9421)):
#0  __libc_enable_asynccancel () at ../nptl/sysdeps/unix/sysv/linux/x86_64/cancellation.S:66
#1  0x00007f7c7eb58758 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:85
#2  0x00007f7c79aeef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7c79aef429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7c7ff9ff3e in QEventDispatcherGlib::processEvents (this=0x7f7c5801a470, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f7c7ff73cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f7c7ff73ef7 in QEventLoop::exec (this=0x7f7c5ebd7dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f7c7fe8b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f7c7ff56cbf in QInotifyFileSystemWatcherEngine::run (this=0x44f1740) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f7c7fe8dd05 in QThreadPrivate::start (arg=0x44f1740) at thread/qthread_unix.cpp:331
#10 0x00007f7c7dee3efc in start_thread (arg=0x7f7c5ebd8700) at pthread_create.c:304
#11 0x00007f7c7eb6489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f7c5e3d7700 (LWP 9431)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f7c5e3d6af0 in ?? ()
#2  0x00007fff345ff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 8 (Thread 0x7f7c505fb700 (LWP 9489)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7c76c44c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f7c76c44d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f7c7dee3efc in start_thread (arg=0x7f7c505fb700) at pthread_create.c:304
#4  0x00007f7c7eb6489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f7c4fdfa700 (LWP 9490)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f7c4fdf9b40 in ?? ()
#2  0x00007fff345ff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0x7f7c0e0e5700 (LWP 9498)):
#0  0x00007f7c79aeed57 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7c79aef429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7c7ff9ff3e in QEventDispatcherGlib::processEvents (this=0x4e05f20, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007f7c7ff73cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f7c7ff73ef7 in QEventLoop::exec (this=0x7f7c0e0e4e00, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007f7c7fe8b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#6  0x00007f7c7fe8dd05 in QThreadPrivate::start (arg=0x4d59ee0) at thread/qthread_unix.cpp:331
#7  0x00007f7c7dee3efc in start_thread (arg=0x7f7c0e0e5700) at pthread_create.c:304
#8  0x00007f7c7eb6489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f7c0d8e4700 (LWP 9499)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f7c0d8e3b20 in ?? ()
#2  0x00007fff345ff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 4 (Thread 0x7f7c0d0e3700 (LWP 9504)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7c7fe8e1ab in wait (time=18446744073709551615, this=0x2980b70) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x28ba730, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7c77628864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2986000, th=0x4e07190) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f7c7762ae0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x28bb2e0, th=0x4e07190) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f7c77629ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f7c0d0e2e20, parent=0x2986000, th=0x4e07190) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f7c77629d5b in ThreadWeaver::Thread::run (this=0x4e07190) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f7c7fe8dd05 in QThreadPrivate::start (arg=0x4e07190) at thread/qthread_unix.cpp:331
#8  0x00007f7c7dee3efc in start_thread (arg=0x7f7c0d0e3700) at pthread_create.c:304
#9  0x00007f7c7eb6489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f7c0c8e2700 (LWP 9505)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7c7fe8e1ab in wait (time=18446744073709551615, this=0x2980b70) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x28ba730, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7c77628864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2986000, th=0x7f7c5809b990) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f7c7762ae0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x28bb2e0, th=0x7f7c5809b990) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f7c7762ae24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x28bb2e0, th=0x7f7c5809b990) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f7c77629ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f7c0c8e1e20, parent=0x2986000, th=0x7f7c5809b990) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f7c77629d5b in ThreadWeaver::Thread::run (this=0x7f7c5809b990) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f7c7fe8dd05 in QThreadPrivate::start (arg=0x7f7c5809b990) at thread/qthread_unix.cpp:331
#9  0x00007f7c7dee3efc in start_thread (arg=0x7f7c0c8e2700) at pthread_create.c:304
#10 0x00007f7c7eb6489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7c0ba7e700 (LWP 10118)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7c69040fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f7c69041019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f7c7dee3efc in start_thread (arg=0x7f7c0ba7e700) at pthread_create.c:304
#4  0x00007f7c7eb6489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7c81981780 (LWP 9414)):
[KCrash Handler]
#6  QUrlPrivate::parse (this=0x620a7e0, parseOptions=QUrlPrivate::ParseAndSet) at io/qurl.cpp:3759
#7  0x00007f7c7ff2ff4c in QUrl::scheme (this=0x7fff345b8450) at io/qurl.cpp:4430
#8  0x00007f7c81413529 in hasSubUrl (url=...) at ../../kdecore/io/kurl.cpp:986
#9  KUrl::hasSubUrl (this=0x7fff345b8450) at ../../kdecore/io/kurl.cpp:1031
#10 0x00007f7c81417a53 in KUrl::addPath (this=0x7fff345b8450, _txt=...) at ../../kdecore/io/kurl.cpp:1344
#11 0x00007f7c7c843875 in KDevelop::AbstractFileManagerPlugin::Private::addJobItems(KDevelop::FileManagerListJob*, KDevelop::ProjectFolderItem*, QList<KIO::UDSEntry> const&, bool) () from /usr/lib/libkdevplatformproject.so.3
#12 0x00007f7c7c844657 in KDevelop::AbstractFileManagerPlugin::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdevplatformproject.so.3
#13 0x00007f7c7ff87eba in QMetaObject::activate (sender=0x660d500, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff345b86b0) at kernel/qobject.cpp:3278
#14 0x00007f7c7c8456b2 in ?? () from /usr/lib/libkdevplatformproject.so.3
#15 0x00007f7c7c845723 in ?? () from /usr/lib/libkdevplatformproject.so.3
#16 0x00007f7c7c845b14 in ?? () from /usr/lib/libkdevplatformproject.so.3
#17 0x00007f7c7ff87eba in QMetaObject::activate (sender=0x4b251b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff345b8870) at kernel/qobject.cpp:3278
#18 0x00007f7c814205b2 in KJob::result (this=<optimized out>, _t1=0x4b251b0) at ./kjob.moc:194
#19 0x00007f7c814205f0 in KJob::emitResult (this=0x4b251b0) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00007f7c7d234ad4 in KIO::SimpleJob::slotFinished (this=0x4b251b0) at ../../kio/kio/job.cpp:494
#21 0x00007f7c7d2399d5 in KIO::ListJob::slotFinished (this=0x4b251b0) at ../../kio/kio/job.cpp:2670
#22 0x00007f7c7d23ec99 in KIO::ListJob::qt_metacall (this=0x4b251b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff345b8b30) at ./jobclasses.moc:821
#23 0x00007f7c7ff87eba in QMetaObject::activate (sender=0x3860940, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#24 0x00007f7c7d2e21d1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#25 0x00007f7c7d2df085 in KIO::SlaveInterface::dispatch (this=0x3860940) at ../../kio/kio/slaveinterface.cpp:88
#26 0x00007f7c7d2d224e in KIO::Slave::gotInput (this=0x3860940) at ../../kio/kio/slave.cpp:344
#27 0x00007f7c7d2d29ac in KIO::Slave::qt_metacall (this=0x3860940, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff345b8f60) at ./slave.moc:82
#28 0x00007f7c7ff87eba in QMetaObject::activate (sender=0x411fc80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#29 0x00007f7c7d205577 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#30 KIO::ConnectionPrivate::dequeue (this=0x37fd130) at ../../kio/kio/connection.cpp:71
#31 0x00007f7c7d20561d in KIO::Connection::qt_metacall (this=0x411fc80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x64337c0) at ./connection.moc:79
#32 0x00007f7c7ff8ba5e in QObject::event (this=0x411fc80, e=<optimized out>) at kernel/qobject.cpp:1217
#33 0x00007f7c7f325424 in notify_helper (e=0x4ccce30, receiver=0x411fc80, this=0x24545d0) at kernel/qapplication.cpp:4486
#34 QApplicationPrivate::notify_helper (this=0x24545d0, receiver=0x411fc80, e=0x4ccce30) at kernel/qapplication.cpp:4458
#35 0x00007f7c7f32a291 in QApplication::notify (this=0x7fff345b9a00, receiver=0x411fc80, e=0x4ccce30) at kernel/qapplication.cpp:4365
#36 0x00007f7c80753126 in KApplication::notify (this=0x7fff345b9a00, receiver=0x411fc80, event=0x4ccce30) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x000000000040a896 in _start ()

Possible duplicates by query: bug 275134, bug 261994.

Reported using DrKonqi
Comment 1 Aleix Pol 2012-01-20 19:36:33 UTC
*** Bug 290738 has been marked as a duplicate of this bug. ***
Comment 2 Kevin Funk 2012-12-01 16:44:56 UTC
Marking as duplicate, backtrace is the same.

*** This bug has been marked as a duplicate of bug 260741 ***