Bug 290278 - selection wrong after file deletion
Summary: selection wrong after file deletion
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: details mode (show other bugs)
Version: 1.99
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-31 18:38 UTC by Martin Koller
Modified: 2012-01-05 19:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2011-12-31 18:38:12 UTC
Version:           1.6.1 (using Devel) 
OS:                Linux

In 4.8.RC1 when I use the details view mode and select some files and delete them, dolphin now suddenly shows the files below the just deleted ones being selected.
This seems to happen only when the selection was made by shift-selection (click on first, Shift click on last file), but not when selecting the files individually with CTRL-click

Reproducible: Always

Steps to Reproduce:
see above

Actual Results:  
see above

Expected Results:  
no selection when selected files are deleted

OS: Linux (i686) release 2.6.34.10-0.4-desktop
Compiler: gcc
Comment 1 Peter Penz 2011-12-31 19:26:41 UTC
Thanks for the report - this issue most probably has been fixed just 2 days ago. I currently have no access to my desktop pc and could not verify this with the ctrl / shift- selection but the fix that had been done is closely related to this report and I'm very sure it has the same root-cause. But I'll leave this issue open until I have access again (~ Monday).
Comment 2 Peter Penz 2012-01-05 19:52:16 UTC
Sorry for the delay - anyhow the issue seems to be fixed in the meantime. I observed a minor other issue with the current item and have reported it in bug 290736.