Bug 290276 - details tree view no longer shows lines
Summary: details tree view no longer shows lines
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: details mode (show other bugs)
Version: 1.99
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 289089 293764 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-31 18:29 UTC by Martin Koller
Modified: 2012-02-14 20:51 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.1


Attachments
screenshot of details view compared to treeview in kmail (30.15 KB, image/png)
2011-12-31 18:30 UTC, Martin Koller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2011-12-31 18:29:33 UTC
Version:           1.6.1 (using Devel) 
OS:                Linux

I upgraded from 4.6.5 to 4.8RC1 and now the details view (tree) mode of a directory no longer shows the lines between nodes and subnodes in the tree
(I'm using the QtCurve Style), however kmail still shows the lines in its tree (kmail is still from 4.4.1 here).
See attached screenshot.

Reproducible: Always

Steps to Reproduce:
use dolphin in details tree view mode


Expected Results:  
lines shall be shown as was in 4.6.5 when I configure QtCurve to do so

OS: Linux (i686) release 2.6.34.10-0.4-desktop
Compiler: gcc
openSuse 11.3
Comment 1 Martin Koller 2011-12-31 18:30:10 UTC
Created attachment 67285 [details]
screenshot of details view compared to treeview in kmail
Comment 2 Martin Koller 2011-12-31 18:32:39 UTC
It is the same problem with the Oxygen style and the option "draw tree branch lines enabled", so it seems dolphin hardcoded disables the branch lines instead using what the user configured
Comment 3 Thomas Zander 2012-01-02 11:12:46 UTC
I would conclude, without actually checking, this is a missing feature in the itemviewsng component thats used in dolphin (and not (yet) in kmail).

If my optimistic conclusion is correcct; I would suggest changing the severity to wishlist.
Comment 4 Martin Koller 2012-01-02 11:18:42 UTC
If it is a missing feature in a reimplementation of a component, it is still a bug (regression) since with the previous implementation it worked fine.
Comment 5 Peter Penz 2012-01-02 12:38:45 UTC
As Thomas concluded the implementation of the "draw tree branch lines" is currently simply missing in the view-engine of Dolphin. So Dolphin did not disable them on purpose (although I personally prefer having no lines but of course Dolphin should respect the current style and don't force anyone with my personal preferences ;-)).

To me it is not so important whether this issue is classified as "wishlist" or "normal" bug. I agree here with Martin that it is a bug or (from a users point of view) even a regression.
Comment 6 Christoph Feck 2012-01-05 16:42:42 UTC
Peter, I am still looking at a jungle of files, can you point me to the place where the branch indicators are rendered, so that I can see if it is easy to add the tree lines? I failed to find "QStyle::PE_IndicatorBranch"...
Comment 7 Peter Penz 2012-01-05 18:13:32 UTC
@Christoph: Thanks for your help, but sadly it is not that easy... Currently there is no information in the item which kind of indicator-branch must be drawn and all items are independent from each other. For getting the kind of indicator-branch also the information is required whether there is a successor item etc. I've done this kind of thing already twice for other projects and conceptually it is no big deal to get it done, but it is definitely something in the range of ~50 - 100 lines of code :-/
Comment 8 Nikita Skovoroda 2012-01-08 10:25:13 UTC
This was on my «to-complain on rc2 list» :-). (See bug #284646).
Wanted to create a report today, but found it already reported.

This looks like a regression to me.

Dolphin details view should respect configuration in oxygen-settings. Lines and tree-buttons are configurable from there, but Dolphin 2.0 ignores those settings now.
Comment 9 Peter Penz 2012-01-08 15:16:59 UTC
*** Bug 289089 has been marked as a duplicate of this bug. ***
Comment 10 Nikita Skovoroda 2012-01-08 19:35:25 UTC
Can this be fixed before 4.8.0 release (to not introduce a regression)?
Comment 11 Peter Penz 2012-01-08 21:19:23 UTC
No sorry, this cannot be fixed until the 4.8 release...
Comment 12 2012-01-20 04:11:27 UTC
We are in branch 4.8 for some time, why is still not possible to fix this bug?
This is a regression since dolphin used to show a cross inside a litle box when i choosed the theme plastique.  i dont know what name is used to call those litle crosses :)
Comment 13 Peter Penz 2012-01-20 08:35:08 UTC
> We are in branch 4.8 for some time, why is still not possible to fix this bug?

@Zé: As far as I know your following the KDE development since a few years already and seem to make daily builds, give feedback on kde-devel@kde.org. I'm really surprised about your question...

At the moment Dolphin has 297 open bugs and 447 open wishes. There are a lot more important issues out there that needs to be fixed first before. The Dolphin team is very small and each member contributes the patches in their spare-time. This issue is a visual inconsistency that should be fixed, but it does not break the workflow for anybody and hence the priority is medium and not high to fix this. If you read comment #7 you will notice that a patch for this is not doable in a few minutes. Although fixing this is not tricky it will take several hours. And I won't spend several hours to fix a visual inconsistency if there are more serious issues out there that really are a problem for users.
Comment 14 2012-01-22 06:18:41 UTC
I understand but i dont think that this can be considered that trivial, at least in my POP (as for many other users) its very important the visual effect, just so that you know  i prefer to go back to a SHA from end of July, than use dolphin 2.0, mainly because of this problem and the expandable folders.

I dont get why you got surprised, this was a matter that i already discussed with you, still your opinion about whats more important to fix is the one that prevails so i need to continue to poke you some here, some there to see if you dont forget about it :)

If i had the knowledge, joining dolphin team would be my first choice but maybe that day isnt that so far away...
Comment 15 Peter Penz 2012-02-10 10:47:54 UTC
*** Bug 293764 has been marked as a duplicate of this bug. ***
Comment 16 Peter Penz 2012-02-14 17:05:13 UTC
Git commit e505c3ae5a8df306992777b7ba121036a7d8933d by Peter Penz.
Committed on 14/02/2012 at 18:04.
Pushed by ppenz into branch 'KDE/4.8'.

Details view: Fix indicator-branches

Up to now no indicator-branches have been drawn when showing a tree. The patch
fixes this so that that the style-dependent branches are drawn.

The main part of the patch is the implementation of
KItemListView::updateSiblingsInformation(). Most of the other changes are
related due to an internal renaming of the expansionsLevel-role to
expandedParentsCount and some related cleanups.
FIXED-IN: 4.8.1

M  +3    -3    dolphin/src/kitemviews/kfileitemlistview.cpp
M  +57   -20   dolphin/src/kitemviews/kfileitemlistwidget.cpp
M  +2    -0    dolphin/src/kitemviews/kfileitemlistwidget.h
M  +76   -68   dolphin/src/kitemviews/kfileitemmodel.cpp
M  +13   -12   dolphin/src/kitemviews/kfileitemmodel.h
M  +128  -0    dolphin/src/kitemviews/kitemlistview.cpp
M  +14   -0    dolphin/src/kitemviews/kitemlistview.h
M  +26   -7    dolphin/src/kitemviews/kitemlistwidget.cpp
M  +13   -0    dolphin/src/kitemviews/kitemlistwidget.h
M  +6    -0    dolphin/src/kitemviews/kitemmodelbase.cpp
M  +6    -0    dolphin/src/kitemviews/kitemmodelbase.h
M  +3    -3    dolphin/src/tests/kfileitemmodeltest.cpp

http://commits.kde.org/kde-baseapps/e505c3ae5a8df306992777b7ba121036a7d8933d
Comment 17 Peter Penz 2012-02-14 17:05:49 UTC
Git commit e2645b3a2bd0fbe99890e86acaa82a66cfb49b7f by Peter Penz.
Committed on 14/02/2012 at 18:04.
Pushed by ppenz into branch 'master'.

Details view: Fix indicator-branches

Up to now no indicator-branches have been drawn when showing a tree. The patch
fixes this so that that the style-dependent branches are drawn.

The main part of the patch is the implementation of
KItemListView::updateSiblingsInformation(). Most of the other changes are
related due to an internal renaming of the expansionsLevel-role to
expandedParentsCount and some related cleanups.
FIXED-IN: 4.8.1

M  +3    -3    dolphin/src/kitemviews/kfileitemlistview.cpp
M  +57   -20   dolphin/src/kitemviews/kfileitemlistwidget.cpp
M  +2    -0    dolphin/src/kitemviews/kfileitemlistwidget.h
M  +76   -68   dolphin/src/kitemviews/kfileitemmodel.cpp
M  +13   -12   dolphin/src/kitemviews/kfileitemmodel.h
M  +128  -0    dolphin/src/kitemviews/kitemlistview.cpp
M  +14   -0    dolphin/src/kitemviews/kitemlistview.h
M  +26   -7    dolphin/src/kitemviews/kitemlistwidget.cpp
M  +13   -0    dolphin/src/kitemviews/kitemlistwidget.h
M  +6    -0    dolphin/src/kitemviews/kitemmodelbase.cpp
M  +6    -0    dolphin/src/kitemviews/kitemmodelbase.h
M  +3    -3    dolphin/src/tests/kfileitemmodeltest.cpp

http://commits.kde.org/kde-baseapps/e2645b3a2bd0fbe99890e86acaa82a66cfb49b7f
Comment 18 Christoph Feck 2012-02-14 19:28:01 UTC
Wow, lots of code to bring the trees back :) Peter, your rate of fixing is fantastic, thanks!
Comment 19 Peter Penz 2012-02-14 20:51:12 UTC
> Wow, lots of code to bring the trees back 

It's actually not that much as it looks like. But during implementing it I detected some related things that should be cleaned up and did this in the scope of this issue. But still it is of course no 3-liner patch ;-)

> Peter, your rate of fixing is fantastic, thanks!

Thanks :-) Some finetuning for this issue is still necessary but this should be finished until tomorrow.