Bug 289723 - Incorrect charset is used for reply to openpgp encrypted message
Summary: Incorrect charset is used for reply to openpgp encrypted message
Status: RESOLVED DUPLICATE of bug 289728
Alias: None
Product: kmail2
Classification: Unclassified
Component: crypto (show other bugs)
Version: 4.7
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-24 09:57 UTC by Stanislav Sidorenko
Modified: 2012-01-08 10:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Sidorenko 2011-12-24 09:57:50 UTC
Version:           4.7 (using KDE 4.7.3) 
OS:                Linux

If pgp/mime encrypted message contains non 7bit characters, e.g. utf-8 characters then reply template to this message will contain non-readable data.

Reproducible: Always

Steps to Reproduce:
1) Create a new message with some utf-8 chracters, e.g. "Тестовое сообщение"
2) Enable pgp/mime encryption.
3) Send message to yourself.
4) Receive it, open and click reply.

Actual Results:  
Message compose window appear with the following text:

> âõÃÂÃÂþòþõ ÃÂþþñÃÂõýøõ

Expected Results:  
Message compose window should contain correctly encoded text:

> Тестовое сообщение
Comment 1 Christophe Giboudeaux 2012-01-08 10:33:13 UTC

*** This bug has been marked as a duplicate of bug 289728 ***