Bug 289604 - rekonq does not load some webpages fully
Summary: rekonq does not load some webpages fully
Status: RESOLVED UPSTREAM
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: 0.10
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-22 18:07 UTC by sahinsureyya
Modified: 2012-06-18 14:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sahinsureyya 2011-12-22 18:07:14 UTC
Version:           unspecified
OS:                Linux

In news websites, rekonq fails to load pictures and/or video links. Instead, I see blank frames with picture logo on them. Some of the frames may be the blocked static advertisements if the adblock with element hiding option is used.

Reproducible: Always

Steps to Reproduce:
Go to the turkish news site www.ntv.com.tr. This happens occasionally with www.cnn.com or www.nytimes.com or www.amazon.com as well.

Actual Results:  
You will see that some of the pictures and video links are not loaded. 

Expected Results:  
I would expect to see the webpages fully loaded with pictures and video links. If the adblock is on, I would expect that the blocked elements would be invisible totally.
Comment 1 Andrea Diamantini 2011-12-23 11:44:22 UTC
Every site you reported works well here with rekonq 0.8.1, qtwebkit 2.2, kdelibs 4.7.
Can you please check your cache settings in the network section of the configuration dialog?
If not, try setting "keep cache in sync". And please, report your rekonq, qtwebkit, kdelibs version.
Comment 2 sahinsureyya 2011-12-23 14:41:54 UTC
I am using kdelibs version 4.7.4 and qtwebkit 2.2 on 
openSUSE12.1. I am using rekonq compiled from the git 
repository.

My Cache settings are "Use cache" with "Keep cache in sync" 
enabled. I have a disk cache size of 51200 KiB. Would you 
recommend increasing the Disk cache size?
Comment 3 Andrea Diamantini 2011-12-23 15:55:18 UTC
(In reply to comment #2)
> I am using kdelibs version 4.7.4 and qtwebkit 2.2 on 
> openSUSE12.1. I am using rekonq compiled from the git 
> repository.
> 
> My Cache settings are "Use cache" with "Keep cache in sync" 
> enabled. I have a disk cache size of 51200 KiB. Would you 
> recommend increasing the Disk cache size?

No, your settings are ok. I was asking because of some strange behavior of cached data in some circustances.
Maybe this is an adblock related problem. Investigating about...
Comment 4 sahinsureyya 2011-12-23 17:05:17 UTC
On Friday, December 23, 2011 03:55:19 PM Andrea Diamantini 
wrote:
> https://bugs.kde.org/show_bug.cgi?id=289604
> 
> 
> 
> 
> 
> --- Comment #3 from Andrea Diamantini <adjam7 gmail com> 
> 2011-12-23 15:55:18 --- (In reply to comment #2)
> 
> > I am using kdelibs version 4.7.4 and qtwebkit 2.2 on
> > openSUSE12.1. I am using rekonq compiled from the git
> > repository.
> > 
> > My Cache settings are "Use cache" with "Keep cache in
> > sync" enabled. I have a disk cache size of 51200 KiB.
> > Would you recommend increasing the Disk cache size?
> 
> No, your settings are ok. I was asking because of some
> strange behavior of cached data in some circustances.
> Maybe this is an adblock related problem. Investigating
> about...

OK, if you need additional information, I will try to provide 
them.

Actually, if you go to kde-look.org, you will also see an 
empty frame with a logo and a text "Sponsoring" just below the 
search box. I guess this one is due to adblock though...
Comment 5 sahinsureyya 2012-05-21 14:01:18 UTC
Just another update; a website which does not do well with rekonq is below

http://life.time.com/

Rekonq fails to load this website properly either when I call this externally from choqok (my twitter accont) or else I open rekonq and try to open the website directly, I checked this website in Firefox as well and it is loading normally with firefox.

I do have other experiences where rekonq does not load streaming media at all. This happens if you want to watch cnn videos (from www.cnn.com and then you click on the videos tab) for example, or if you want to listen to bbc radio from the bbc website.
Comment 6 Andrea Diamantini 2012-06-13 15:48:32 UTC
All the urls reported above work well with rekonq 0.9.80, kdelibs 4.8.x and Qt 4.8.x. At least they seem the same as the ones shown in chromium (but for a known font problem).
What about you with the reported versions?
Comment 7 sahinsureyya 2012-06-13 21:27:48 UTC
I am on Fedora 17, with rekonq built from git 0.9.80, Qt 4.8.2 and Kde 4.8.3. The websites in the original report are loading properly now. Rarely I see the pages loading just picture logos instead of video/picture links. Still I do have problems with a few more websites such as:

http://life.time.com/

I am loading this website with rekonq and I get a crappy web page. If I load the same website with firefox, it is loading properly. I am not sure whether I am missing any plugins or I need to tweak rekonq to see the webpage properly.

Another problem I am having is with streaming media. For example, if I go www.cnn.com and then choose TV&Video tab, I can't watch the videos, but if I choose from the main webpage of cnn, I can watch videos. Same for bbc iplayer radio, I can't listen to bbc radio using rekonq. I am not sure whether I need to install extra packages (codecs etc) or it is a problem with rekonq.

But these are not related to the original bug report. So, I can agree that rekonq is performing better now.
Comment 8 Andrea Diamantini 2012-06-15 21:25:11 UTC
Ok, let's set this as fixed -> upstream then, as the improvements you mentioned depends on webkit and on kde integration rather than directly in rekonq...
About the audio/video problem, qtwebkit is using gstreamer to properly manage it, so get sure you have it installed plus all its plugins (good, bad, ugly... the more, the better)
Comment 9 sahinsureyya 2012-06-15 23:12:38 UTC
OK, just as a last comment for this bug, there is still a similar problem with the following website

http://kde-look.org

if you visit the page and scroll down near the search box (bottom of the items listed under "Artwork" on the left side) you will still see a picture logo. I know that this is a blocked advertisement, konqueror and firefox were correctly blocking and hiding this if I remember correctly. I am not sure why rekonq is not hiding this blocked picture advertisement although I checked "Hide Filtered Elements" option.
Comment 10 Andrea Diamantini 2012-06-17 04:58:22 UTC
Ok, please open a different bug report against it and hopefully we'll fix
it in time for 1.0 stable release :)

2012/6/16 <sahinsureyya@yahoo.ca>

> https://bugs.kde.org/show_bug.cgi?id=289604
>
> --- Comment #9 from sahinsureyya@yahoo.ca ---
> OK, just as a last comment for this bug, there is still a similar problem
> with
> the following website
>
> http://kde-look.org
>
> if you visit the page and scroll down near the search box (bottom of the
> items
> listed under "Artwork" on the left side) you will still see a picture
> logo. I
> know that this is a blocked advertisement, konqueror and firefox were
> correctly
> blocking and hiding this if I remember correctly. I am not sure why rekonq
> is
> not hiding this blocked picture advertisement although I checked "Hide
> Filtered
> Elements" option.
>
> --
> You are receiving this mail because:
> You are the assignee for the bug.
>
Comment 11 sahinsureyya 2012-06-17 12:25:25 UTC
Ok, I filed another report; bug 302050 for the problem on kde-look.org website.
Comment 12 Andrea Diamantini 2012-06-18 14:22:14 UTC
Ok, thanks :)

2012/6/17 <sahinsureyya@yahoo.ca>

> https://bugs.kde.org/show_bug.cgi?id=289604
>
> --- Comment #11 from sahinsureyya@yahoo.ca ---
> Ok, I filed another report; bug 302050 for the problem on kde-look.orgwebsite.
>
> --
> You are receiving this mail because:
> You are the assignee for the bug.
>