Bug 289586 - Rekonq shows 404 error message for favicon, even though not referenced
Summary: Rekonq shows 404 error message for favicon, even though not referenced
Status: RESOLVED DUPLICATE of bug 289029
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.8.1
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: 0.9
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-22 14:00 UTC by Frank Steinmetzger
Modified: 2011-12-29 17:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the website in question (14.16 KB, image/png)
2011-12-22 14:00 UTC, Frank Steinmetzger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2011-12-22 14:00:34 UTC
Created attachment 67023 [details]
Screenshot of the website in question

Version:           0.8.1 (using KDE 4.7.3) 
OS:                Linux

I was browsing a page earlier (www.kalinka-ilmenau.de, see screenshot) and at some point saw apache’s 404 response headers for /favicon.ico. I looked at the source of the page and there was no mentioning of a favicon. I have similar problems with other pages (like showing the 200 response headers, but I can’t remember/describe a particular occurence right now).

Reproducible: Sometimes

Steps to Reproduce:
Browsed on the page klicking around wildly. At some point the described bug occurs.

Actual Results:  
Above the actual page I get to see the verbose apache response headers.

Expected Results:  
The headers should not be shown.
Comment 1 Andrea Diamantini 2011-12-22 16:36:04 UTC
I noticed it also on other pages. It seems to me that sometimes kio mixes qtwebkit requests with other ones (eg: favicons). Or at least this was my first impression. Hopefully workarounding it for 0.8.2 (available asap).
Comment 2 Andrea Diamantini 2011-12-29 17:40:45 UTC

*** This bug has been marked as a duplicate of bug 289029 ***