Bug 289498 - crashed
Summary: crashed
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-21 13:32 UTC by ale.porta.87
Modified: 2012-07-06 18:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ale.porta.87 2011-12-21 13:32:36 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: 
I was turning off my latptop. That's it. I don't now if it's a KDE problem or another software that was running when I quit the pc.
Thanks

-- Backtrace:
Application: Programma stub per servizio di Nepomuk (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7fe1b6fd7780 (LWP 1818))]

Thread 9 (Thread 0x7fe1a1093700 (LWP 2118)):
#0  0x00007fe1b43401fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x20b85f8) at pthread_mutex_unlock.c:290
#2  0x00007fe1b385b013 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe1b385b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe1b6ae5f3e in QEventDispatcherGlib::processEvents (this=0x210b660, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fe1b6ab9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fe1b6ab9ef7 in QEventLoop::exec (this=0x7fe1a1092dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fe1b69d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fe1b6a9ccbf in QInotifyFileSystemWatcherEngine::run (this=0x210c3e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x210c3e0) at thread/qthread_unix.cpp:331
#10 0x00007fe1b433cefc in start_thread (arg=0x7fe1a1093700) at pthread_create.c:304
#11 0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fe19affd700 (LWP 2130)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fe1b6abaafc in QCoreApplication::notifyInternal (this=0x7fff289ff970, receiver=0x2112590, event=0x7fe19affcb50) at kernel/qcoreapplication.cpp:787
#8  0x00007fe1b6ae55b7 in sendEvent (event=0x7fe19affcb50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#9  socketNotifierSourceDispatch (source=0x20f8950) at kernel/qeventdispatcher_glib.cpp:110
#10 0x00007fe1b385aa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fe1b385b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fe1b385b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fe1b6ae5ed6 in QEventDispatcherGlib::processEvents (this=0x2121e00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#14 0x00007fe1b6ab9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#15 0x00007fe1b6ab9ef7 in QEventLoop::exec (this=0x7fe19affcd60, flags=...) at kernel/qeventloop.cpp:201
#16 0x00007fe1b69d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#17 0x00007fe1a7a0a0ae in ?? () from /usr/lib/libsopranoserver.so.1
#18 0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x7fe19c0057d0) at thread/qthread_unix.cpp:331
#19 0x00007fe1b433cefc in start_thread (arg=0x7fe19affd700) at pthread_create.c:304
#20 0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#21 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fe19a7fc700 (LWP 2131)):
#0  0x00007fe1b433f034 in __pthread_mutex_lock (mutex=0x209a7f8) at pthread_mutex_lock.c:61
#1  0x00007fe1b385a023 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe1b385adfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe1b385b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe1b6ae5f3e in QEventDispatcherGlib::processEvents (this=0x20e98e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fe1b6ab9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fe1b6ab9ef7 in QEventLoop::exec (this=0x7fe19a7fbd60, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fe1b69d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fe1a7a0a0ae in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x211bf90) at thread/qthread_unix.cpp:331
#10 0x00007fe1b433cefc in start_thread (arg=0x7fe19a7fc700) at pthread_create.c:304
#11 0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fe199ffb700 (LWP 2132)):
#0  0x00007fe1b433f034 in __pthread_mutex_lock (mutex=0x20a9fa8) at pthread_mutex_lock.c:61
#1  0x00007fe1b385a8c2 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe1b385b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe1b385b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe1b6ae5f3e in QEventDispatcherGlib::processEvents (this=0x20b3150, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fe1b6ab9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fe1b6ab9ef7 in QEventLoop::exec (this=0x7fe199ffad60, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fe1b69d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fe1a7a0a0ae in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x2123bb0) at thread/qthread_unix.cpp:331
#10 0x00007fe1b433cefc in start_thread (arg=0x7fe199ffb700) at pthread_create.c:304
#11 0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fe1997fa700 (LWP 2134)):
#0  __pthread_mutex_lock (mutex=0x2110e08) at pthread_mutex_lock.c:47
#1  0x00007fe1b385af2f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe1b385b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe1b6ae5f3e in QEventDispatcherGlib::processEvents (this=0x20fc720, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe1b6ab9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe1b6ab9ef7 in QEventLoop::exec (this=0x7fe1997f9d60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe1b69d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe1a7a0a0ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x20b35e0) at thread/qthread_unix.cpp:331
#9  0x00007fe1b433cefc in start_thread (arg=0x7fe1997fa700) at pthread_create.c:304
#10 0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fe198ff9700 (LWP 2137)):
#0  0x00007fe1b433f034 in __pthread_mutex_lock (mutex=0x20a7da8) at pthread_mutex_lock.c:61
#1  0x00007fe1b385a023 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe1b385adfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe1b385b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe1b6ae5f3e in QEventDispatcherGlib::processEvents (this=0x20da7a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fe1b6ab9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fe1b6ab9ef7 in QEventLoop::exec (this=0x7fe198ff8d60, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fe1b69d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fe1a7a0a0ae in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x20dd520) at thread/qthread_unix.cpp:331
#10 0x00007fe1b433cefc in start_thread (arg=0x7fe198ff9700) at pthread_create.c:304
#11 0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe1987f8700 (LWP 3461)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe1b69d41ab in wait (time=18446744073709551615, this=0x20c8170) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x20c8120, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fe1b69c881f in QThreadPoolThread::run (this=0x266a6d0) at concurrent/qthreadpool.cpp:140
#4  0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x266a6d0) at thread/qthread_unix.cpp:331
#5  0x00007fe1b433cefc in start_thread (arg=0x7fe1987f8700) at pthread_create.c:304
#6  0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe196ff5700 (LWP 4026)):
#0  0x00007fe1b4627773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe1b385af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe1b385b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe1b6ae5f3e in QEventDispatcherGlib::processEvents (this=0x209a5a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe1b6ab9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe1b6ab9ef7 in QEventLoop::exec (this=0x7fe196ff4d60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe1b69d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe1a7a0a0ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fe1b69d3d05 in QThreadPrivate::start (arg=0x7fe19c0083a0) at thread/qthread_unix.cpp:331
#9  0x00007fe1b433cefc in start_thread (arg=0x7fe196ff5700) at pthread_create.c:304
#10 0x00007fe1b463389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe1b6fd7780 (LWP 1818)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe1b69d41ab in wait (time=18446744073709551615, this=0x7fe19c031540) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fe19c00bc10, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fe1b69d3a4c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:745
#4  0x00007fe1a7a09628 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007fe1a7a0fc43 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007fe1a7a05e7e in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007fe1a7c3dc6c in Nepomuk::Core::~Core (this=0x2005990, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:45
#8  0x00007fe1a7c3dd19 in Nepomuk::Core::~Core (this=0x2005990, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#9  0x00007fe1b6accd75 in QObjectPrivate::deleteChildren (this=0x2011090) at kernel/qobject.cpp:1955
#10 0x00007fe1b6ad2349 in QObject::~QObject (this=0x200ffe0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#11 0x00007fe1a7c3cef3 in ~Storage (this=0x200ffe0, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#12 Nepomuk::Storage::~Storage (this=0x200ffe0, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#13 0x00007fe1b6accd75 in QObjectPrivate::deleteChildren (this=0x20066b0) at kernel/qobject.cpp:1955
#14 0x00007fe1b6ad2349 in QObject::~QObject (this=0x2004be0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#15 0x0000000000404439 in Nepomuk::ServiceControl::~ServiceControl (this=0x2004be0, __in_chrg=<optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007fe1b6accd75 in QObjectPrivate::deleteChildren (this=0x1e27680) at kernel/qobject.cpp:1955
#17 0x00007fe1b6ad2349 in QObject::~QObject (this=0x7fff289ff970, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#18 0x00007fe1b4dfdf87 in QApplication::~QApplication (this=0x7fff289ff970, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#19 0x0000000000403a54 in main (argc=2, argv=0x7fff289ffe18) at ../../../nepomuk/servicestub/main.cpp:105

This bug may be a duplicate of or related to bug 257176.

Possible duplicates by query: bug 289434, bug 289390, bug 289271, bug 289198, bug 288744.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-06 18:12:54 UTC

*** This bug has been marked as a duplicate of bug 292950 ***