Bug 289109 - Amarok crashes on exit after unsuccessfully trying to add a AudioCD file to playlist
Summary: Amarok crashes on exit after unsuccessfully trying to add a AudioCD file to p...
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.4.90 (2.5 beta)
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-16 11:20 UTC by Harald Brennich
Modified: 2011-12-17 16:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Brennich 2011-12-16 11:20:50 UTC
Application: amarok (2.4.90)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.0-rc4-154-g8e8da02-1-vanilla-debug x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
1. Insert Audio CD
2. Select source Audio CD
3. Select a wav file and try to add it to playlist. Nothing happens.
4. Quit amarok. Amarok crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe765c9f760 (LWP 2674))]

Thread 9 (Thread 0x7fe745f7e700 (LWP 2686)):
#0  0x00007fff4a313928 in ?? ()
#1  0x00007fe745f7db10 in ?? ()
#2  0x00007fe75c2f02b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007fe7638aa162 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fe763981d3d in ?? () from /usr/lib64/libQtCore.so.4
#5  0x00007fe7639820b5 in ?? () from /usr/lib64/libQtCore.so.4
#6  0x00007fe763980b6c in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007fe763980c15 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007fe75c03f087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#9  0x00007fe75c03ffa9 in ?? () from /lib64/libglib-2.0.so.0
#10 0x00007fe75c040650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#11 0x00007fe7639813e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#12 0x00007fe763951492 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#13 0x00007fe76395170d in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#14 0x00007fe76384f458 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#15 0x00007fe76392fea8 in ?? () from /usr/lib64/libQtCore.so.4
#16 0x00007fe763851b4b in ?? () from /usr/lib64/libQtCore.so.4
#17 0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#18 0x00007fe76233966d in clone () from /lib64/libc.so.6
#19 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fe73f959700 (LWP 2687)):
#0  0x00007fe7623304f3 in poll () from /lib64/libc.so.6
#1  0x00007fe75c040114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fe75c040650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fe7639813e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007fe763951492 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007fe76395170d in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007fe76384f458 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007fe763851b4b in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe76233966d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fe73ead6700 (LWP 2688)):
#0  0x00007fe7623304f3 in poll () from /lib64/libc.so.6
#1  0x00007fe75c040114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fe75c040650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fe7639813e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007fe763951492 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007fe76395170d in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007fe76384f458 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007fe763851b4b in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe76233966d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fe73dad4700 (LWP 2697)):
#0  0x00007fe7604ea38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe763852abb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fe75f8d472e in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007fe75f8d71f3 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007fe75f8d5f6f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007fe75f8d5ff8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007fe763851b4b in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#8  0x00007fe76233966d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fe737fff700 (LWP 2806)):
#0  0x00007fe7604ea38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe759076d74 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#3  0x00007fe76233966d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fe7377fe700 (LWP 2807)):
#0  0x00007fe7604ea38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe763852abb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fe75f8d472e in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007fe75f8d71f3 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007fe75f8d720c in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007fe75f8d720c in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007fe75f8d720c in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007fe75f8d720c in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007fe75f8d5f6f in ?? () from /usr/lib64/libthreadweaver.so.4
#9  0x00007fe75f8d5ff8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#10 0x00007fe763851b4b in ?? () from /usr/lib64/libQtCore.so.4
#11 0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#12 0x00007fe76233966d in clone () from /lib64/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe7367fc700 (LWP 2824)):
#0  0x00007fe7604ea38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe763852abb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fe75f8d472e in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007fe75f8d71f3 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007fe75f8d5f6f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007fe75f8d5ff8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007fe763851b4b in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#8  0x00007fe76233966d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe735ffb700 (LWP 2825)):
#0  0x00007fe7604ea38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe763852abb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fe75f8d472e in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007fe75f8d71f3 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007fe75f8d5f6f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007fe75f8d5ff8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007fe763851b4b in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007fe7604e5a3f in start_thread () from /lib64/libpthread.so.0
#8  0x00007fe76233966d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe765c9f760 (LWP 2674)):
[KCrash Handler]
#6  0x0000000000da451a in ?? ()
#7  0x00007fe764a613ee in qDeleteAll<QList<Collections::CollectionFactory*>::const_iterator> (this=0xd51c80, __in_chrg=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::CollectionFactory> > (this=0xd51c80, __in_chrg=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0xd51c80, __in_chrg=<value optimized out>) at /usr/src/debug/amarok-2.4.90/src/core-impl/collections/support/CollectionManager.cpp:138
#10 0x00007fe764a61559 in CollectionManager::~CollectionManager (this=0xd51c80, __in_chrg=<value optimized out>) at /usr/src/debug/amarok-2.4.90/src/core-impl/collections/support/CollectionManager.cpp:140
#11 0x00007fe764a5e2d6 in CollectionManager::destroy () at /usr/src/debug/amarok-2.4.90/src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007fe764c390cf in App::~App (this=0x7fff4a243d80, __in_chrg=<value optimized out>) at /usr/src/debug/amarok-2.4.90/src/App.cpp:248
#13 0x000000000040e91c in main (argc=3, argv=0x7fff4a246508) at /usr/src/debug/amarok-2.4.90/src/main.cpp:308

Possible duplicates by query: bug 285951, bug 285541.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-12-17 16:34:45 UTC

*** This bug has been marked as a duplicate of bug 285951 ***