Bug 288913 - Typing 'reset' in Konsole should clear scrollback history
Summary: Typing 'reset' in Konsole should clear scrollback history
Status: RESOLVED DUPLICATE of bug 171598
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.7.2
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-13 18:48 UTC by SiegeLord
Modified: 2011-12-15 11:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SiegeLord 2011-12-13 18:48:48 UTC
Version:           2.7.2 (using KDE 4.7.2) 
OS:                Linux

Issuing the command 'reset' in Konsole does not clear the scrollback buffer like it does in virtually every terminal emulator I can think of (the exceptions are rxvt and its forks). Terminals where that does work include terminator, gnome-terminal, xcfe4-terminal, xterm.

Reproducible: Always

Steps to Reproduce:
Issue the following commands in the Konsole window:

for i in {0..500}; do echo $i; done #fill up the scrollback buffer
reset

Then try scrolling up (e.g. by pressing Shift+PgUp).

Actual Results:  
You will see the numbers printed by the first line.

Expected Results:  
You shouldn't be able to scroll up, as the command prompt shown after the 'reset' command should be the first line in the scroll buffer.

The motivation behind this request is the following workflow:

$ gcc buggy_program.c
<gcc shows thousands of errors>
Fix some of the initial errors
$ gcc buggy_program.c
<gcc shows thousands of errors>

Because of the large number of errors gcc is prone to showing, it is hard to find where the first error is after the second invocation of gcc because they are somewhere in the middle of the scroll buffer. With a working reset command, this becomes easier, as you can discard the first set of errors by issuing it before you invoke gcc again.
Comment 1 Jekyll Wu 2011-12-15 11:41:57 UTC
Thanks for your report.

I think the same problem is also reported in bug 171598. I'm not sure whether the current behavior should be changed, since the current behavior has been there for quite a long time.

As a workaround for your example, use the "Clear Scrollback and Reset" action (default shortcut is Ctrl+Shift+X) to accomplish what 'reset' does in xterm.

BTW, AFAIK, some terminal emulators do not clear history upon 'reset'. Try mlterm and putty/pterm .

*** This bug has been marked as a duplicate of bug 171598 ***