Bug 288575 - Recent changes in kdelibs break controls of amaroks plasma-parts
Summary: Recent changes in kdelibs break controls of amaroks plasma-parts
Status: RESOLVED DUPLICATE of bug 292895
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.9-Git
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-09 15:51 UTC by Christian (Fuchs)
Modified: 2012-06-27 10:21 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the bug: buttons on bottom are missing, size of contents is wrong (19.93 KB, image/png)
2011-12-09 15:51 UTC, Christian (Fuchs)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian (Fuchs) 2011-12-09 15:51:34 UTC
Created attachment 66556 [details]
Screenshot of the bug: buttons on bottom are missing, size of contents is wrong

Version:           Git (using Devel) 
OS:                Linux

Since KDE 4.8 Beta2 changes made in kdelibs break the amarok context view, which uses plasma. Please see the screenshot attached.  Downgrading kdelibs to 4.8 Beta2 solves this issue. 

I tried to bisect, but since kdelibs takes a while to compile here and KDEs webgit is down since yesterday, I didn't manage to find the exact commit breaking it. 

You might have to forward this bug to the correct project, even though the package causing it is kdelibs, you might want to add the plasma people. 

Reproducible: Always

Steps to Reproduce:
- Get kdelibs more recent than 4.8 Beta2 
- Start amarok


Actual Results:  
- The parts using plasma (context view) is broken, both regarding size and missing buttons.

Expected Results:  
External apps are not affected like this when plasma changes.

Qt is 4.7.4, System is gentoo linux on x86_64, the whole kde (kdelibs, base, plasma ...) is a current (yesterday) git/svn build. 

Thanks for investigating, please tell me if there is any further information I can provide.
Comment 1 Myriam Schweingruber 2011-12-15 23:30:38 UTC
Confirmed by users on IRC
Comment 2 Matěj Laitl 2011-12-15 23:37:34 UTC
Hmm, the same error happens in 4.7 branch after the 4.7.4 release:
 * 4.7.4 (as released, kdelibs devs didn't bother to upload a git tag:
http://www.mail-archive.com/release-team@kde.org/msg05261.html ): works okay
 * 8095c11d181 (on the 4.7 branch): the bug can be reproduced as described

This should hopefully shorten an interval for bisecting.
Comment 3 Christian (Fuchs) 2012-01-05 18:59:43 UTC
Duplicate of https://bugs.kde.org/show_bug.cgi?id=290123, partially fixed. The size of the content is still wrong until resized, but at least the buttons are back. 

As soon as this is fixed as well: the only problem remaining: either the packagers have to patch this manually, or there should be a minor amarok release before 4.8 hits the shelves.
Comment 4 BartOtten 2012-01-10 21:25:43 UTC
Having all 'on the edge' the size-problem is still alive and kickin'
Comment 5 mgolden 2012-01-12 18:40:22 UTC
Perhaps this is related: I am the reporter of bug https://bugs.kde.org/show_bug.cgi?id=290123 When I first reported that bug, I was asked to delete all my amarok initialization files in .kde.  When I did that, I didn't see the issue reported in this bug.  However, a few days after that bug was resolved, I restored the files

/home/mgolden/.kde/share/config/amarok-appletsrc
/home/mgolden/.kde/share/config/amarok_homerc
/home/mgolden/.kde/share/config/amarokrc

and now I am seeing this as well.  As others have mentioned, the problem goes away when the application is resized.

Perhaps there is something in one of those files that is being misread.  Probably people who are doing a clean install/test are not seeing this.
Comment 6 Matěj Laitl 2012-06-27 10:21:28 UTC
From the screenshot from Fuchs, this is a duplicate of bug 292895. (or, the missing buttons is another already fixed bug)

*** This bug has been marked as a duplicate of bug 292895 ***