Bug 287864 - Print Margins are NOT retained from one print job to the next
Summary: Print Margins are NOT retained from one print job to the next
Status: RESOLVED DUPLICATE of bug 205802
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 4.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-29 20:37 UTC by Shaun Andrew
Modified: 2011-12-09 17:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shaun Andrew 2011-11-29 20:37:05 UTC
Version:           4.0 (using KDE 4.7.3) 
OS:                Linux

This makes the 3rd time since KDE 4.0 that I have reported the Kate Print Margin FAILURE. 

PRIOR to KDE 4.0, Kate was able to retain Print Margins from one print job to the next, and Kate stored the Print Margin info between sessions.  Kate retained Print Margins back in KDE 2.2!  Kate retained Print Margins up to KDE 3.5.10, then lost the ability since KDE 4.0.

PLEASE restore the retention of Print Margins for Kate.



Reproducible: Always

Steps to Reproduce:
select File->Print
select Properties
change Print Margins
select OK
select Print

repeat...
select File->Print
select Properties
...RATS!  The darn Print Margins are back at their default values!  What a nuisance.


Actual Results:  
Print Margins are NOT retained.  Print Margins return to their default values.

Expected Results:  
Print Margins are RETAINED per user's setting.  I set them and they stay put until I reset them. 

This problem has persisted since KDE 4.0.  That is about 4+ years.
Comment 1 Christoph Feck 2011-12-08 11:07:00 UTC

*** This bug has been marked as a duplicate of bug 205802 ***
Comment 2 Dominik Haumann 2011-12-09 17:22:48 UTC
Shaun, this is valid for ALL KDE and Qt applications. This needs to be fixed in Qt itself, and will probably never happen in Qt4.x, and thus also never be fixed in KDE 4.x. See also:
- https://bugs.kde.org/show_bug.cgi?id=198172
- https://bugreports.qt.nokia.com//browse/QTBUG-15351