Bug 287776 - Amarok crashed after start
Summary: Amarok crashed after start
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-28 17:54 UTC by reychino
Modified: 2011-11-29 16:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description reychino 2011-11-28 17:54:48 UTC
Application: amarok (2.4.3)
KDE Platform Version: 4.7.2 (4.7.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-12-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Everytime I start amarok it chrash down and apears the debug option

- Custom settings of the application:
I installed some applications to customize the program. The program was stable for few days but later it crashed down.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Aborted
[Current thread is 1 (Thread 0xb645e720 (LWP 4422))]

Thread 6 (Thread 0xb6053b70 (LWP 4423)):
#0  0x091d2c72 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0x0929a62b in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x06b7f5e6 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x06b80dde in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x06b8192b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x02c8f304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0x06baa2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x00682e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x0928c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xafa3cb70 (LWP 4445)):
#0  isEmpty (src=0xb4f1ffc0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:95
#1  isEmpty (src=0xb4f1ffc0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:139
#2  timerSourceCheckHelper (src=0xb4f1ffc0) at kernel/qeventdispatcher_glib.cpp:146
#3  0x06b8071d in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x06b8103a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x06b81524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x05c16577 in QEventDispatcherGlib::processEvents (this=0x9a91948, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#7  0x05be8289 in QEventLoop::processEvents (this=0xafa3c280, flags=...) at kernel/qeventloop.cpp:149
#8  0x05be8522 in QEventLoop::exec (this=0xafa3c280, flags=...) at kernel/qeventloop.cpp:201
#9  0x05af22a0 in QThread::exec (this=0x9a7b9e0) at thread/qthread.cpp:492
#10 0x05bc9fdb in QInotifyFileSystemWatcherEngine::run (this=0x9a7b9e0) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x05af4da2 in QThreadPrivate::start (arg=0x9a7b9e0) at thread/qthread_unix.cpp:320
#12 0x00682e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0x0928c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xad38fb70 (LWP 4447)):
#0  0x00c4f416 in __kernel_vsyscall ()
#1  0x0068748c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0929a3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x05af5467 in wait (this=0x9c46680, mutex=0x9c46920, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9c46680, mutex=0x9c46920, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00673210 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9c46668, th=0x9c46c18) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x00675eac in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9c46a00, th=0x9c46c18) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x00672e5b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9c46668, th=0x9c46c18) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x00675f9a in ThreadWeaver::WorkingHardState::applyForWork (this=0x9c46a00, th=0x9c46c18) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00672da3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9c46668, th=0x9c46c18, previous=0xa150a98) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x006749ce in ThreadWeaver::ThreadRunHelper::run (this=0xad38f2e4, parent=0x9c46668, th=0x9c46c18) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x00674a8b in ThreadWeaver::Thread::run (this=0x9c46c18) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x05af4da2 in QThreadPrivate::start (arg=0x9c46c18) at thread/qthread_unix.cpp:320
#13 0x00682e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x0928c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xac9eab70 (LWP 4453)):
#0  0x00c4f416 in __kernel_vsyscall ()
#1  0x0068748c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0929a3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb720eb57 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x00682e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0x0928c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac01eb70 (LWP 4454)):
#0  0x00c4f416 in __kernel_vsyscall ()
#1  0x0068748c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0929a3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x05af5467 in wait (this=0x9c46680, mutex=0x9c46920, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9c46680, mutex=0x9c46920, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00673210 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9c46668, th=0xa1519a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x00675eac in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9c46a00, th=0xa1519a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x00672e5b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9c46668, th=0xa1519a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x00675f9a in ThreadWeaver::WorkingHardState::applyForWork (this=0x9c46a00, th=0xa1519a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00672da3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9c46668, th=0xa1519a0, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x006749ce in ThreadWeaver::ThreadRunHelper::run (this=0xac01e2e4, parent=0x9c46668, th=0xa1519a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x00674a8b in ThreadWeaver::Thread::run (this=0xa1519a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x05af4da2 in QThreadPrivate::start (arg=0xa1519a0) at thread/qthread_unix.cpp:320
#13 0x00682e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x0928c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb645e720 (LWP 4422)):
[KCrash Handler]
#7  0x00c4f416 in __kernel_vsyscall ()
#8  0x091e6e71 in raise () from /lib/i386-linux-gnu/libc.so.6
#9  0x091ea34e in abort () from /lib/i386-linux-gnu/libc.so.6
#10 0x00adc0b5 in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#11 0x00ad9fa5 in ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#12 0x00ad9fe2 in std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#13 0x00ada14e in __cxa_throw () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#14 0x05ae9f85 in qBadAlloc () at global/qglobal.cpp:2019
#15 0x05b146b0 in QListData::detach_grow (this=0x9eca818, idx=0xbf9c6bd4, num=1) at tools/qlist.cpp:86
#16 0x00d8d33c in QList<QWeakPointer<QAbstractAnimation> >::detach_helper_grow (this=0x9eca818, i=2147483647, c=1) at /usr/include/qt4/QtCore/qlist.h:664
#17 0x00d8d5a1 in QList<QWeakPointer<QAbstractAnimation> >::append (this=0x9eca818, t=...) at /usr/include/qt4/QtCore/qlist.h:497
#18 0x00d8a36b in enqueue (this=0x9eca7e0, anim=0xa29cee0) at /usr/include/qt4/QtCore/qqueue.h:59
#19 Context::ContextView::addCollapseAnimation (this=0x9eca7e0, anim=0xa29cee0) at ../../src/context/ContextView.cpp:257
#20 0x00d85888 in Context::Applet::collapse (this=0x9ec48c0, on=false) at ../../src/context/Applet.cpp:320
#21 0x00d85d05 in Context::Applet::setCollapseOff (this=0x9ec48c0) at ../../src/context/Applet.cpp:279
#22 0x03f9ca37 in VideoclipApplet::trackPlaying (this=0x9ec48c0) at ../../../../../src/context/applets/videoclip/VideoclipApplet.cpp:173
#23 0x03fa0f33 in VideoclipApplet::qt_metacall (this=0x9ec48c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf9c6ef8) at ./VideoclipApplet.moc:98
#24 0x05bef6ba in QMetaObject::metacall (object=0x9ec48c0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9c6ef8) at kernel/qmetaobject.cpp:237
#25 0x05bff4ff in QMetaObject::activate (sender=0x96a7698, m=0x169ccc0, local_signal_index=3, argv=0xbf9c6ef8) at kernel/qobject.cpp:3287
#26 0x01321d23 in EngineController::trackPlaying (this=0x96a7698, _t1=...) at ./EngineController.moc:247
#27 0x01323a7c in EngineController::slotNewTrackPlaying (this=0x96a7698, source=...) at ../../src/EngineController.cpp:1140
#28 0x0132ecda in EngineController::qt_metacall (this=0x96a7698, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0xbf9c70e8) at ./EngineController.moc:205
#29 0x05bef6ba in QMetaObject::metacall (object=0x96a7698, cl=QMetaObject::InvokeMetaMethod, idx=44, argv=0xbf9c70e8) at kernel/qmetaobject.cpp:237
#30 0x05bff4ff in QMetaObject::activate (sender=0x96da0f8, m=0x81003c4, local_signal_index=7, argv=0xbf9c70e8) at kernel/qobject.cpp:3287
#31 0x080d5d33 in Phonon::MediaObject::currentSourceChanged (this=0x96da0f8, _t1=...) at ./moc_mediaobject.cpp:236
#32 0x080d68c1 in Phonon::MediaObjectPrivate::_k_currentSourceChanged (this=0x96a7890, source=...) at ../../phonon/mediaobject.cpp:599
#33 0x080d6d40 in Phonon::MediaObject::qt_metacall (this=0x96da0f8, _c=QMetaObject::InvokeMetaMethod, _id=22, _a=0xbf9c7258) at ./moc_mediaobject.cpp:145
#34 0x05bef6ba in QMetaObject::metacall (object=0x96da0f8, cl=QMetaObject::InvokeMetaMethod, idx=26, argv=0xbf9c7258) at kernel/qmetaobject.cpp:237
#35 0x05bff4ff in QMetaObject::activate (sender=0x99d8430, m=0x36e2408, local_signal_index=0, argv=0xbf9c7258) at kernel/qobject.cpp:3287
#36 0x036c9623 in Phonon::Gstreamer::MediaObject::currentSourceChanged (this=0x99d8430, _t1=...) at ./moc_mediaobject.cpp:212
#37 0x036d0da0 in Phonon::Gstreamer::MediaObject::setSource (this=0x99d8430, source=...) at ../../gstreamer/mediaobject.cpp:1045
#38 0x080d3e6d in Phonon::MediaObject::setCurrentSource (this=0x96da0f8, newSource=...) at ../../phonon/mediaobject.cpp:261
#39 0x013244b1 in EngineController::playUrl (this=0x96a7698, url=..., offset=109310) at ../../src/EngineController.cpp:526
#40 0x01325e04 in EngineController::play (this=0x96a7698, track=..., offset=109310) at ../../src/EngineController.cpp:428
#41 0x013268ba in EngineController::restoreSession (this=0x96a7698) at ../../src/EngineController.cpp:323
#42 0x0130db4a in App::continueInit (this=0xbf9c78e4) at ../../src/App.cpp:661
#43 0x0130e652 in App::App (this=0xbf9c78e4) at ../../src/App.cpp:186
#44 0x08054e83 in main (argc=) at ../../src/main.cpp:287

Reported using DrKonqi
Comment 1 Bogdan Udrescu 2011-11-29 13:43:18 UTC
I think you should post all the applications you used to customize it. I consider it an external issue due to them.
Comment 2 Myriam Schweingruber 2011-11-29 16:56:15 UTC
This is already solved in the upcoming Amarok 2.5

*** This bug has been marked as a duplicate of bug 258741 ***