Bug 287685 - Message list does not reflect folder after using folder filter box.
Summary: Message list does not reflect folder after using folder filter box.
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: Git (master)
Platform: Compiled Sources Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 297136 313369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-27 15:23 UTC by Luis Silva
Modified: 2013-02-26 22:59 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Silva 2011-11-27 15:23:16 UTC
Version:           Git (master) (using KDE 4.7.3) 
OS:                Linux

The title says it all. If you use the filter box above the folder list the message list will only reflect the contents of the last selected folder. This can cause data loss if acting on emails after this bug was triggered.

Reproducible: Always

Steps to Reproduce:
1. Select any folder in the folder list.
2. Use the filter box to search for a different folder.
3. Click on the folder you were searching for.

Actual Results:  
The message list will show only the messages from the folder selected in 1. and not the messages in the active folder.

Expected Results:  
Whe an folder is selected, the message list should reflect the content of that folder.

OS: Linux (i686) release 3.0.0-14-generic
Compiler: gcc
Comment 1 Luis Silva 2012-05-29 21:40:13 UTC
Bug still present in master.
Comment 2 Philipp Woelfel 2012-08-03 15:49:35 UTC
This bug is still present in KDE 4.9.
Comment 3 Laurent Montel 2012-08-03 15:56:01 UTC
? I don't understand 
you click on specific folder and it's updated no ?
Comment 4 Laurent Montel 2012-08-03 15:59:09 UTC
Ah it doesn't clean selection.
Comment 5 Philipp Woelfel 2012-08-03 20:40:51 UTC
I'm a bit confused by the original bug report. Here is what happens on my system: 

If I enter something in the *folder* filter (the one that is by default not turned out, but you can turn it on in the preferences), the *message* list gets "corrupted". I.e., after selecting a new folder from the ones that are still visible when the filter is on, the messages that are shown in the message list do not correspond to the selected folder. Sometimes, the message list seems to show a mix of messages from the selected folder and some other folder (the one that was active before I entered something in the filter field). This behavior does not change even once I clear the filter. The only way to get back to a normal behavior is by restarting kmail2.
Comment 6 Laurent Montel 2012-08-14 16:23:13 UTC
*** Bug 297136 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Wrana 2012-08-29 14:31:15 UTC
I can confirm the behavior exactly as Philipp describes it in #5 on Kubuntu 12.04 with original kde sc and also still same behavior with the kde sc 4.9 backports
Comment 8 Laurent Montel 2012-08-29 14:41:50 UTC
I can reproduce this bug and already investigate it.
it's on my todo list.
Not success yet to fix it
Comment 9 Luis Silva 2012-12-26 18:13:01 UTC
Confirmed as per Comment #8
Comment 10 Luis Silva 2013-01-28 11:07:36 UTC
*** Bug 313369 has been marked as a duplicate of this bug. ***
Comment 11 Martin Koller 2013-02-26 11:18:44 UTC
Git commit c87b460d62dbb9c59070e63bfc05deb87a59a14f by Martin Koller.
Committed on 26/02/2013 at 12:10.
Pushed by mkoller into branch 'KDE/4.10'.

make sure the messagelist only shows selected folders

When the folder tree is filtered and the currently shown folder is
now no longer in the folder tree, the automatic deselection did not work
because the hidden folders were set to not-selectable and not-enabled,
but QItemSelection can only deselect selectable and enabled items.
This led to the problem that we saw the old selected folder and any
newly selected folder intermixed in the messagelist.
Related: bug 314457

M  +0    -6    mailcommon/foldertreewidgetproxymodel.cpp

http://commits.kde.org/kdepim/c87b460d62dbb9c59070e63bfc05deb87a59a14f
Comment 12 Alexandre Bonneau 2013-02-26 22:59:36 UTC
Nice ! This was a very annoying bug, I'm eager to try the next Kmail version.

Thank you again :)