Bug 287629 - Inconsistent error message in Java-Script confirmation
Summary: Inconsistent error message in Java-Script confirmation
Status: RESOLVED UPSTREAM
Alias: None
Product: i18n
Classification: Translations
Component: de (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: German-Translators
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-26 18:32 UTC by Christian Trippe
Modified: 2012-01-12 21:33 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the dialog (46.59 KB, image/png)
2011-11-26 18:32 UTC, Christian Trippe
Details
screenshot (27.64 KB, image/png)
2011-11-26 22:40 UTC, Burkhard Lück
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Trippe 2011-11-26 18:32:24 UTC
Created attachment 66101 [details]
Screenshot of the dialog

Version:           unspecified (using KDE 4.7.2) 
OS:                Linux

After having browsed a site and left konqueror open for a while I got a message for "Javscript Bestätigung"

The text of the message, to be precise the named options" are not consitent with the button labels

Text:
Ihre Session ist abgelaufen. Für die Weiterbenutzung des Dienstes wird empfohlen, eine neue Session zu erzeugen.
Möchten Sie eine neue Session erzeugen, klicken Sie bitte »OK«, sonst »Abbrechen«.

Button labels "Ja" and "Nein"

So probably the button labels should be "OK" and "Abbrechen". I am not sure if this is really a translation problem or this also exists in English.

Adding a screenshot of the dialog.



Reproducible: Didn't try

Steps to Reproduce:
Go to www.deichmann.com.
Search for a shop
Wait some time

Actual Results:  
see above

Expected Results:  
consitent text Text consistent with button labels.
Comment 1 Burkhard Lück 2011-11-26 20:41:10 UTC
(In reply to comment #0)
> 
> After having browsed a site and left konqueror open for a while 

Browser module ? KHTML / Webkit? (Menü Ansicht->Anzeigemodus)

> 
> The text of the message, to be precise the named options" are not consitent
> with the button labels
> 
> Text:
> Ihre Session ist abgelaufen. Für die Weiterbenutzung des Dienstes wird
> empfohlen, eine neue Session zu erzeugen.
> Möchten Sie eine neue Session erzeugen, klicken Sie bitte »OK«, sonst
> »Abbrechen«.
> 
No hit in trunk/branch 4.7:
$ wcgrep "Weiterbenutzung" l10n-kde4/de/messages/
> 
> Steps to Reproduce:
> Go to www.deichmann.com.
> Search for a shop
> Wait some time
> 
What is "Search for a shop"? How long to wait?
Comment 2 Christian Trippe 2011-11-26 21:00:17 UTC
(In reply to comment #1)
> (In reply to comment #0)
> Browser module ? KHTML / Webkit? (Menü Ansicht->Anzeigemodus)

Webkit (as it is the default since KDE 4.7.2)
 
> > Steps to Reproduce:
> > Go to www.deichmann.com.
> > Search for a shop
> > Wait some time
> > 
> What is "Search for a shop"? How long to wait?

Use "Filialfinder" in the top davigation bar and then search for shops near a location of your choice. Then wait for 10-15 minutes.
Comment 3 Burkhard Lück 2011-11-26 22:39:52 UTC
(In reply to comment #2)
> 
> Webkit (as it is the default since KDE 4.7.2)
> 
Building kde from sources KHTML is default, so your default is a apparently a distribution (SuSe) default.


> Use "Filialfinder" in the top davigation bar and then search for shops near a
> location of your choice. Then wait for 10-15 minutes.

Thanks for providing the steps to reproduce this issue. Using KHTML I get the same error text with the Button labels "OK" and "Abbrechen".

The german team does not use ">>", so thi si a downstream issue
Comment 4 Burkhard Lück 2011-11-26 22:40:47 UTC
Created attachment 66107 [details]
screenshot
Comment 5 Frederik Schwarzer 2011-11-27 10:00:36 UTC
I wanted to test it but here Konqueror just closes when the "Filialfinder" was started before I can even inser info in one of the fields.
Comment 6 Frederik Schwarzer 2011-11-27 11:08:18 UTC
Ok, habe es jetzt gesehen. Ist definitiv nicht unsere Übersetzung. "Session" übersetzen wir mit Sitzung.

Google gibt mir auch keine Information, wo der String her kommt.

Am besten hier mal probieren: http://old-de.opensuse.org/Distributionslokalisierungs-Team
Comment 7 Christian Trippe 2011-11-27 18:07:01 UTC
First thanks for your quick response and your help.

I have reported this now at https://bugzilla.novell.com/show_bug.cgi?id=732921

(In reply to comment #3)
> Building kde from sources KHTML is default, so your default is a apparently a
> distribution (SuSe) default.

Here I just wanted to give you the reason why I think this statement (only SUSE default) is not completly right (it seems to depend on the release of kwebkitpart), see https://bugzilla.novell.com/show_bug.cgi?id=726198#c6 
However you might still use khtml in konqueror, if you have an old home because of ~/.kde4/share/apps/konqueror/profiles/webbrowsing making konqueror still use khtml (happend to me at first)
Comment 8 Frederik Schwarzer 2011-11-29 18:41:39 UTC
Yep. You might be right. We will investigate this further to find out, how to fix it.

The error message comes from the website, so nothing we can do. However, 
http://www.javascripter.net/faq/confirm.htm indicates, that these boxes should have an "OK" and a "Cancel" button and not "yes" and "no".

Johannes, how is the status here?
Comment 10 Johannes Obermayr 2012-01-12 21:33:30 UTC
I assume it is a WONTFIX:
https://bugs.webkit.org/show_bug.cgi?id=76190

Spending hours of my life to fail on such stupid rules ...

Adding three KDE people with permissions to commit to WebKit.